Page 1 of 2

Mint VM aborts with 5.0.12

PostPosted: 21. Dec 2015, 14:23
by bernieh
A Linux Mint 17.3 vm which runs under vb 5.0.10 immediately aborts after upgrading to vb 5.0.12. The mint window only appears for an instant. This is on Solaris 10 1/13. Downgrading to vb 5.0.10 allows the vm to start and function as before. Attached is the log of a failed start with vb 5.0.12.

Re: Mint VM aborts with 5.0.12

PostPosted: 21. Dec 2015, 14:59
by socratis
Your log file ends prematurely. Shut down the VM all the way and then zip and attach the log.

Re: Mint VM aborts with 5.0.12

PostPosted: 21. Dec 2015, 16:26
by bernieh
I cannot shutdown the vm. It aborts almost immediately when attempting to start it. I do not even see the prompt to enter the pass-phrase to decrypt the (mint encrypted) disk. It is aborting very early in the boot process.

Re: Mint VM aborts with 5.0.12

PostPosted: 22. Dec 2015, 17:44
by Ramshankar
Could you please provide the core dump when the VM aborts?

Check this link on how to setup core dumps for VirtualBox on Solaris hosts https://www.virtualbox.org/wiki/Core_dump

Re: Mint VM aborts with 5.0.12

PostPosted: 22. Dec 2015, 21:50
by bernieh
I have a core dump (34MB bzip2) but I haven't been able to attach it. I guess my upload speed is too slow. Is there any other way to send it to you?

Re: Mint VM aborts with 5.0.12

PostPosted: 23. Dec 2015, 10:29
by michaln
Do you have Dropbox or similar?

Re: Mint VM aborts with 5.0.12

PostPosted: 23. Dec 2015, 16:34
by Ramshankar
Even if you can't send the whole core dump immediately, can you attach output of:

Code: Select all   Expand viewCollapse view
pstack <corefile-in-question>

Re: Mint VM aborts with 5.0.12

PostPosted: 23. Dec 2015, 21:00
by bernieh
Attached is the pstack. I won't be able to do anything more with this until next week.

Re: Mint VM aborts with 5.0.12

PostPosted: 25. Dec 2015, 09:00
by Capouch
I can confirm this same behavior--in several wild variations, on Slackware Linux. It's a mess! It seems as if you do an install from an ISO on a 5.0.12 instance, then that instance will be able to use it just fine. But if you export the box and move it to a separate instance of 5.0.12 it not only crashes like this on boot, but stops everyone else then from booting as well.

I have been in general hell for the past couple of days since upgrading several host machines to this version.

I reverted to 5.0.10 and all is well again. I hate to invite any flaming, but this isn't the first time a new version came with nasty surprises.

Re: Mint VM aborts with 5.0.12

PostPosted: 25. Dec 2015, 21:19
by michaln
Capouch wrote:I reverted to 5.0.10 and all is well again. I hate to invite any flaming, but this isn't the first time a new version came with nasty surprises.

It's not the last time either. Exercise caution when upgrading.

Re: Mint VM aborts with 5.0.12

PostPosted: 24. Jan 2016, 15:53
by bernieh
bernieh wrote:I have a core dump (34MB bzip2) but I haven't been able to attach it. I guess my upload speed is too slow. Is there any other way to send it to you?


The core dump is at https://www.dropbox.com/s/jyegrpayb0et8 ... 9.bz2?dl=0

Re: Mint VM aborts with 5.0.12

PostPosted: 25. Jan 2016, 12:08
by michaln
Thank you for the core dump. Please note that it will probably take a few days before someone is available to look at it.

Re: Mint VM aborts with 5.0.12

PostPosted: 2. Feb 2016, 18:41
by Ramshankar
Had a look at the core. The problem is with the ICH AC97 Audio device code. However, there have been fixes in this area. I suggest you please try with 5.0.14 and report here if the problem persists.

Re: Mint VM aborts with 5.0.12

PostPosted: 2. Feb 2016, 23:47
by bernieh
The booting problem is gone. It boots fine and even shuts down without the long pause that existed in the last few 5.0.x releases. The sound doesn't actually work from the linux guest but that has been the case with (all?) the 5.0.x releases. Thanks.

Re: Mint VM aborts with 5.0.12

PostPosted: 3. Feb 2016, 11:54
by pentagonik
Can you please post a recent VBox.log running that guest which has no audio? Thanks.