VirtualBox 4.2.6 on Solaris 11.1 SRU 2.5

Discussions related to using VirtualBox on Solaris hosts.

VirtualBox 4.2.6 on Solaris 11.1 SRU 2.5

Postby jailbird » 27. Dec 2012, 07:51

Brand new VBox 4.2.6 install on an up-to-date Solaris 11.1 SRU 2.5 install.

Trying to startup a Windows 2012 VM. DVD is an .iso, HDD is a ZVOL. Both are attached to a SATA controller w/ Host I/O Caching enabled.

$ VBoxManage startvm "Windows 2012" --type headless
Waiting for VM "Windows 2012" to power on...
VM "Windows 2012" has been successfully started.

However it doesn't really start. The logfile has:

Log created: 2012-12-27T05:50:33.570871000Z
Executable: /opt/VirtualBox/amd64/VBoxHeadless
Arg[0]: /opt/VirtualBox/amd64/VBoxHeadless
Arg[1]: --comment
Arg[2]: Windows 2012
Arg[3]: --startvm
Arg[4]: c2cefc7a-0fdc-4bfd-b02d-8c93095fd5ed
Arg[5]: --vrde
Arg[6]: config
internal REM fatal error: rc=VERR_GENERAL_FAILURE TCG fatal error: /home/vbox/tinderbox/4.2-sol-rel/src/recompiler/tcg/i386/tcg-target.c:514
internal REM fatal error: rc=VERR_GENERAL_FAILURE TCG fatal error: /home/vbox/tinderbox/4.2-sol-rel/src/recompiler/tcg/i386/tcg-target.c:514

Any ideas?
jailbird
 
Posts: 3
Joined: 15. Dec 2008, 19:58

Re: VirtualBox 4.2.6 on Solaris 11.1 SRU 2.5

Postby jailbird » 27. Dec 2012, 19:40

Okay, it's working now. I had switched ASLR from the default of tagged binaries only to always on. VirtualBox doesn't seem to like ASLR. Reverted ASLR back to default, and it appears to be working now!
jailbird
 
Posts: 3
Joined: 15. Dec 2008, 19:58

Re: VirtualBox 4.2.6 on Solaris 11.1 SRU 2.5

Postby Clive45 » 10. Jan 2013, 15:59

I do wish ORACLE would smarten up on some of these known issues. Given that USB functionality is so important to users, I would have had these issues flagged up for users much earlier. I have been struggling to get USB working for over a week now, and still no luck.

ORACLE Solaris 11.1 (Fresh install)
VBox 4.2.6 plus extensions etc.
Guest OS is Win XP with SP3 and all the latest patches.
I have checked, ie added the USB 2 EHCI etc.

Yet I still cannot get USB working.
Clive45
 
Posts: 14
Joined: 14. Mar 2010, 14:50
Primary OS: MS Windows XP
VBox Version: OSE self-compiled
Guest OSses: Linux

Re: VirtualBox 4.2.6 on Solaris 11.1 SRU 2.5

Postby Guyver » 11. Jan 2013, 18:16

@ Clive45 - please start a new thread, give details to your issues - what isn't working, are there any error messages, any VBox logs that show errors? etc...

Thread hijacking with generic issue rants won't allow anyone to assist.

I know I am one of the people with USB issues in that the VM appears to constantly drop and re-grab the usb devices making them unusable, and have several threads related to that issue.
USB issues do not appear to be widespread, and as such do not take a high priority.

The more users with the issues, and separate threads detailing them, the higher the chances of getting time allocated by Oracle to research and fix.
Guyver
 
Posts: 103
Joined: 11. Feb 2012, 06:19
Location: Central United States
Primary OS: Solaris
VBox Version: PUEL
Guest OSses: Windows 7


Return to VirtualBox on Solaris Hosts

Who is online

Users browsing this forum: No registered users and 1 guest