RDP encryption

Discussions related to using VirtualBox on Solaris hosts.

RDP encryption

Postby Carlos Azevedo » 3. Jul 2012, 19:25

Hello,

I have followed all the steps on the online manual in order to set RDP encryption using OpenSSL generated keys and certificates.
I have also forced "Security/Method" to TLS and I can connect without problems.
My RDP client is rdesktop 1.6.0 from Solaris 11 SRU 7.5.

My dobut is:

When I check the output of "VBoxManage showvminfo vm --details" it still shows me "Encription: RDP4".
Please note that I can never connect with "rdesktop -4", only "rdesktop -5", of course, which seems OK.
But then why showvminfo insists on showing "Encryption: RDP4"?
Shouldn't it be something else, such as RDP5 or TLS?
Did I miss something or is it a bug?

Here's what I believe to be the relevant part of the log:
00:00:33.731 VRDP: New connection:
00:00:33.740 VRDP: Methods 0x00000003
00:00:33.740 VRDP: Channel: [cliprdr] [1004]. Accepted.
00:00:33.745 VRDP: Client seems to be rdesktop.
00:00:33.745 VRDP: Logon: client1 (X.Y.Z.W) build 2600. User: [user1] Domain: [] Screen: 0
00:00:33.747 AUTH: User: [user1]. Domain: []. Authentication type: [External]
00:00:33.748 AUTH: ConsoleVRDPServer::Authenticate:
loading external authentication library 'VBoxAuthSimple' <== I guess my problem may be due to this...
00:00:33.748 AUTH: Using entry point 'AuthEntry'.
00:00:33.751 AUTH: external authentication module returned 'access granted'
00:00:33.751 AUTH: Access granted.
00:00:33.761 VBVA: VRDP acceleration has been requested.
00:00:33.861 VRDP: SunFlsh disabled.
00:00:33.861 RDPDR disabled.
00:01:59.596 VRDP: Received the Disconnect Request packet.
00:01:59.596 VRDP: Connection closed:
00:01:59.596 VRDP: Logoff: client1 (X.Y.Z.W) build 2600. User: [user1] Domain: [] Reason 0x0001.
00:01:59.596 VBVA: VRDP acceleration has been disabled.


Would that mean that if I choose VBoxAuthSimple I give up enhanced security?
But it seems Solaris has no other authentication method... does it?

Thanks in advance,
Carlos.
Carlos Azevedo
 
Posts: 14
Joined: 3. Jul 2012, 19:02

Re: RDP encryption

Postby Alan_K » 2. Feb 2017, 00:23

Two things I would check as it seems maybe this version doesn't know what the TLS is. Looks like it granted access then didn't know how to proceed and shutdown the connection. Try it with stand ssl and see if it works then try to find were your version ids the encryption "type". I think you are probably already there by the time you read this post as you are close.
Alan_K
 
Posts: 1
Joined: 2. Feb 2017, 00:18

Re: RDP encryption

Postby socratis » 2. Feb 2017, 07:15

One thing I would check is the date. And this is long dead... Time to put it to rest...

Topic posted: 2012-07-03, 19:25
Original Poster last visited: 2013-12-27, 12:50
Topic locked: 2017-02-02, 07:15
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 12658
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to VirtualBox on Solaris Hosts

Who is online

Users browsing this forum: No registered users and 1 guest