VB 4.1.6 on Solaris 11 11/11 - USB Devices

Discussions related to using VirtualBox on Solaris hosts.

Re: VB 4.1.6 on Solaris 11 11/11 - USB Devices

Postby Ramshankar » 9. Dec 2011, 21:56

Hm, you sure that that's the correct log for the VM? Just making sure, because the USB controller will definitely log to the VBox.log when USB devices are plugged into the VM with the device and vendor ID.
Oracle Corp.
Ramshankar
Oracle Corporation
 
Posts: 636
Joined: 7. Jan 2008, 16:17

Re: VB 4.1.6 on Solaris 11 11/11 - USB Devices

Postby guyverdh » 13. Dec 2011, 20:23

I built out a new VirtualBox instance, running Windows XP SP3 - no corporate stuff installed, bare bones WinXP.
Same issue with USB devices showing up, disappearing.
Considering re-building the OS on the laptop from the ground up, but would prefer to keep that as a last ditch effort.

I can wait until you have a debug'd version available to test with.

I will do some additional boots and get the log files uploaded to show the devices. From what I can tell, they get captured, show in the vbox log files. I can't say that I see them disappearing by the log file.
Watching the Bluetooth icon in the lower right hand corner flip to red center, then back to white, back to red, back to white (with the usb attach / detach noise) is pretty straight forward.
guyverdh
 
Posts: 25
Joined: 7. Jan 2011, 23:02
Primary OS: Solaris
VBox Version: PUEL
Guest OSses: Windows XP 32Bit

Re: VB 4.1.6 on Solaris 11 11/11 - USB Devices

Postby Ramshankar » 14. Dec 2011, 16:11

Yes, I wouldn't expect the disappearing devices to get logged in the VBox.log file, but the VBox.log for such a session (with the device being captured) would still be interesting. Also, I suppose there is nothing interesting happening /var/adm/messages either? If the VBoxUSB driver notices something funny, it -might- log something in there (not sure if I already asked you this, in which case ignore it).
Oracle Corp.
Ramshankar
Oracle Corporation
 
Posts: 636
Joined: 7. Jan 2008, 16:17

Re: VB 4.1.6 on Solaris 11 11/11 - USB Devices

Postby guyverdh » 14. Dec 2011, 20:26

I'm attaching the latest VBox.log file from a session where the USB Broadcomm (internal to the laptop) goes away and comes back.
As expected nothing shows up that pinpoints this activity.
Also, nothing from the /var/adm/messages file indicates the device going away from the OS level.
I've been tempted to try it with the EHCI (2.0) disabled, and reverting to USB 1.0 spec just for grins (assuming that's what would happen if I unchecked the EHCI 2.0 box).
Attachments
VBox.log
(76.3 KiB) Downloaded 10 times
guyverdh
 
Posts: 25
Joined: 7. Jan 2011, 23:02
Primary OS: Solaris
VBox Version: PUEL
Guest OSses: Windows XP 32Bit

Re: VB 4.1.6 on Solaris 11 11/11 - USB Devices

Postby guyverdh » 14. Dec 2011, 20:46

I did give that option a go, and it made zero difference. The USB Bluetooth adapter still continued to flip / flop available / unavailable.
guyverdh
 
Posts: 25
Joined: 7. Jan 2011, 23:02
Primary OS: Solaris
VBox Version: PUEL
Guest OSses: Windows XP 32Bit

Re: VB 4.1.6 on Solaris 11 11/11 - USB Devices

Postby bqbauer » 15. Dec 2011, 04:15

Do you have any other computer on which you could install Solaris 11 for even a short time? After your experiences so far, I still wonder if it's an issue with Solaris on your hardware. Maybe the USB support is only 90% there with the Lenovo. If the laptop has an esata port, maybe you could borrow/buy a disk & dock to do a temporary clean install, or mirror your internal to an external for safe keeping.

My new desktop wouldn't work with Solaris Express 2010.11, and VB would hose it completely. In comes Solaris 11, and everything is solved (another thread here). Maybe you're having a similar issue with the laptop & Solaris 11--something's just a little off. Did you upgrade to Solaris 11, or was it a clean install? I've seen imperfect [Open]Solaris upgrades, so I suppose if you did an upgrade from any previous release something could be wonky.

Just throwing out ideas. Don't know what resources you can get your hands on.
bqbauer
 
Posts: 123
Joined: 14. Dec 2008, 22:04

Re: VB 4.1.6 on Solaris 11 11/11 - USB Devices

Postby guyverdh » 15. Dec 2011, 19:08

I'm not as concerned about the disk as I am things like the blackberry, or bluetooth connections.

I've submitted the parts list in this or a previous thread that are included in the Lenovo. All the components check out as supported (regarding the usb, bluetooth) - there are a few Intel pieces that aren't.

Intel Corporation 5 Series/3400 Series Chipset
HECI Controller
HECI_Controller.txt
(1.24 KiB) Downloaded 11 times

Thermal Subsystem
Thermal_Subsystem.txt
(1.24 KiB) Downloaded 8 times

KT Controller
KT_Controller.txt
(1.34 KiB) Downloaded 9 times


Those are the only 3 things that show as unsupported / no drivers.
guyverdh
 
Posts: 25
Joined: 7. Jan 2011, 23:02
Primary OS: Solaris
VBox Version: PUEL
Guest OSses: Windows XP 32Bit

Re: VB 4.1.6 on Solaris 11 11/11 - USB Devices

Postby guyverdh » 15. Dec 2011, 19:09

The 2 Chipset USB2 Enhanced Host Controllers show bound to the ehci device.

#1 -
USB2_Enhanced_Host_Controller_1.txt
(1.86 KiB) Downloaded 11 times

#2 -
USB2_Enhanced_Host_Controller_2.txt
(1.86 KiB) Downloaded 4 times
guyverdh
 
Posts: 25
Joined: 7. Jan 2011, 23:02
Primary OS: Solaris
VBox Version: PUEL
Guest OSses: Windows XP 32Bit

Re: VB 4.1.6 on Solaris 11 11/11 - USB Devices

Postby guyverdh » 4. Jan 2012, 20:58

Just checking in. I see the files I uploaded have been downloaded, so I assume they're being reviewed.
guyverdh
 
Posts: 25
Joined: 7. Jan 2011, 23:02
Primary OS: Solaris
VBox Version: PUEL
Guest OSses: Windows XP 32Bit

Re: VB 4.1.6 on Solaris 11 11/11 - USB Devices

Postby guyverdh » 24. Jan 2012, 20:35

Any word on the debug code to try and solve the issue? Or driver updates to allow the Intel chipset USB to work properly, without disconnecting/reconnecting?
guyverdh
 
Posts: 25
Joined: 7. Jan 2011, 23:02
Primary OS: Solaris
VBox Version: PUEL
Guest OSses: Windows XP 32Bit

Re: VB 4.1.6 on Solaris 11 11/11 - USB Devices

Postby guyverdh » 24. Jan 2012, 20:36

Note: 4.1.8 made no difference in the issue.
guyverdh
 
Posts: 25
Joined: 7. Jan 2011, 23:02
Primary OS: Solaris
VBox Version: PUEL
Guest OSses: Windows XP 32Bit

Re: VB 4.1.6 on Solaris 11 11/11 - USB Devices

Postby Ramshankar » 25. Jan 2012, 16:50

There have been other complaints of well working devices not working properly under Solaris 11 with VirtualBox. It could be some Solaris side change as pretty much nothing core USB related changed in VirtualBox between 4.1.x and 4.1.8. I'm upgrading my box to Solaris 11 175 (update 1, 7) as I write and once I get VirtualBox build issues sorted out, I can start testing this myself. I cannot test your specific device, but I plan to start with viewtopic.php?f=11&t=47304 (iPhone doesn't work on S11). It definitely works here on my snv_166 and is something I can test easily right in my office, after my dev. box upgrade and I'll if it's a generic S11 breakage or kernel regression or some other issue.
Oracle Corp.
Ramshankar
Oracle Corporation
 
Posts: 636
Joined: 7. Jan 2008, 16:17

Re: VB 4.1.6 on Solaris 11 11/11 - USB Devices

Postby Ramshankar » 7. Feb 2012, 21:40

Still working on https://forums.virtualbox.org/viewtopic ... 11&t=47304 and it -could- be something in Solaris 11 itself. At this point my snv_161 internal build seems solid with no device disconnects. Sorry this seems like it might take sometime to fully investigate and fix because it might spam multiple teams (VBox, solaris USB, solaris kernel/power management/whatever).
Oracle Corp.
Ramshankar
Oracle Corporation
 
Posts: 636
Joined: 7. Jan 2008, 16:17

Re: VB 4.1.6 on Solaris 11 11/11 - USB Devices

Postby Guyver » 11. Feb 2012, 06:22

Glad to read that there appears to be some leads on where the problem is. The worst ones often are the hardest to find.
Good luck, and I'll keep checking in.
If you need me to do anything or test anything let me know.
Thanks.
Guyver
 
Posts: 62
Joined: 11. Feb 2012, 06:19
Location: Central United States
Primary OS: Solaris
VBox Version: PUEL
Guest OSses: Windows 7

Re: VB 4.1.6 on Solaris 11 11/11 - USB Devices

Postby justus » 9. Aug 2012, 10:22

Topic: vboxuser numeric group ID changed, VirtualBox does not want to forget the old one.

I am running two boot environments (Solaris 11 and openindiana) as server, Linux NFS clients and VirtualBox with 3 different guests in both server BEs. Over all this, I maintain identical user IDs and identical numeric IDs for e.g. the group "users", to avoid complications.

In this spirit, I also changed the numeric value for vboxuser in one of the BEs from 100 to 1001, to have the same numeric ID in both BEs. As expected, thereafter USB was not available from any guest of that BE.
I then uninstalled VirtualBox, uninstalled the extension pack, reinstalled both in that BE, and reinstalled the guest additions in the test guest. But USB stayed unavailable in the guests until setting back vboxuser to 100 in that BE.
What should I remove/modify, that VirtualBox will forget about the numeric vboxuser ID?
justus
 
Posts: 5
Joined: 9. Aug 2012, 08:57

PreviousNext

Return to VirtualBox on Solaris Hosts

Who is online

Users browsing this forum: No registered users and 2 guests