VB 4.1.x freezes on Q67 host

Discussions related to using VirtualBox on Solaris hosts.

VB 4.1.x freezes on Q67 host

Postby bqbauer » 21. Aug 2011, 06:25

I just got a new computer for work, a Dell OptiPlex 990 with the Q67 chipset, i7-2600 CPU, and 16GB memory. Solaris Express recognizes & works with everything except the new Intel ethernet chip. Everything went great until I installed VB 4.1.2. When it starts to load the kernel modules during the initial VB install, the whole system freezes & I have to power it off. About 1-2 tries in a dozen succeeds in installing the kernel modules & then VB works fine for that boot of the host. However, upon rebooting the host, it stops yet again when it loads the VB kernel modules at boot time. If I boot from the LiveCD & remove VB, the problem goes away. I've started over with a new install of Solaris Express and have duplicated the problem now with two fresh installs.

The host BIOS has VT-d support, which I've turned off & on with no difference. I run VB 4.1.2 on two other Solaris Express hosts, including one with the X58 chipset & an i7-920. Seems the Q67 interacting with the VB modules might be a bad mix? Have any developers had a chance to test this with build 151? How about a newer internal build that might better support the Q67 chipset? I'm hoping this problem solves itself when Solaris 11 is released. It would be nice to know if this problem exists or is solved with any internal builds. I've also tested with VB 4.1.0, but nothing older (yet).

I know this is a mixed bag of information, but I'm hoping it sparks something that a developer might recognize.
bqbauer
 
Posts: 151
Joined: 14. Dec 2008, 22:04

Re: VB 4.1.x freezes on Q67 host

Postby bqbauer » 21. Aug 2011, 09:38

Just tested with VB 4.0.12. No problem. Whatever is doing this, it's unique to VB 4.1.x. Help, fix please! Don't want to be stuck without the ability to upgrade. Since everything freezes or crashes, I don't know what logs I can offer, but will do what I can.
bqbauer
 
Posts: 151
Joined: 14. Dec 2008, 22:04

Re: VB 4.1.x freezes on Q67 host

Postby Ramshankar » 21. Aug 2011, 14:03

What was changed is MP notification support.

Could you open a bug ticket with the relevant information (including psrinfo output, host OS versions, anything in /var/adm/messages).
Oracle Corp.
Ramshankar
Oracle Corporation
 
Posts: 780
Joined: 7. Jan 2008, 16:17

Re: VB 4.1.x freezes on Q67 host

Postby hsfoer » 5. Oct 2011, 10:23

Hello,

looks like that I have the same problem.

Using Sol 11 Express on Acer Aspire 7750G (I7, i7-2630QM, only ATGE is the "free" one)

I'm running older versions of virtualbox (last 4.0.12), seeing no problems.

Today I've tried 4.1.4 and during installation of the modules (pkadd) the hole system freezes ;-(

Removing new one, install the old one, system run's fine.

Have you open a BUG?

Hans Foertsch
hsfoer
 
Posts: 5
Joined: 18. Nov 2009, 13:25
Primary OS: OpenSolaris 11
VBox Version: OSE other
Guest OSses: Windows etc.

Re: VB 4.1.x freezes on Q67 host

Postby Ramshankar » 6. Oct 2011, 18:49

Oracle Corp.
Ramshankar
Oracle Corporation
 
Posts: 780
Joined: 7. Jan 2008, 16:17

Re: VB 4.1.x freezes on Q67 host (fixed in Solaris 11?)

Postby bqbauer » 29. Nov 2011, 22:51

I originally created this post, and I wanted to follow up.

Initially, I found that disabling C State Control in the BIOS fixed the problem, although I found the host networking would die if I ever used bridged networking with a guest. Then 4.1.4 was released, and the lockup problem resurfaced; no matter what I did and I could not resolve it. I backed down to 4.0.x, but this version also had problems on the host with bridged networking. So I worked only with NAT networking for now. I've been using VB for years, and never with oddball problems like this on any Solaris version. I decided to wait for Solaris 11 before bothering with this again.

So, enter Solaris 11. I did a clean install of Solaris along with all the same packages I was using in Solaris 11 Express. I installed VB 4.1.6 with no problems. Rebooted a few times--no problems! Went into the BIOS and enabled C States. No problems! Note that I had done several clean installs of Solaris Express, and the problem was 100% reproducible on this host.

So far, Solaris 11 has fixed every quirky issue I had with VB 4.1.x on this semi-cutting edge system/chipsets. My system is flying once again, VB guests work great, all features are available to me.
bqbauer
 
Posts: 151
Joined: 14. Dec 2008, 22:04


Return to VirtualBox on Solaris Hosts

Who is online

Users browsing this forum: No registered users and 1 guest