Daily crashes with Vbox 4 - Win7-64 on OSOL134

Discussions related to using VirtualBox on Solaris hosts.

Daily crashes with Vbox 4 - Win7-64 on OSOL134

Postby bayoda » 27. Dec 2010, 08:50

Hi

My 3.2.12 Virtualbox was really stable. No Crashes at all.
I installed VBox 4 on OSOL 134 some days ago (when it was available) and since this time:
Every morning I came to the office - my Win7-64 is gone. Hard Crash / freezed - doesn't mather - it's away...

I attach the VBoxLog here maybe it helps - tried every thing to "turn" but nothing really helped...

Maybe some other has the same problem and know how to fix it? or is downgrade the only possbility :(

greetings

Michael
Attachments
win764pro-2010-12-26-21-47-48.log.zip
(34.28 KiB) Downloaded 32 times
bayoda
 
Posts: 8
Joined: 15. Jun 2009, 23:35
Primary OS: OpenSolaris 11
VBox Version: PUEL
Guest OSses: WindowsXP / Windows7

Re: Daily crashes with Vbox 4 - Win7-64 on OSOL134

Postby Alekz » 2. Jan 2011, 22:16

I have exactly the same problem. Win7 freezes, but "top" shows very high CPU usage (from 30% to 48%). No "resets" work. The only solution is to kill all VB processes and start again.
Alekz
 
Posts: 3
Joined: 2. Jan 2011, 22:13
Primary OS: Solaris
VBox Version: OSE other
Guest OSses: Windows 7 x64

Re: Daily crashes with Vbox 4 - Win7-64 on OSOL134

Postby garyd » 3. Jan 2011, 20:02

I have the same problem with Solaris 11 Express 11/10. Usually my first step to troubleshoot such issues is to turn off VT-x/AMD-V but when you're running a 64-bit guest that's apparently not an option. I'm tempted to install a 32-bit version of Windows to see if that helps. Has anyone had similar issues with it? What kind of host hardware are you using? I'm running on an aging Sun Ultra 20 workstation but it's got four gigabytes of RAM with two dedicated to my guest. My crashes happen much more often than daily, however.

-Gary
garyd
 
Posts: 1
Joined: 3. Jan 2011, 19:49
Primary OS: Solaris
VBox Version: OSE other
Guest OSses: Windows 7

Re: Daily crashes with Vbox 4 - Win7-64 on OSOL134

Postby gerard » 4. Jan 2011, 17:31

I have the same problem on redhat 5.5. Any solutions?
I running win 64 2008 R2.
gerard
 
Posts: 4
Joined: 4. Jan 2011, 17:27
Primary OS: Linux other
VBox Version: OSE other
Guest OSses: Win 2k8 64 R2

Re: Daily crashes with Vbox 4 - Win7-64 on OSOL134

Postby Alekz » 7. Jan 2011, 16:28

The high processor utilization has been fixed by reducing the amount of CPU's from 4 to 1. But Windows freezes every 30min. To restart it all VBox processes need to be killed.
Alekz
 
Posts: 3
Joined: 2. Jan 2011, 22:13
Primary OS: Solaris
VBox Version: OSE other
Guest OSses: Windows 7 x64

Re: Daily crashes with Vbox 4 - Win7-64 on OSOL134

Postby tomwaters » 7. Feb 2011, 12:35

Same here on solaris 11 express with latest vbox. Running headless guests, server 2008r2 and centos 5.5.

Strange thing is that box thinks it's still in running state, but can not connect or even ping the machine.

Need to kill the process...not happy. Sometimes it happens to one vm, sometimes all 3 vm's. Vm's may run a day, or 3 before freezing.

Did not have the issue with opensolaris 111b 2009.06

What do you need to help debug this...or should we submit a bug report to get some support?
tomwaters
 
Posts: 20
Joined: 26. May 2010, 00:31
Primary OS: OpenSolaris 10
VBox Version: PUEL
Guest OSses: Windows 7

Re: Daily crashes with Vbox 4 - Win7-64 on OSOL134

Postby tomwaters » 10. Feb 2011, 09:44

I have raised a bug here http://www.virtualbox.org/ticket/8294

This is getting freaking annoying. I wish I could run VMware on Solaris.

Looks like I'll be reverting back to OpenSolaris 2009.06...at least my VM's ran for more than a day before hanging.
tomwaters
 
Posts: 20
Joined: 26. May 2010, 00:31
Primary OS: OpenSolaris 10
VBox Version: PUEL
Guest OSses: Windows 7

Re: Daily crashes with Vbox 4 - Win7-64 on OSOL134

Postby pbeltranl » 12. Feb 2011, 11:38

Hi,

I upgraded from the last 3.x version to the last 4.x. Then, I noticed that:

I could work without any problem, but after a pause (do nothing on my laptop)... Virtualbox was crashed. So, I disabled all the powersave features (screen & HD) on my guest OS (Windows 7) and it runs stable forever since that.

Hope this helps.

My host OS is Ubuntu 10.10 (maverick).
pbeltranl
 
Posts: 3
Joined: 12. Feb 2011, 11:29
Primary OS: Ubuntu other
VBox Version: OSE other
Guest OSses: windows xp & seven

Re: Daily crashes with Vbox 4 - Win7-64 on OSOL134

Postby tomwaters » 13. Feb 2011, 23:49

Thanks for this pbeltranl, really appreciate the help.

Coincidently, I changed my power saving (disk, usb etc. all on all the time) and screen saver settings in the win7 vm's two days ago and have not had a "freeze" yet...normally it would have by now. Fingers crossed that is the issue.

Strange as it did not happen on v 3.12

Rather annoying in one way though...as I have a support ticket open, and set the vm's up for a core dump so can send it to the oracle guys....
tomwaters
 
Posts: 20
Joined: 26. May 2010, 00:31
Primary OS: OpenSolaris 10
VBox Version: PUEL
Guest OSses: Windows 7

Re: Daily crashes with Vbox 4 - Win7-64 on OSOL134

Postby tomwaters » 14. Feb 2011, 11:06

Hmmm...may be related to power management...found this on the Linux forum...
" Since 4.0, there are some more ACPI options available and when you have the GA installed, they become enabled in the VM OS. Open the Guest OS power management and disable the actions for hibernate and suspend."

Looking more likely and explains why it appeared under 4.0.2....as I was rev running 3.12 in opensolaris 2009.06
tomwaters
 
Posts: 20
Joined: 26. May 2010, 00:31
Primary OS: OpenSolaris 10
VBox Version: PUEL
Guest OSses: Windows 7

Re: Daily crashes with Vbox 4 - Win7-64 on OSOL134

Postby tomwaters » 16. Feb 2011, 01:41

I guess there is another issue as it just crashed...all 3 vm's went out...the win2k ones first, then the centos one.

Have sent the core dump to oracle.

On the bright side...it did last 4 days this time :|
tomwaters
 
Posts: 20
Joined: 26. May 2010, 00:31
Primary OS: OpenSolaris 10
VBox Version: PUEL
Guest OSses: Windows 7

Re: Daily crashes with Vbox 4 - Win7-64 on OSOL134

Postby pbeltranl » 16. Feb 2011, 13:30

me too just now!

My case:

I've upgraded my Ubuntu 10.10. I paused to work on my laptop for a while... and my VirtualBox 4.0.2 was crashed again! So I guess it has happened because the OS upgrade this time. So I will try to re-build my virtual box (sudo /etc/init.d/vboxdrv setup) and I think it will fix the problem. I'll come back again if not.
pbeltranl
 
Posts: 3
Joined: 12. Feb 2011, 11:29
Primary OS: Ubuntu other
VBox Version: OSE other
Guest OSses: windows xp & seven

Re: Daily crashes with Vbox 4 - Win7-64 on OSOL134

Postby tomwaters » 16. Feb 2011, 23:32

I am trying 3.12 now...if that crashes, or frank is not able to decypher the issue from the core dumps, I am done.

I went solaris as a stable vm platform, and while i love Solaris, 0-4 days uptime for the VM's is just not going to work for me.

ESXi is looking like my next step.
tomwaters
 
Posts: 20
Joined: 26. May 2010, 00:31
Primary OS: OpenSolaris 10
VBox Version: PUEL
Guest OSses: Windows 7

Re: Daily crashes with Vbox 4 - Win7-64 on OSOL134

Postby pbeltranl » 19. Feb 2011, 10:41

The new 4.0.4 version fixes this bug:

http://www.virtualbox.org/ticket/8131
pbeltranl
 
Posts: 3
Joined: 12. Feb 2011, 11:29
Primary OS: Ubuntu other
VBox Version: OSE other
Guest OSses: windows xp & seven

Re: Daily crashes with Vbox 4 - Win7-64 on OSOL134

Postby tomwaters » 19. Feb 2011, 13:15

Thanks for that. I am very hopeful this will resolve my issues. Will try the new release and post back with how it goes.

(Note: 3.12 seems to work ok, but only ran it for 2 days before I had to take down the server so not 100% sure it's not happening under 3.12).
tomwaters
 
Posts: 20
Joined: 26. May 2010, 00:31
Primary OS: OpenSolaris 10
VBox Version: PUEL
Guest OSses: Windows 7

Next

Return to VirtualBox on Solaris Hosts

Who is online

Users browsing this forum: No registered users and 2 guests