Virtual Machine not starting after server power outage

Discussions related to using VirtualBox on Solaris hosts.

Virtual Machine not starting after server power outage

Postby norus » 7. May 2009, 02:22

Hi all,

My server had a power outage and one of the virtual machines won't start.

I'm running Solaris Express b112 with VirtualBox 2.2.0 The guest machine is a Windows XP Pro.
Here's a little explanation of the problem:

Code: Select all   Expand viewCollapse view
solaris:~# VBoxHeadless -s xp -v on -p 3390
VirtualBox Headless Interface 2.2.0
(C) 2008-2009 Sun Microsystems, Inc.
All rights reserved.

Listening on port 3390
Error: failed to start machine. Error message: Medium '/root/.VirtualBox/HardDisks/xp.vmdk' is not accessible. Could not open the hard disk '/root/.VirtualBox/HardDisks/xp.vmdk'.
VMDK: inconsistency between grain table and backup grain table in '/root/.VirtualBox/HardDisks/xp.vmdk' (VERR_VD_VMDK_INVALID_HEADER).
VD: error opening image file '/root/.VirtualBox/HardDisks/xp.vmdk' (VERR_VD_VMDK_INVALID_HEADER)

solaris:~# ls -l .VirtualBox/HardDisks/
total 18758208
-rw-------   1 root     root     8482193408 May  6 21:42 xp.vmdk

solaris:~# VBoxManage showvminfo xp
VirtualBox Command Line Management Interface Version 2.2.0
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

Name:            xp
Guest OS:        Windows XP
UUID:            535ff592-835e-443b-9edd-7073f5a43397
Config file:     /root/.VirtualBox/Machines/xp/xp.xml
Memory size:     254MB
VRAM size:       12MB
Boot menu mode:  message and menu
ACPI:            on
IOAPIC:          on
PAE:             off
Time offset:     0 ms
Hardw. virt.ext: on
Nested Paging:   off
VT-x VPID:       off
State:           powered off (since 2009-05-07T00:12:46.320000000)
Monitor count:   1
3D Acceleration: off
Floppy:          empty
SATA:            disabled
IDE Controller:  PIIX4
Primary master:  /root/.VirtualBox/HardDisks/xp.vmdk (UUID: e4014abd-91c5-48ed-8fde-4c5180d9af6f)
DVD:             empty
NIC 1:           MAC: 08002772D1E3, Attachment: Bridged Interface 'yukonx1 - Ethernet', Cable connected: on, Trace: off (file: none), Type: Am79C973, Reported speed: 0 Mbps
NIC 2:           disabled
NIC 3:           disabled
NIC 4:           disabled
NIC 5:           disabled
NIC 6:           disabled
NIC 7:           disabled
NIC 8:           disabled
UART 1:          disabled
UART 2:          disabled
Audio:           disabled (Driver: Unknown, Controller: Unknown)
Clipboard Mode:  Bidirectional
VRDP:            disabled
USB:             enabled

USB Device Filters:

Index:            0
Active:           yes
Name:             Canon MP530 [0108]
VendorId:         04A9
ProductId:        1712
Revision:         0108
Manufacturer:     Canon
Product:          MP530
Remote:           no
Serial Number:    21A2A0

Shared folders:  <none>

Guest:

Statistics update:                   disabled

solaris:~# last reboot | head -n1
reboot    system boot                   Thu May  7 02:05


Any ideas on how this problem can be solved?
norus
 
Posts: 5
Joined: 4. May 2009, 15:47
Primary OS: Solaris
VBox Version: OSE other
Guest OSses: XP, Debian Lenny

Re: Virtual Machine not starting after server power outage

Postby Perryg » 7. May 2009, 03:00

Look in the folder indicated and see if the file is there and what the size of it is.
You may be able to repair it with the XP install CD.
Perryg
Site Moderator
 
Posts: 25943
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Virtual Machine not starting after server power outage

Postby norus » 7. May 2009, 15:15

Perryg wrote:Look in the folder indicated and see if the file is there and what the size of it is.
You may be able to repair it with the XP install CD.


The file _is_ there. See the CODE part.
And the install CD won't help me since the problem is at a lower level, VirtualBox can't read the vmdk file. Anyway, I "fixed" the problem by replacing xp.vmdk with an older version from last week's backup.
norus
 
Posts: 5
Joined: 4. May 2009, 15:47
Primary OS: Solaris
VBox Version: OSE other
Guest OSses: XP, Debian Lenny

Re: Virtual Machine not starting after server power outage

Postby Ramshankar » 11. May 2009, 16:09

What do you mean by won't start? Does the image not boot up properly or do you get error messages while starting a VM? If so, what does the error say?
Oracle Corp.
Ramshankar
Oracle Corporation
 
Posts: 636
Joined: 7. Jan 2008, 16:17

Re: Virtual Machine not starting after server power outage

Postby Ramshankar » 13. Aug 2009, 11:33

rsperduta wrote:I having am similar problem.
I was running virtual machine with Ubuntu on Windows XP host then someone else needed computer so they switch user and when they finish they power down while my virtual box was still running :(

Now it says hard drive grain table is inconsistent with backup grain table and refuses to power up my virtual machine with said hard drive attached :roll: (so I not can use it at all)

It seems to me there would be no point keeping grain table backups if all they would do is prevent me from using, so how do I delete the corrupted grain table?


This doesn't belong under the "OpenSolaris Hosts" section, please post this is the Windows host section of our forums.

ModEdit: previous post split and moved.
Oracle Corp.
Ramshankar
Oracle Corporation
 
Posts: 636
Joined: 7. Jan 2008, 16:17


Return to VirtualBox on Solaris Hosts

Who is online

Users browsing this forum: No registered users and 1 guest