Strange symbols displayed on console during startup

Discussions related to using VirtualBox on Solaris hosts.

Strange symbols displayed on console during startup

Postby douvryf » 4. Feb 2020, 21:18

Hello,

I upgraded virtualbox to the latest version and strange symbols are displayed at the first stage of the boot.

My config is solaris 11.3 , virtualbox 6.1.2

Regards,
François

virtualbox.JPG
virtualbox console
virtualbox.JPG (111.97 KiB) Viewed 28395 times
douvryf
 
Posts: 1
Joined: 4. Feb 2020, 21:04

Re: Strange symbols displayed on console during startup

Postby stes » 5. Feb 2020, 16:51

What is the OS of the guests that you are trying to run on the host (I understand that the host is Solaris) ?

Is it a variant of Red Hat Linux ? (for the guests)

Which version or "variation" (rebuild) of Red Hat Linux of the guest OS ?

Also you could check under 'Display settings' the display mode (Vbox SVGA or VMware SVGA) etc.
stes
 
Posts: 156
Joined: 28. Apr 2018, 11:07

Re: Strange symbols displayed on console during startup

Postby ganchev » 6. Apr 2020, 04:31

I am experiencing the same issue with VirtualBox 6.1.4 under Solaris 11.3.
When you start a VM it shows complete garbage on the screen until it switches to a graphical mode.
It doesn't matter which Graphics Controller type is chosen (VBoxVGA/VMSVGA/VBoxSVGA).
The console of some operating systems like pfSense or RouterOS is completely unusable as they never switches to a mode which works.

This problem seems to be specific to Solaris hosts because in VirtualBox 6.1.4 running on Windows it seems to be OK.

Here is how the RouterOS setup looks like:

VBox-6.1.4-Sol-11.3.png
VBox-6.1.4-Sol-11.3.png (16.57 KiB) Viewed 28103 times

This is very serious regression.
ganchev
 
Posts: 3
Joined: 6. Apr 2020, 04:10

Re: Strange symbols displayed on console during startup

Postby stes » 6. Apr 2020, 18:23

It's possible, have you checked the ChangeLog

https://www.virtualbox.org/wiki/Changelog-6.1#v4

there are several items under "Graphics" that may apply ...

What's the latest version that still works for you without the problem, 6.0.18 ?
stes
 
Posts: 156
Joined: 28. Apr 2018, 11:07

Re: Strange symbols displayed on console during startup

Postby ganchev » 14. Apr 2020, 19:51

The last version that I've tried from the 6.0.x series is 6.0.16 and it used to work OK.
I haven't reverted from 6.1.4 to 6.0.18 to test this as I managed to install the text OS I needed in "blind" mode.
ganchev
 
Posts: 3
Joined: 6. Apr 2020, 04:10

Re: Strange symbols displayed on console during startup

Postby ganchev » 24. Apr 2020, 20:03

The display issue is still present in VirtualBox 6.1.6.
I also hit a strange storage problem in one Linux VM which caused disk corruption, something which has never happened before for me. I managed to recover with minimal data loss thanks to time-slider.
So I removed 6.1.6 and installed 6.0.20. The display issue is not present in 6.0.20, the console looks normal and everything is readable.
Whatever is causing the problem in 6.1.x has not been back-ported to 6.0.x.
ganchev
 
Posts: 3
Joined: 6. Apr 2020, 04:10

Re: Strange symbols displayed on console during startup

Postby svartalf » 30. May 2020, 10:57

Posting to register that I also had this issue with unreadable consoles due to strange characters when I upgraded to 6.1
My guests are CentOS and due to this console display bug I am sticking on 6.0.16.
svartalf
 
Posts: 7
Joined: 31. Mar 2018, 18:32

Re: Strange symbols displayed on console during startup

Postby klaus » 19. Dec 2020, 00:18

This has just reached our attention a few days ago, and today one of our devs spotted the root cause. Please check the latest testbuilds (6.1 has the fix, too).

Really sorry that this took so long. This will be included in the next release, of course.
klaus
Oracle Corporation
 
Posts: 944
Joined: 10. May 2007, 14:57

Re: Strange symbols displayed on console during startup

Postby Hergen » 14. Jan 2021, 15:36

Just tried Version 6.1.17 r141968 and the issue is fixed. I can continue to setup my Netapp Simulator. Thanks a lot.
Hergen
 
Posts: 1
Joined: 14. Jan 2021, 15:34

Re: Strange symbols displayed on console during startup

Postby klaus » 14. Jan 2021, 16:45

Thanks for confirming... the fix is part of VirtualBox 6.1.18 which will be published on 19 January 2021.
klaus
Oracle Corporation
 
Posts: 944
Joined: 10. May 2007, 14:57

Re: Strange symbols displayed on console during startup

Postby svartalf » 24. Jan 2021, 23:54

I've just upgraded to 6.1.18 and console characters are displayed as expected.
Many thanks for fixing.
svartalf
 
Posts: 7
Joined: 31. Mar 2018, 18:32

Re: Strange symbols displayed on console during startup

Postby obiewan » 22. Feb 2022, 11:20

Hi,

I am seeing a different set of messages on my virtual console (with VirtualBox) BUT, also on the host system. My host and guest(s) are Fedora Core 37. I recently upgraded the host and started seeing the gibberish messages during boot (after in the VM)..

Here's my bug report to RedHat (FedoraCore): https://bugzilla.redhat.com/show_bug.cgi?id=2037703

I have, I think, isolated the cause of my situation. When I boot with "quiet" on the command line in grub.cfg I see NO GIBBERISH. When I remove "quiet", the gibberish appears.

Any thoughts would be appreciated.

Best regards and STAY SAFE!

George...
obiewan
 
Posts: 9
Joined: 30. Nov 2017, 20:26

Re: Strange symbols displayed on console during startup

Postby klaus » 22. Feb 2022, 18:55

Since this (apparently not really related) garbage output happens in the middle of the boot process I see few alternatives to finding a way to run the boot process under "strace", logging all the syscalls made by the various processes. Hunting down the text could be difficult, too, because the logging seems to use text mode (hard to be 100% certain though without VBox.log), relying on VGA support for a 9 bit charset. At least it looks like something bolted to the intensity. Can be seen by the ellipsis char in the normal looking message text, too. And there are suspiciously many accented chars for any Latin-X 8-bit charset.
klaus
Oracle Corporation
 
Posts: 944
Joined: 10. May 2007, 14:57


Return to VirtualBox on Solaris Hosts

Who is online

Users browsing this forum: No registered users and 1 guest