Page 1 of 1

Compile and install vbox5.2.20 problem

PostPosted: 28. Oct 2018, 11:45
by Artlu
in https://www.virtualbox.org/wiki/Windows ... structions
The documentation requires qt5.6.x and above and is built with c++, but isn't this qt5.6.x required to be compiled in vs2013 and above? What can I do.

Re: Compile and install vbox5.2.20 problem

PostPosted: 28. Oct 2018, 12:15
by socratis
Moving to "OSE" from "Windows Hosts".

Re: Compile and install vbox5.2.20 problem

PostPosted: 30. Oct 2018, 20:06
by mhanor
Qt 5.6.3 compiles just fine with MSVC++ 10.0 (Visual Studio 2010 or SDK 7.1)

Re: Compile and install vbox5.2.20 problem

PostPosted: 6. Jan 2019, 08:02
by Yurii.Ch
Unfortunately, it is impossible to upgrade VBox OSE under Windows to anything newer than MS VC++ 10.0 because of COM and ATL bindings. I tried several times, appeared it requires huge amount of work, and I gave up. In the parallel discussion there's an explanation of legacy tools usage, backward compatibility with older systems, which are often used in virtual environment