Page 1 of 1

UI Crashes on startup (#17763)

PostPosted: 11. May 2018, 12:44
by lyallp

[ModEdit; related ticket: #17763: UI Fails to start - 5.2.12 - qtcore 5.9.4]

Suggestions as to what to do for the following would be appreciated.
I have been using VirtualBox built from sources for ages, but since moving from qt4 to qt5, things broke.
If I need to supply additional information, let me know.

Code: Select all   Expand viewCollapse view
lyall@Lyalls-PC ~
$ VirtualBox
Qt FATAL: ASSERT failure in QCoreApplication::sendEvent: "Cannot send events to objects owned by a different thread. Current thread 0x0x556c4feaf630. Receiver '' (of type 'UITaskMediumEnumeration') was created in thread 0x0x556c4fcdefe0", file kernel/qcoreapplication.cpp, line 563
lyall@Lyalls-PC ~

Host system is 64 bit Gentoo on Intel Core i7-7700 built from source, as is the Gentoo way.
Kernel version 4.9.95-gentoo

No KDE applications are running at the time. I use Fluxbox as my desktop.

I tried using virtualbox 5.2.10 (Gentoo unstable version) but this exhibited the same behaviour as 5.1.36 (which is the 'stable' version for Gentoo).

I am not using systemd.

Installed Virtualbox versions:
Code: Select all   Expand viewCollapse view
 virtualbox 5.1.36(14:36:39 09/05/18)(alsa opengl pam pulseaudio qt5 sdk udev -debug -doc -headless -java -libressl -lvm -pax_kernel -python -vboxwebsrv -vnc ELIBC="-FreeBSD" PYTHON_TARGETS="python2_7")
 virtualbox-additions  5.1.36-r1^m(18:49:28 09/05/18)
 virtualbox-extpack-oracle^ms(14:36:51 09/05/18)
 virtualbox-modules 5.1.36(13:41:01 09/05/18)(-pax_kernel KERNEL="linux")

The following packages are installed to support this build.
Code: Select all   Expand viewCollapse view
 * dependency graph for app-emulation/virtualbox-5.1.36
 `--  app-emulation/virtualbox-5.1.36  amd64
   `--  app-emulation/virtualbox-modules-5.1.36  (~app-emulation/virtualbox-modules-5.1.36) amd64
   `--  dev-libs/libIDL-0.8.14-r2  (dev-libs/libIDL) amd64
   `--  dev-libs/libxslt-1.1.32  (>=dev-libs/libxslt-1.1.19) amd64
   `--  net-misc/curl-7.59.0  (net-misc/curl) amd64
   `--  dev-libs/libxml2-2.9.8  (dev-libs/libxml2) amd64
   `--  media-libs/libpng-1.6.34  (media-libs/libpng) ~amd64
   `--  media-libs/libvpx-1.5.0  (media-libs/libvpx) amd64
   `--  sys-libs/zlib-1.2.11-r1  (sys-libs/zlib) amd64
   `--  media-libs/libsdl-1.2.15-r9  (media-libs/libsdl) amd64  [X video]
   `--  x11-libs/libX11-1.6.5  (x11-libs/libX11) amd64
   `--  x11-libs/libXcursor-1.1.15  (x11-libs/libXcursor) amd64
   `--  x11-libs/libXext-1.3.3  (x11-libs/libXext) amd64
   `--  x11-libs/libXmu-1.1.2  (x11-libs/libXmu) amd64
   `--  x11-libs/libXt-1.1.5  (x11-libs/libXt) amd64
   `--  virtual/opengl-7.0-r1  (virtual/opengl) amd64
   `--  media-libs/freeglut-3.0.0  (media-libs/freeglut) amd64
   `--  dev-qt/qtcore-5.9.4-r2  (dev-qt/qtcore) amd64
   `--  dev-qt/qtgui-5.9.4-r3  (dev-qt/qtgui) amd64
   `--  dev-qt/qtprintsupport-5.9.4  (dev-qt/qtprintsupport) amd64
   `--  dev-qt/qtwidgets-5.9.4-r1  (dev-qt/qtwidgets) amd64
   `--  dev-qt/qtx11extras-5.9.4  (dev-qt/qtx11extras) amd64
   `--  dev-qt/qtopengl-5.9.4  (dev-qt/qtopengl) amd64
   `--  x11-libs/libXinerama-1.1.3  (x11-libs/libXinerama) amd64
   `--  dev-libs/libressl-2.6.4  (dev-libs/libressl) amd64
   `--  dev-libs/openssl-1.0.2o  (dev-libs/openssl) amd64
   `--  sys-fs/lvm2-2.02.145-r2  (sys-fs/lvm2) amd64
   `--  virtual/udev-217  (>=virtual/udev-171) amd64
   `--  net-libs/libvncserver-0.9.11-r1  (>=net-libs/libvncserver-0.9.9) amd64
   `--  dev-util/kbuild-0.1.9998_pre20131130-r1  (>=dev-util/kbuild-0.1.9998_pre20131130-r1) amd64
   `--  dev-lang/yasm-1.3.0  (>=dev-lang/yasm-0.6.2) amd64
   `--  sys-devel/bin86-0.16.21  (sys-devel/bin86) amd64
   `--  sys-libs/libcap-2.24-r2  (sys-libs/libcap) amd64
   `--  sys-power/iasl-20160729  (sys-power/iasl) amd64
   `--  virtual/pkgconfig-0-r1  (virtual/pkgconfig) amd64
   `--  media-libs/alsa-lib-1.1.2  (>=media-libs/alsa-lib-1.0.13) amd64
   `--  app-text/docbook-sgml-dtd-4.4  (app-text/docbook-sgml-dtd) amd64
   `--  dev-texlive/texlive-basic-2017-r1  (dev-texlive/texlive-basic) amd64
   `--  dev-texlive/texlive-latex-2017  (dev-texlive/texlive-latex) amd64
   `--  dev-texlive/texlive-latexrecommended-2017  (dev-texlive/texlive-latexrecommended) amd64
   `--  dev-texlive/texlive-latexextra-2017  (dev-texlive/texlive-latexextra) amd64
   `--  dev-texlive/texlive-fontsrecommended-2017  (dev-texlive/texlive-fontsrecommended) amd64
   `--  dev-texlive/texlive-fontsextra-2017  (dev-texlive/texlive-fontsextra) amd64
   `--  virtual/jdk-1.8.0-r3  (>=virtual/jdk-1.6) amd64
   `--  sys-libs/pam-1.2.1-r2  (sys-libs/pam) amd64
   `--  sys-apps/elfix-0.9.2  (sys-apps/elfix) amd64
   `--  media-sound/pulseaudio-11.1  (media-sound/pulseaudio) amd64
   `--  dev-qt/linguist-tools-5.9.4  (dev-qt/linguist-tools) amd64
   `--  net-libs/gsoap-2.8.51  (net-libs/gsoap) amd64  [-gnutls(-)]
   `--  dev-lang/python-2.7.14-r1  (>=dev-lang/python-2.7.5-r2) amd64
   `--  dev-lang/python-exec-2.4.5  (>=dev-lang/python-exec-2) amd64  [python_targets_python2_7(-)? -python_single_target_jython2_7(-) -python_single_target_pypy(-) -python_single_target_pypy3(-) -python_single_target_python3_4(-) -python_single_target_python3_5(-) -python_single_target_python3_6(-) python_single_target_python2_7(+)]
   `--  dev-java/java-config-2.2.0-r4  (>=dev-java/java-config-2.2.0-r3) amd64
   `--  virtual/jre-1.8.0-r1  (>=virtual/jre-1.6) amd64
   `--  virtual/tmpfiles-0  (virtual/tmpfiles) amd64
[ app-emulation/virtualbox-5.1.36 stats: packages (54), max depth (1) ]

Re: UI Crashes on startup

PostPosted: 12. May 2018, 00:33
by socratis
Moving to "OSE" from "Linux Hosts", I think you might have a better chance there.

But, just from my limited experience, VirtualBox and Qt (and your host) need to just align so that the whole thing works. That's all I have for you I'm afraid...

Re: UI Crashes on startup

PostPosted: 12. May 2018, 03:45
by lyallp
Where would I find the library versions that are used by Oracle to build the binary versions?
I assume there is an internal build environment.
If I know what versions they are, I could maybe tweak the Gentoo build to require those versions.

Re: UI Crashes on startup

PostPosted: 12. May 2018, 19:27
by socratis
lyallp wrote:Where would I find the library versions that are used by Oracle to build the binary versions?
In the "configure" at the top of the /vbox. There is the minimum version stated and checked for. I would suggest to look at the pre-made VirtualBox that comes with Gentoo and see what Qt version they're using. Go for that version.

For example, mine (OSX) was using Qt 5.6.2 for the longest time. Windows still does. There was an issue where you'd see double cursors on the OSX builds, in several of the guests. That issue turned out to be an issue with Qt and an upgrade to 5.6.3 fixed it. That's what OSX builds use now.

I tried to take it a notch higher with Qt 5.7.x. You wanna guess what happened? Kaboom! So, stick with the things that work in the official releases, that's your best bet.

What I was doing to avoid tweaking my real system? I had a VM with the same OSX version as my host which I could reset at any point, and I was able to experiment at will. Upgrading, downgrading, testing, reverting to my (single) snapshot. If something was working, it became part of the snapshot, i.e. a permanent feature. And I documented the whole thing so I can repeat it at will. I still have that VM, that's my "Mac OS X 10.9 - Build" VM. ;)

I forgot to say that I just discovered an issue with the latest versions in the trunk that would cause my built-VirtualBox to crash. No warnings, no errors during the build, but it was a runtime crash. I tracked it down to a specific changeset and I'm waiting for the developers to get some "relaxed" time so we can see what can be done about it.

Re: UI Crashes on startup

PostPosted: 13. May 2018, 09:54
by lyallp
Thanks for the post.
Problem is, Gentoo only goes back to QT 5.9.4, oldest I can go without delving into other repositories.
I may have to go with VirtualBox-bin, just to find out what versions of libraries it uses now.
Edit: Damn, VirtualBox-bin doesn't start as root nor user, with a
Code: Select all   Expand viewCollapse view
Failed to initialize COM or to find the VirtualBox COM server. Most likely, the VirtualBox server is not running or failed to start.
The application will now terminate.

Sheesh, I may just start looking at alternatives...

Re: UI Crashes on startup

PostPosted: 13. May 2018, 11:02
by socratis
How about the idea of running the whole thing inside a VM, as to not actually screw your host?

The way that I understand it is that Gentoo is a rolling release, right? But, in the Gentoo Downloads ( I see that the LiveDVD is from 2016-07-04, while the Minimal installation is from 2018-04-15. Gonna try with the latter.

I don't have a Gentoo VM, so I'll take it as a chance to try it out... ;)

lyallp wrote:Sheesh, I may just start looking at alternatives...
To what? Building it on your own?

Re: UI Crashes on startup

PostPosted: 13. May 2018, 11:10
by lyallp
lyallp wrote:To what? Building it on your own?

Alternative VM host software.

Gentoo is a rolling release, my installation is a couple of years old but I do updates regularly. Basically, everything is built from source, except things like nvidia drivers, oracle ext packs and additions.
Only around 30 applications on my install is what Gentoo calls '~' or 'unstable', that software is not libraries or frameworks but applications.

The beauty of this is that if I decide I want to debug an app, I can rebuild it with debug, including all the libraries it uses, to provide symbols, helpful if an app core dumps, I can provide a nice stack trace to the developers.

Re: UI Crashes on startup (#17763)

PostPosted: 14. May 2018, 12:11
by socratis
Added ticket related information in the title and the first post...