The api of Powerup cannot work in version 5.0.12

Discussions related to using the OSE version of VirtualBox.

The api of Powerup cannot work in version 5.0.12

Postby DanielZhao » 7. Jan 2016, 06:04

I change to the sample of VBoxHeadless.cpp to MyVBoxHeadless.cpp use version 5.0.12, and run it , the powerup cannot work ,i don't know why, maybe not use "RTR3InitExe" codes cause this result , but i compile the codes contains "RTR3InitExe" also get lots of unresolved external symbol errors, hard to solve it . Can anyone help me? Thanks!
DanielZhao
 
Posts: 2
Joined: 7. Jan 2016, 05:52

Re: The api of Powerup cannot work in version 5.0.12

Postby noteirak » 7. Jan 2016, 13:12

Moving to "VirtualBox OSE" since this seems to be a compilation problem, not an API usage problem.
Hyperbox - Virtual Infrastructure Manager - https://kamax.io/hbox/
Manage your VirtualBox infrastructure the free way!
noteirak
Site Moderator
 
Posts: 5198
Joined: 13. Jan 2012, 11:14
Primary OS: Debian other
VBox Version: OSE Debian
Guest OSses: Debian, Win 2k8, Win 7

Re: The api of Powerup cannot work in version 5.0.12

Postby DanielZhao » 8. Jan 2016, 03:57

Thanks for your reply ,but the powerup in version 4.3 is ok, i check the com interface , the IFrameBuffer and IDisplay interface get lots of change, i just want to know the detail reason why the powerup in version 5.0 cannot work.
DanielZhao
 
Posts: 2
Joined: 7. Jan 2016, 05:52


Return to VirtualBox OSE

Who is online

Users browsing this forum: No registered users and 1 guest