Page 1 of 3

USB is enabled in VBox GUI but not in my VM

PostPosted: 8. Oct 2015, 17:20
by RicV
Hi Experts,

I am trying to access a real USB memory stick plugged into my Ubuntu 14.04 host from within my Ubuntu 14.04 guest, using VBox OSE 5.0.0.

— I have installed the guest additions, and confirmed that folder sharing and screen resizing works.

— I have installed the extension pack, as shown in the attachment. Actually, I tried both of the 5.0.0 extension packs that I found in the download area, though they appear to be identical.

— I have added myself to the vboxusers group.

— After researching countless related issues in the VBox forum and the Ubuntu forum, I have installed several additional packages that others found were necessary.

— I rebooted my host after every step, above.

These steps all helped me make progress, but now I am stuck and looking for further advice. Here is my problem:

I can enable the USB controller in the VirtualBox GUI Settings, but it still says there are no devices. Here is the strange part: when I start the VM and use the Devices/USB menu therein, the enable check box appears checked, but it's greyed out. And of course, trying to add a filter for my device still says that no devices are available. See the attached screen shots.

I have tried with both USB 2.0 and 1.1, same result.

I have tried everything I can find in the VBox forum and Ubuntu forum, but evidently I am still missing something.

Someone said that you need to have an empty filter in order to get a device list, and though that sounded unlikely, I even tried that, to no avail.

Any other ideas? I'm fresh out of ideas.

Re: USB is enabled in VBox GUI but not in my VM

PostPosted: 8. Oct 2015, 18:30
by mpack
I don't know what that log file is, but it isn't a VirtualBox VM log. I also don't understand why it says "truncated" at the end. You have not reached the 256K archive attachment limit.

p.s. we don't need the VBoxSVC log or the JPEGs. This will give you even more space in the archive.
p.p.s. I wouldn't recommend sticking with the .0.0 release of any software once fixed versions are available. The current release is 5.06.

Re: USB is enabled in VBox GUI but not in my VM

PostPosted: 8. Oct 2015, 18:35
by RicV
It is a virtual box log file, but all the messages that start with RicV (i.e. my name) are from LogAlways statements I have added (and plan to remove once I get things working). If you think it will help, I can inhibit my message and capture a new log. What VBOX_LOG setting would be most helpful?

Re: USB is enabled in VBox GUI but not in my VM

PostPosted: 8. Oct 2015, 19:02
by Perryg
The only requirements for USB with a Linux host is you must install the matching extension pack and your user name must be in the vboxusers group and activated with a log out and in or a reboot.

Re: USB is enabled in VBox GUI but not in my VM

PostPosted: 8. Oct 2015, 19:10
by RicV
I did both of those things, as noted above. I am currently building an unmodified 5.0.6 download to see if I can reproduce it with that...

Re: USB is enabled in VBox GUI but not in my VM

PostPosted: 8. Oct 2015, 19:13
by Perryg
Like I said those are the only requirements. So if it does not work it has to be with the build. Only you could tell that.

Re: USB is enabled in VBox GUI but not in my VM

PostPosted: 8. Oct 2015, 22:14
by RicV
OK, so I downloaded the 506 OSE code from http://download.virtualbox.org/virtualb ... .6.tar.bz2, unpacked it, ran the configure script followed by env.sh, and tried to build with kmk LOG_ENABLED=1. The compile failed in DevE1000.cpp due to issues with the Log6 macro. Rather than get distracted on a tangent, I removed the whole out tree and rebuilt with logging disabled. This worked.

Next, I uninstalled the 500 extension pack and installed the 506 extension pack.

Now, I have the same exact problem as before. I can enable the USB Controller, but I still cannot see any USB device.

I assume you will need a log file of some type, so I'll try to figure that out.

Re: USB is enabled in VBox GUI but not in my VM

PostPosted: 8. Oct 2015, 22:33
by Perryg
I need to see the guests log file ( as an attachment ) Right click on the guest in the Main Manager then click show log. Save and post as an attachment. Compress if it is too large to post.

I would also like to see the following with this install ( from the host terminal )

    VBoxManage -v
    VBoxManage list extpacks
    and the results of id

Re: USB is enabled in VBox GUI but not in my VM

PostPosted: 8. Oct 2015, 22:38
by RicV
Do I need to get the LOG_ENABLED build working for this, or can I use a regular (kmk all) build?

Re: USB is enabled in VBox GUI but not in my VM

PostPosted: 8. Oct 2015, 22:38
by Perryg
Show me what you have now and I can tell.

Re: USB is enabled in VBox GUI but not in my VM

PostPosted: 8. Oct 2015, 23:23
by RicV
OK, I've got it. Sorry for the delay, I had removed my out tree to work on the LOG_ENABLED problem, so then I had to kill it again to rebuild normally.

Re: USB is enabled in VBox GUI but not in my VM

PostPosted: 8. Oct 2015, 23:37
by Perryg
All of this looks good. Post the following please:
VBoxManage list usbhost

Re: USB is enabled in VBox GUI but not in my VM

PostPosted: 9. Oct 2015, 01:48
by RicV
Apparently VBoxManage thinks there are no devices there at all. But I had my USB memory stick installed at the time, and in fact used that to copy the attached file from my test PC to my main PC, so not only present but functional.

Re: USB is enabled in VBox GUI but not in my VM

PostPosted: 9. Oct 2015, 01:56
by Perryg
But you can run lsusb and see the device, right?
Also check if /dev/vboxusb exists and has a file in it. ( probably zero byte )

Re: USB is enabled in VBox GUI but not in my VM

PostPosted: 9. Oct 2015, 02:02
by RicV
I can see it with lsusb (on the host). But there is no /dev/vboxusb.