Page 1 of 1

Where Do You Get Extension Pack for Your Forked VirtualBox

PostPosted: 30. Aug 2015, 13:29
by Gene77072
I was trying to work with Ubuntu Audio Support trying to figure out Audio Anomalies with several of the Ubuntu 15.10 development distributions.
They were steering me to various VirtualBox Patches that don't seem to be in GA packages and also making logic changes to some of the source.
I used instructions from the post "Building VirtualBox from SVN using Debian-6 & 7 x86_64" to create a Forked Version of the source for my Ubuntu environment.
Although the post has a slight mention of Extension Pack, there are no instructions specifically building that file.
I could not find in the created directory structure any file representing the Oracle VM Virtualbox Extension Pack for my Forked level.
Only several Extension Packs involved in Debug.

Is the contents of the Extension pack supported under this Fork Process?
If not, do I just use the latest Extension Pack?

Re: Where Do You Get Extension Pack for Your Forked VirtualB

PostPosted: 30. Aug 2015, 13:38
by mpack
We do not support third party forks here. Among other things that also means that we don't consider it our responsibility to verify or even know if the GAs work in that environment or not. It is simply not our concern.

If you have any questions about, e.g., the Ubuntu fork, then you need to ask in the Ubuntu forums. Or, you can install the official version of VirtualBox which we do support.

Re: Where Do You Get Extension Pack for Your Forked VirtualB

PostPosted: 30. Aug 2015, 13:55
by Martin
The Extension Pack is not included because these features are not part of the open source license.

Re: Where Do You Get Extension Pack for Your Forked VirtualB

PostPosted: 30. Aug 2015, 15:08
by mpack
Oops, sorry I was thinking of the Guest Additions.

Yes, as Martin said. The whole point of the standard extension pack is that these are closed source extras added to the open source application. However what I said before about support for third party forks still applies.

"Unsupported registration structure version 1.0"

PostPosted: 22. Apr 2016, 00:49
by vindicator
Is this why I would get "Unsupported registration structure version 1.0." when trying to install an extension pack?
For some reason, this error message doesn't seem to have been brought up anywhere yet. I don't know if this is why or if I should create a bug/ticket.

I "svn checkout" the source, build and install it.
I try to install the latest ext-pack even though it is a version < the subversion trunk and get that error.

With the last build I did, I think the installation of ext-pack 5.0.14-105127 for vbox 5.0.51-r59584 failed, but I think I was able to install ext-pack 5.0.0-101573.
But now I built 5.0.51-r60604 and neither of those 2 ext-packs, nor 5.0.18 would install.

Re: Where Do You Get Extension Pack for Your Forked VirtualBox

PostPosted: 22. Apr 2016, 01:01
by Perryg
Building from SVN ( future version ) you would need to ask the DEVs to provide one for you. IRC or the DEV mailing list.
https://www.virtualbox.org/wiki/Community