Compile VirtualBox-4.2.12 error on win7 64bit

Discussions related to using the OSE version of VirtualBox.

Compile VirtualBox-4.2.12 error on win7 64bit

Postby wuzf » 31. May 2013, 04:46

Hi, I have successfully to compile Virtualbox-4.2.12 on xp(32bit),but there have some error when I compile on win7(64bit).

My compile step as follows:

E:\VirtualBox-4.2.12>cscript configure.vbs "--with-VC=C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC" --with-Min
GW32=D:\VirtualBoxSoftWare\mingw32 --with-MinGW-w64=D:\VirtualBoxSoftWare\mingw64 --with-libxml2=D:\VirtualBoxSoftWare\l
ibxml2 --with-libxslt=D:\VirtualBoxSoftWare\libxslt --with-libSDL=D:\VirtualBoxSoftWare\SDL-1.2.15 --with-openssl=D:\Vir
tualBoxSoftWare\openssl --with-libcurl=D:\VirtualBoxSoftWare\libcurl --with-Qt4=D:\VirtualBoxSoftWare\Qt\4.8.4 --with-py
thon=D:\VirtualBoxSoftWare\Python27 --with-DDK=D:\WinDDK\7600.16385.1 "--with-SDK=C:\Program Files\Microsoft SDKs\Window

Shell inheritance test: OK
Source path: OK
Checking for kBuild...
Found kBuild: E:/VirtualBox-4.2.12/kBuild
Found kBuild binaries: E:/VirtualBox-4.2.12/kBuild/bin/win.x86
Checking for Windows DDK v7.1...
Found Windows DDK v7.1: D:/WinDDK/7600.16385.1
Checking for Visual C++...
Found Visual C++ v10 with ATL: C:/PROGRA~2/MICROS~2.0/VC (C:/Program Files (x86)/Microsoft Visual Studio 10.0/VC)
Checking for Windows Platform SDK (recent)...
Found Windows Platform SDK (v71): C:/PROGRA~1/MIA713~1/Windows/v7.1 (C:/Program Files/Microsoft SDKs/Windows/v7.1)
Checking for Midl.exe...
Found Midl.exe: C:/PROGRA~1/MIA713~1/Windows/v7.1/bin/Midl.exe (C:/Program Files/Microsoft SDKs/Windows/v7.1/Bin/Midl.e
Checking for MinGW32 GCC v3.3.x + Binutils + Runtime + W32API...
warning: Can't locate a suitable MinGW32 installation, ignoring since we're targetting AMD64 and won't need it.
Checking for MinGW-w64 GCC (unprefixed)...
Found MinGW-w64 (GCC v4.5.4): D:/VirtualBoxSoftWare/mingw64
Checking for libSDL...
Found libSDL: D:/VirtualBoxSoftWare/SDL-1.2.15
Checking for libxml2...
Found libxml2: D:/VirtualBoxSoftWare/libxml2
Checking for libxslt...
Found libxslt: D:/VirtualBoxSoftWare/libxslt
Checking for openssl...
Found openssl: D:/VirtualBoxSoftWare/openssl
Checking for libcurl...
Found libcurl: D:/VirtualBoxSoftWare/libcurl
Checking for Qt4...
Found Qt4 : D:/VirtualBoxSoftWare/Qt/4.8.4
Checking for Python...
Found Python : D:\VirtualBoxSoftWare\Python27

call kbuild\envwin.cmd --win64 --release

VBoxRT.def : error LNK2001: unresolved external symbol _CONF_get_section
VBoxRT.def : error LNK2001: unresolved external symbol _CONF_get_string
E:/VirtualBox-4.2.12/out/win.amd64/release/obj/VBoxRT/VBoxRT.lib : fatal error LNK1120: 2 unresolved externals
kmk: *** [E:/VirtualBox-4.2.12/out/win.amd64/release/obj/VBoxRT/VBoxRT.dll] Error 1120
The failing command:
@ C:/PROGRA~2/MICROS~2.0/VC/bin/amd64/link.exe -nologo -machine:amd64
LIB:libcd.lib /DISALLOWLIB:libcmt.lib /DISALLOWLIB:libcmtd.lib /DISALLOWLIB:msvcrtd.lib /DISALLOWLIB:msvcprtd.lib /MA
NIFEST /OUT:E:/VirtualBox-4.2.12/out/win.amd64/release/obj/VBoxRT/VBoxRT.dll /IMPLIB:E:/VirtualBox-4.2.12/out/win.amd
64/release/obj/VBoxRT/VBoxRT.lib /MAPINFO:EXPORTS /INCREMENTAL:NO /MAP:E:/VirtualBox-4.2.12/out/win.amd64/release/obj/VB
oxRT/ /DLL /DEF:E:/VirtualBox-4.2.12/out/win.amd64/release/obj/VBoxRT/VBoxRT.def /LIBPATH:C:/PROGRA~1/MIA71
3~1/Windows/v7.1/Lib/x64 /LIBPATH:D:/WinDDK/7600.16385.1/lib/wlh/amd64 /LIBPATH:C:/PROGRA~1/MIA713~1/Windows/v7.1/Lib/
x64 @E:/VirtualBox-4.2.12/out/win.amd64/release/obj/VBoxRT/VBoxRT.rsp
kmk: *** Deleting file `E:/VirtualBox-4.2.12/out/win.amd64/release/obj/VBoxRT/VBoxRT.dll'
kmk: *** [E:/VirtualBox-4.2.12/out/win.amd64/release/obj/VBoxRT/VBoxRT.dll] Deleting file `E:/VirtualBox-4.2.12/out/win.
kmk: *** Waiting for unfinished jobs....
kmk: *** Exiting with status 2

why? How to solve? I check it on the on the BBS posts with the problems, but still not solve.
My openssl version is 0.9.8x.
Posts: 15
Joined: 30. May 2013, 10:57

Re: Compile VirtualBox-4.2.12 error on win7 64bit

Postby feverwind » 29. Jul 2013, 10:10

maybe your libcur.lib is not 64bit
Posts: 13
Joined: 17. Jul 2013, 09:49

Re: Compile VirtualBox-4.2.12 error on win7 64bit

Postby xuchao » 25. Nov 2013, 07:35

can you tell me how did you set the mingW,i tried several times ,but it always tell me "Microsoft VBscript runtime error:type mismatch"
Posts: 15
Joined: 20. Oct 2013, 16:15

Return to VirtualBox OSE

Who is online

Users browsing this forum: No registered users and 5 guests