Page 1 of 1

No Pressure from usb Tablet

PostPosted: 15. Aug 2012, 05:53
by num_lock_key
Anyone here know how to get tablet pressure sensetivity working a virtual machine? It works fine on the host but is treated as a mouse on the VM. I don't mind locking it to a VM, as long as it is easy enough to unlock so I can use it again on the host when I shut the VM down or something. I read online that there is something called a filter, but I am not sure how to do this.

Host: Ubuntu 12.04lts
VM1: Linux Mint 13
VM2: WinXP
Tablet: Genius MousePen 8x6
VirtualBox OSE: 4.1.12_Ubuntu-r77245

Thanks for your time and help!

Re: No Pressure from usb Tablet

PostPosted: 17. Aug 2012, 13:49
by num_lock_key
Solved:
  • Install the extention for specific version of virtualbox.
  • Add your (host) username as member of group "vboxusers"
  • Add a filter for the tablet. For me it was done by selecting the VM in the launcher on the host, going to Machine->settings->USB.
  • The cursor may not work properly if the virtualbox os addons are installed on the VM. If this is the case, simply turn off mouse integration.

Re: No Pressure from usb Tablet

PostPosted: 17. Mar 2015, 23:39
by vale
I'm having the same problem.

The thing is, I have the extension pack installed and everything, I ticked on "Enable USB 2.0 driver" and I clicked on "add a new filter". Now what? Is there anything else I should do? If I just launch Windows, it still doesn't recognize the tablet as such. And when I try to go to "tablet preferences", it tells me there is no supported tablet on the system, as it did before...

Thanks in advance!


*EDIT*

I could solve this issue by following the instructions in this thread and in this other: https://forums.virtualbox.org/viewtopic.php?f=2&t=61988

Re: No Pressure from usb Tablet

PostPosted: 18. Mar 2015, 00:31
by socratis
Your virtual machine runs on virtual hardware (as in it doesn't mimic/copy your exact hardware). That's all...