Discuss the 6.0.10 release

This is for discussing general topics about how to use VirtualBox.

Discuss the 6.0.10 release

Postby michael » 16. Jul 2019, 15:50

Discuss the 6.0.10 release here.
You can download the release here.
VirtualBox 6.0.10 is a new maintenance release.

VirtualBox 6.0.14 has been released. Please try that before continuing the discussion in this thread.

Known new issues/regressions
These are new and confirmed tickets about issues with 6.0.10:
  • #11577 Secure Boot doesn't allow 'vboxdrv' module to load (now works for Ubuntu and Debian 10+ hosts)
  • #18766 6.0.10 r132072 crashes Windows VM when Shared Folders are used - Fixed with 6.0.11 r132480 or later.
  • #18767 VirtualBox 6.0.10 segfaults at startup on CentOS 7.6
  • #18802 cannot do "savestate" machine - Fixed with 6.0.12.
  • #18843 VirtualBox crashes with Skype and Windows 10 guest
  • #18869 vbox_ttm.c - header file nit in include directive - Fixed with 6.0.11 r132724 or later.
  • #18917 VBox 6.0.10 GAs fail to compile on Red Hat/CentOS/OL 7.7; also Red Hat 8.1 Beta - Fixed with 6.0.13 r133264 or later.
See also:
michael
Oracle Corporation
 
Posts: 683
Joined: 10. May 2007, 09:46

Re: Discuss the 6.0.10 release

Postby sej7278 » 18. Jul 2019, 14:32

i get a segfault when trying to install the guest additions on an existing debian stretch guest (debian buster host).

if i ignore it and reboot, the guest comes back with no way to move the mouse or use the keyboard - i'm basically stuck at the gdm screen with no way to login.
sej7278
Volunteer
 
Posts: 1003
Joined: 5. Sep 2008, 14:40
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Solaris, Linux, Windows, OS/2, MacOSX, FreeBSD

Re: Discuss the 6.0.10 release

Postby michael » 18. Jul 2019, 14:40

Could you please provide more details about the segfault? I assume it is in code on the host?
michael
Oracle Corporation
 
Posts: 683
Joined: 10. May 2007, 09:46

Re: Discuss the 6.0.10 release

Postby sej7278 » 18. Jul 2019, 18:19

michael wrote:Could you please provide more details about the segfault? I assume it is in code on the host?

hmm, it seems to be ok now, don't you just love intermittent issues?!

it did segfault with some error code (139?) twice when trying to build the initramfs. it was VBoxLinuxAdditions.sh that segfaulted on the guest, not vbox on the host.

i wonder if it was because i'd already mounted some shared folders - as this time i just did a fresh boot and ran the installer straight away.
sej7278
Volunteer
 
Posts: 1003
Joined: 5. Sep 2008, 14:40
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Solaris, Linux, Windows, OS/2, MacOSX, FreeBSD

Re: Discuss the 6.0.10 release

Postby jsnyder-ats » 9. Aug 2019, 17:31

I have not had any issues with segfaults; however, 6.0.10 broke the mouse cursor for me. The cursor display is 2/3rds of a line below where it has an effect. This happened in an earlier release but was fixed, so it seems that this is a regression.
jsnyder-ats
 
Posts: 2
Joined: 9. Aug 2019, 17:27

Re: Discuss the 6.0.10 release

Postby klaus » 9. Aug 2019, 18:38

Try the latest 6.0 guest additions from the Test build page. It contains some fixes to the Windows graphics drivers which had issues with the Windows 10 magnifier support... if it doesn't help, let us know, ideally with a screenshot.
klaus
Oracle Corporation
 
Posts: 712
Joined: 10. May 2007, 14:57

Re: Discuss the 6.0.10 release

Postby jsnyder-ats » 12. Aug 2019, 15:48

I upgraded the VirtualBox to the latest test build, along with the guest additions. The issue is still present.

Environment:
Windows 7
VirtualBox: 6.0.11r132665
Guest Additions: VBoxGuestAdditions_6.0.11-132500.iso
Image: Ubuntu 16.04

Running any editor (gedit, Sublime, etc...), if I click into text, the cursor will place itself on the line above where I clicked and to the left by 2 characters.

Example:

Line 1
Line 2

Using 6.0.10/11, if I click directly at the end of Line 2, the cursor will place itself between the e and the space of Line 1.

This issue does not happen to me in 5.2.32.
jsnyder-ats
 
Posts: 2
Joined: 9. Aug 2019, 17:27

Re: Discuss the 6.0.12 release

Postby ciamaulex » 25. Sep 2019, 15:48

Hello,

I have an issue that began with 6.0.10 and repeated with 6.0.12
Win7 32 bit guest, used since several years with all VBox versions since 5.1.x
This is used primarily as VPN access client with 10+ different VPN clients installed
Host was Win7 x64, now is Win10 x64

Starting with 6.0.10, after disconnecting VPN from certain sites, the Virtualbox window freezes (guest screen frozen as well).
this happened twice a day with NAT networking, then I switched to bridged mode and it never happened again.

After update to 6.0.12, this happened again with bridged networking.
I must kill the window from Task Manager on the host to reboot the guest.

If you need any log file, please let me know.

Best regards and thanks for the great work.
ciamaulex
 
Posts: 5
Joined: 22. Nov 2017, 13:57
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Windows 2016, Debian

Re: Discuss the 6.0.10 release

Postby socratis » 25. Sep 2019, 17:01

ciamaulex wrote:I have an issue that began with 6.0.10 and repeated with 6.0.12
Then I'm going to move your post from the "Discuss the 6.0.12 release" to the "Discuss the 6.0.10 release" thread. Each "Discuss the X.Y.Z release" is specifically for problems new to the X.Y.Z release. Yours seems to belong in the 6.0.10 area.

ciamaulex wrote:then I switched to bridged mode and it never happened again
So, it's a sporadic one, not an easily reproducible test? That's a tough one...

ciamaulex wrote:If you need any log file, please let me know.
We need to see a complete VBox.log, from a complete VM run, where the problem occurs:
  • Start the VM from cold-boot (not from a paused or saved state) / Observe or recreate the problem / Shutdown the VM (force close it if you have to).
  • With the VM completely shut down (not paused or saved), right-click on the VM in the VirtualBox Manager and select "Show Log".
  • Save only the first "VBox.log", ZIP it and attach it to your response. See the "Upload attachment" tab below the reply form.
Image
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25938
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Discuss the 6.0.10 release

Postby ciamaulex » 11. Oct 2019, 17:17

Hello,
the problem about frozen VM happened again today.

I wanted to give you a log from a cold boot as per your directions, but the other VM I cold boot daily did not show the issue again.
This is from another VM that was booted this morning from a saved state and ran fine for several hours until I disconnected my Cisco VPN client.
I hope it can shed some light, in any case I will post another log if the condition happens again.

Thank you
Attachments
XP_DEV-2019-10-11-17-08-00.zip
(21.36 KiB) Downloaded 3 times
ciamaulex
 
Posts: 5
Joined: 22. Nov 2017, 13:57
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Windows 2016, Debian

Re: Discuss the 6.0.10 release

Postby ciamaulex » 11. Oct 2019, 17:24

Oops, we're lucky today...
this VM was cold booted this morning and froze just now while trying anothe VPN connection.
Note: peeking at the last lines of the log I saw (both in this log and the previous) a line:

Audio: Device configuration of driver 'DSoundAudio' has changed

Maybe this has something to do?

Thank you
Attachments
Win7_VPN-2019-10-11-15-28-33.zip
(22.17 KiB) Downloaded 3 times
ciamaulex
 
Posts: 5
Joined: 22. Nov 2017, 13:57
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Windows 2016, Debian


Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 9 guests