Nat Network port connections allowed only after ping

This is for discussing general topics about how to use VirtualBox.

Nat Network port connections allowed only after ping

Postby DiscoFever » 20. May 2019, 17:56

Hello,
I have a few VMs in a NAT network. Using just two as an example, one is a postgres database server listening on port 5432. The other is my dev machine where I use dBeaver to manage a database on the server.

The network addresses are static.

Upon booting these machines up, I can ping the database server from my dev machine. However, I was not able to connect with my database client.
The correct server port is listed as open for listening.
I tried telnet. No dice.

From the server, I ping the dev machine. There is a noticeable difference in the time it takes to start returning results. However, once the replies do start coming, the 'time' attribute is roughly the same as the ping from dev to server.

Now, if I go back to my dev machine, I am able to connect with telnet, and so with dbeaver as well.

The same thing happens between the other virtual machines and the database server.

I am trying to figure out the correct way to configure my db server to let the other vms connect after a bootup without this extra step.
If anyone understand what is happening here, I'd appreciate any links, insights, or advice.
Thanks
DF
DiscoFever
 
Posts: 1
Joined: 20. May 2019, 17:05

Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 16 guests