Disabling VT-x

This is for discussing general topics about how to use VirtualBox.

Disabling VT-x

Postby GeorgeA7299 » 28. Apr 2019, 14:36

Hello

I have a virtual machine that I wish to disable VT-x/AMD-V on. However, when I uncheck the option on the Acceleration Tab, close the System Settngs dialog box, and then open the settings again, the VT-x/AMD-V is enabled again as if I hadn't changed it. Can anyone tell me what to do?
GeorgeA7299
 
Posts: 2
Joined: 27. Apr 2019, 19:17

Re: Disabling VT-x

Postby socratis » 28. Apr 2019, 18:07

I would like to see the "recipe" of the VM, the ".vbox" file:
  1. Right-click on the VM in the VirtualBox Manager. Select "Show in Finder/Explorer/Whatever".
  2. ZIP the selected ".vbox" file and attach it to your response.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 23883
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Disabling VT-x

Postby mpack » 28. Apr 2019, 18:18

You can't create a 64bit VM, >Win8 VM, or a multi-CPU VM without VT-x (or AMD-v). Using any of these features implicitly enables VT-x again.
mpack
Site Moderator
 
Posts: 29224
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Disabling VT-x

Postby socratis » 28. Apr 2019, 19:13

D'oh! :shock:
That's what happens when you're mostly working on an OSX host, where that option is not even there. :?

In fact trying to disable "Hardware virtualization: Enable VT-x/AMD-V", results in invalid settings (the yellow triangle, hover over it), with one or more of the following warning showing:

  • General: Basic
    The virtual machine operating system hint is set to a 64-bit type. 64-bit guest systems require hardware virtualization, so this will be enabled automatically if you confirm the changes.

  • System: Acceleration
    The hardware virtualization is not currently enabled in the Acceleration section of the System page. This is needed for nested paging support. It will be enabled automatically if you confirm your changes.

  • System: Processor
    The hardware virtualization is not currently enabled in the Acceleration section of the System page. This is needed to support more than one virtual processor. It will be enabled automatically if you confirm your changes.
However... a Win10-32 bit, 1 CPU, no Nested-Paging, is fine without VT-x enabled. I do remember a similar rule for a VM with > Win8.x requiring VT-x, but I can't reproduce the conditions, maybe they've changed the requirements?

BTW, all of these mean that the host will use its hardware acceleration, which I'm not sure why the OP would care about. From the tooltip of the setting:
Settings tooltip wrote:When checked, the virtual machine will try to make use of the host CPU's hardware virtualization extensions such as Intel VT-x and AMD-V.

The guest will not see VT-x/AMD-V, unless we're talking about an AMD CPU, and VirtualBox > 6.0.0 and Settings » System » Acceleration » Enable Nested Paging, are all enabled...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 23883
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Disabling VT-x

Postby GeorgeA7299 » 28. Apr 2019, 19:39

Thanks guys. You gave me all the information I needed.
GeorgeA7299
 
Posts: 2
Joined: 27. Apr 2019, 19:17


Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 7 guests