Weird mouse behavior with VirtualBox 6.0.6 upgrade (#18567)

This is for discussing general topics about how to use VirtualBox.

Weird mouse behavior with VirtualBox 6.0.6 upgrade (#18567)

Postby Greg Bailey » 17. Apr 2019, 00:14


ModEdit; related ticket: #18567: mouse is eratic in Windows 10 after update 6.04 >>> 6.06

Reports so far

    Reporter            Host        Guest           Monitors (HiDPI)
    ----------------------------------------------------------
    Greg Bailey Win10 C7.6-64
    notandor F29-64 Win7 2 (?)
    dciarnie F29 Win10/U18.04 (?)
    NickP Win10x64 M19/Raspbian 2 (?)
    spike6479 - - 2 (?)
    karolbe Suse15 WinXP/7x64 2 (?)
    mahansbane/*seeker - Win10 5 (?)
    *Jurg Mint Win10 (?)
    *proof Win10 Win7 (?)
    *reinhard Mint18.3 Win7 (?)
    *Spike - Win7 2 (?)
* = from the bugtracker


Host: VirtualBox 6.0.6 Windows 10 Enterprise
Guest: CentOS 7.6.1810 (3.10.0-957.10.1.el7.x86_64 kernel) with VirtualBox 6.0.4 guest additions running MATE 1.16 desktop from EPEL

After upgrading the Windows 10 host from VirtualBox 6.0.4 to VirtualBox 6.0.6, the mouse is behaving erratically, in that clicks don't appear to register correctly.

A left-button single click on an item in the panel would normally launch an app, but now it appears to turn the icon grey (as if perhaps only the click-down was registered?) A right mouse click brings up the usual menu, and then using the left mouse button appears to select items from that pop-up menu. Clicking the left mouse button on the background, the panel, and on menus usually doesn't appear to have any effect.

This seems similar to viewtopic.php?f=3&t=90267 and I've tried the workaround for that issue by logging out and back in, but the problem is still there.

I've changed nothing on the guest VM -- it's still running guest additions 6.0.4.
Last edited by socratis on 19. Apr 2019, 03:21, edited 2 times in total.
Greg Bailey
 
Posts: 11
Joined: 2. Nov 2007, 18:47
Location: Phoenix, AZ, US

Re: Weird mouse behavior with VirtualBox 6.0.6 upgrade

Postby notandor » 17. Apr 2019, 09:37

Yep, confirm same overhere
host fedora 29 5.0.7-200.fc29.x86_64
guest w7 ga 6.0.4 & 6.0.6

This is with 2&3D enabled and dual monitor. Staretd with vboxvga and later tried svga without luck. Now @6.04, will make a log later and try single monitor.

in "scaled mode" the mouse works correct.

Just tried 6.0.6 on a laptop (single screen) with the same result: weird mouse. So it's also on single screen.
Last edited by notandor on 24. Apr 2019, 11:42, edited 3 times in total.
notandor
 
Posts: 2
Joined: 17. Jan 2017, 21:16

Re: Discuss the 6.0.6 release

Postby socratis » 17. Apr 2019, 10:11

@Greg Bailey, notandor
I merged your "Weird mouse behavior with VirtualBox 6.0.6 upgrade" thread with the "Discuss the 6.0.6 release". That's where it should be in the first place.
Turns out that the thread needed a life of its own, too many reports to guarantee a stand-alone thread.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25221
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Discuss the 6.0.6 release

Postby dciarnie » 18. Apr 2019, 04:09

As somebody else found, the mouse is seriously broken in this release.
I have both a Windows 10 guest and an Ubuntu 18.04 guest running on an up to date Fedora 29 host. Mouse clicks are pretty much ignored in both guests making things basically unusable.
Everything works just fine with 6.0.4.
dciarnie
 
Posts: 2
Joined: 30. Apr 2017, 02:18

Mouse buttons in Linux guests not working after 6.0.6 upgrade

Postby NickP » 18. Apr 2019, 08:17

I have two Linux guests (Mint 19 and Raspbian Stretch) on a Windows 10 x64 host. The mouse buttons in both VMs work fine with Virtualbox 6.0.4, but as soon as I upgrade to 6.0.6, the mouse buttons stop working in both guests - the mouse pointer is still active in the window, because if I pause the mouse over a tray icon, I get the tooltip, but neither mouse button works. This problem happens both before and after installing the 6.0.6 guest additions. I downloaded both the 6.0.6 install exe and extpack files a second time, and ran a binary compare on the two downloads, which found no differences, so I don't think the files were corrupted during the download.

I first encountered the problem with running the VMs under 6.0.6 but before the 6.0.6 guest additions had been installed, so I installed the 6.0.6 guest additions in the VMs, but that didn't fix the problem. So I closed the guests, restored the VMs from backup, uninstalled Virtualbox 6.0.6, installed 6.0.4 and 6.0.4 extpack, ran the guests, and confirmed that the mouse worked correctly. Closed the guests and installed 6.0.6 and 6.0.6 extpack. On running the VMs, the mouse buttons in neither VM worked. I shut down the VMs, which had not had the 6.0.6 guest additions installed in them, uninstalled 6.0.6 and reinstalled 6.0.4, and the mouse buttons in the VMs now work correctly.

Anyone else had a similar problem? For the moment I'm obviously sticking with 6.0.4.
NickP
 
Posts: 11
Joined: 6. Nov 2013, 06:10

Re: Discuss the 6.0.6 release

Postby socratis » 18. Apr 2019, 09:04

@NickP
I merged your topic with the "Discuss the 6.0.6 release", since this is a 6.0.6 specific issue. a similar thread.

NickP wrote:Anyone else had a similar problem?

9 reports with 11 reporters so far:
  1. Greg Bailey (the very first reply to this thread)
  2. notandor
  3. dciarnie
  4. Nick P
  5. spike6479
  6. karolbe
  7. User 'nine76evil' from the IRC last night, Manjaro 18 host, Whonix-XFCE Workstation.
  8. Ticket #18567: mouse is eratic in Windows 10 after update 6.04 >>> 6.06 with 3 additional reporters; Jurg, proof, reinhard
  9. Ticket #18573: Mouse buttons not working on monitor 2.
I tried to replicate the last config (nine76evil) on two hosts (OSX 10.11.6, Win10-64 1809), just because I already had the VM, and couldn't replicate it. I have also been running a barrage of hosts/guests combinations since 6.0.6 came out, but I haven't seen that weird mouse behavior.

Which begs the question; why I don't see it, and 4 other independent users do. What's the common denominator? Going with a hunch, my gut feeling, I think that it might be a combination of 3D acceleration and the vGPU (Graphics Controller). I'm coming from the pre-6.0.x era, so all my VMs are using 3D=on/vGPU=VBoxVGA (the older one). What are the rest of you using, can we make a works/fails matrix?

Actually it would be best if each of you posted a complete VBox.log, from a complete VM run, where the problem occurs:
  • Start the VM from cold-boot (not from a paused or saved state) / Observe problem / Shutdown the VM (force close it if you have to).
  • With the VM completely shut down (not paused or saved), right-click on the VM in the VirtualBox Manager and select "Show Log".
  • Save only the first "VBox.log", ZIP it and attach it to your response. See the "Upload attachment" tab below the reply form.
Image

 Edit: Updated report/reference count 
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25221
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Mouse buttons in Linux guests not working after 6.0.6 upgrade

Postby spike6479 » 18. Apr 2019, 14:18

NickP wrote:The mouse buttons in both VMs work fine with Virtualbox 6.0.4, but as soon as I upgrade to 6.0.6, the mouse buttons stop working in both guests

I am having very similar problems with 6.0.6. The problem only occurs when the VM screen is on monitor 2. If I move the screen to monitor 1 (the main monitor) every thing works fine.
spike6479
 
Posts: 2
Joined: 18. Apr 2019, 14:14

Re: Discuss the 6.0.6 release

Postby karolbe » 18. Apr 2019, 21:49

After upgrade to 6.0.6 my Windows VMs (XP and 7) are unusable, mouse is behaving incorrectly when VirtualBox window is on the secondary monitor. When I move the window to the primary monitor all seems to be OK. Pretty bizarre situation.

On the secondary monitor symptoms are following.

When the mouse pointer is on the right part of the screen of the secondary monitor all is OK, however on the left part of the screen of the secondary monitor following things happen:
  • mouse pointer is not visible, it shows up for a moment when I click left mouse button, then when I move it it disappears again
  • seems like left mouse button is swapped with the middle mouse button, so e.g. when I am trying to log into Windows and I left click on the password text field it does not get focused, I have to press middle mouse button. On the Windows desktop when I press left mouse button I can see the rectangle selection being drawn on the screen, I am unable to click on any of the icons etc.
  • when I disable mouse integration it improves a bit - mouse buttons behave properly, but then the mouse pointer moves only on parts of the screen e.g. just 2/3 to the right, or it gets limited to the left part of the screen.
Everything was working fine prior to 6.0.6 upgrade, obviously I have the latest Guest Additions etc.

UPDATE:
I have just downgraded to 6.0.4 and all is behaving normally again.
Attachments
Windows7 -Work-CURRENT-2019-04-18-21-34-28.log
(88.73 KiB) Downloaded 23 times
karolbe
 
Posts: 6
Joined: 5. May 2008, 12:40

Re: Weird mouse behavior with VirtualBox 6.0.6 upgrade (#18567)

Postby socratis » 18. Apr 2019, 22:00

@karolbe
I merged your post with the thread dealing with the subject.

PS. For future reference you should ZIP your logs. It helps you, it helps us, it helps the server, it helps save a (virtual) tree or two... ;)
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25221
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Weird mouse behavior with VirtualBox 6.0.6 upgrade (#18567)

Postby mahansbane » 19. Apr 2019, 02:40

I have the same problem, when I upgraded from 6.0.4 to 6.0.6; my mouse buttons do not work on the Windows 10 guests, however, only on my primary monitor in full screen or seamless mode. I have a five monitor set up and the guests work normally on the other 4 monitors (including in full screen and seamless modes). This is an inconvenience that I hope is corrected soon. If one has questions let me know. Thanks for your time.
mahansbane
 
Posts: 3
Joined: 19. Apr 2019, 02:36

Re: Mouse buttons in Linux guests not working after 6.0.6 upgrade

Postby NickP » 19. Apr 2019, 02:54

spike6479 wrote:I am having very similar problems with 6.0.6. The problem only occurs when the VM screen is on monitor 2. If I move the screen to monitor 1 (the main monitor) every thing works fine.

I'm running two monitors, so after seeing this I checked, and I can replicate this behaviour. If I drag the VM to monitor 1, no problem with the mouse at all.

Edit: on my system, the mouse problem on monitor 2 with VMs under 6.0.6 seems to be because I had the scale set to 150% - I have two equal physical size monitors, but monitor 1 is 2560x1600 resolution and monitor 2 is 3840x2160 resolution, so I had monitor 2 set to 150% scale so that GUI elements were approximately the same size on both monitors. If I set monitor 2 to 100% scale, then I have no mouse problems with the VMs on either monitor, but I then have GUI elements appearing too small for comfort on monitor 2.

I've attached the log from a Raspberry Pi session with the problem.
Attachments
Raspberry Pi-2019-04-19-12-08-17.zip
(26.92 KiB) Downloaded 11 times
Last edited by NickP on 19. Apr 2019, 04:11, edited 2 times in total.
NickP
 
Posts: 11
Joined: 6. Nov 2013, 06:10

Re: Weird mouse behavior with VirtualBox 6.0.6 upgrade (#18567)

Postby socratis » 19. Apr 2019, 03:34

I'm starting to see what's going on here. Everyone that mentioned a 2nd (or more) monitor, is reporting a problem. I've made a summary at the first post of what I could gather from the information... :?
socratis wrote:If only someone listened and posted a VBox.log...

You can at least confirm that this is a multiple-monitor issue, that seems to affect a whole lot of different host/guest combinations.

I just need to to confirm the following and/or fill in the missing gaps:
  • Host: Complete details. Version/Build/Revision/Bits. Win10 is not an OS, it's a family.
  • Guest: Same as the host.
  • Monitors: How many, HiDPI or not, and where/how do you lose the mouse.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25221
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Mouse integration strange behaviour in full screen mode

Postby leenux_tux » 19. Apr 2019, 09:55

Hello Forum,

A few details of the config first...
Host, Linux Mint Rosa 17.3
Guest, Windows 7
VirtualBox version 6.0.6r130049, QT5.6.1 (recently upgraded from 5.2)

I have a really strange issue whereby the mouse just does random clicks (sometime left, sometimes right) inside the Windows guest when moving the mouse and trying to click on things. Sometimes trying to click on the start button highlights all of the shortcuts on the desktop, all very strange. This only happens in full screen mode, as soon as I hit right-ctrl + F to exit full screen mode everything works perfectly. I have the latest edition of the guest additions installed as well. Has anyone else seen this problem and, if they have, how did they fix it ? I have been trawling through the forum (and google of course) but have not found anyone who has had this exact issue.

Thx
leenux_tux
 
Posts: 3
Joined: 19. Apr 2019, 09:26

Re: Mouse integration strange behaviour in full screen mode

Postby socratis » 19. Apr 2019, 10:06

@leenux_tux
Do you have two monitors by any chance? It appears that there's a issue with 2 monitors and 6.0.6, see "Weird mouse behavior with VirtualBox 6.0.6 upgrade (#18567)".

We need to see a complete VBox.log, from a complete VM run, where the problem occurs:
  • Start the VM from cold-boot (not from a paused or saved state) / Observe problem / Shutdown the VM (force close it if you have to).
  • With the VM completely shut down (not paused or saved), right-click on the VM in the VirtualBox Manager and select "Show Log".
  • Save only the first "VBox.log", ZIP it and attach it to your response. See the "Upload attachment" tab below the reply form.
Image
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25221
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Erratic mouse behavior after 6.0.6 update

Postby geneing » 20. Apr 2019, 00:20

After updating to 6.0.6 mouse behavior is erratic (Win host, Ubuntu 18.04 guest). It behaves as if the mouse button is pressed at random times. Downgrading to 6.0.4 resolved the issue. Wanted to give the heads up after wasting several hours debugging this issue.
geneing
 
Posts: 2
Joined: 29. Dec 2010, 07:21
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: OpenSuSE

Next

Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 17 guests