Unable to see USB storage on VB 5.2.22 using filters

This is for discussing general topics about how to use VirtualBox.

Unable to see USB storage on VB 5.2.22 using filters

Postby lvskiprof » 15. Jan 2019, 01:10

This used to work with a previous version, but has been broken since the update. I have a USB 3.0 128GB Patriot stick that I often use to transfer files. I also have a Delock USB 3.0 CFast reader that I am using. I had created filters for both in the earlier version and they worked fine, but now they fail to attach the device when I select them from the USB list of filters.

Host OS is Windows 10 and the guest OS is Ubuntu 16.04 64-bit, running on a laptop with an i7 CPU.

I have also tried editing the USB filters, or making them enabled by default, but any attempt to change them gets this error when you click OK to save:
Failed to save the settings.

Empty or null bridged interface name is not valid.

Result Code: E_FAIL (0x80004005)
Component: NetworkAdapterWrap
Interface: INetworkAdapter {e925c2aa-4fe4-aaf6-91c5-e9b8ea4151ee}
Attachments
VBox.zip
Log for starting VM, plugging in Delock device after being logged in and waiting a minute for something to happen, selecting it from USB filter list and waiting a minute, selecting a second time from filter list (gets error immediately), and shutting down VM. Also output from VBoxManage commands requested.
(31.15 KiB) Downloaded 13 times
Last edited by socratis on 15. Jan 2019, 01:43, edited 1 time in total.
Reason: Enclosed the information in [quote] tags for better readability.
lvskiprof
 
Posts: 12
Joined: 10. Aug 2009, 18:55
Location: Las Vegas, NV
Primary OS: MS Windows other
VBox Version: OSE other
Guest OSses: Windows XP, Windows 7, Ubuntu, Red Hat

Re: Unable to see USB storage on VB 5.2.22 using filters

Postby socratis » 15. Jan 2019, 04:01

lvskiprof wrote: I had created filters for both in the earlier version and they worked fine
You need to re-read #4: USB Filters of the USB basics and troubleshooting thread. You have too many values defined.

lvskiprof wrote: but now they fail to attach the device when I select them from the USB list of filters.
What does that mean? Select what from where? Are you maybe confusing the "On-the-fly" with the "filter" method? See #2: Capturing a USB device in VirtualBox, same thread.

lvskiprof wrote:but any attempt to change them gets this error when you click OK to save:
That's because there's something wrong with your settings. It actually tells you which part.

PS. I didn't see the device(s) being plugged as described in #8: Asking for help, did you follow the instructions exactly?
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 26729
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 20 guests