Nested virtualization/AMD-V in the guest: Success stories (and failures)

This is for discussing general topics about how to use VirtualBox.

Re: Nested virtualization/AMD-V in the guest: Success stories (and failures)

Postby socratis » 9. Dec 2019, 11:59

Bidyut wrote:I was wondering how virtual box VM inside ESXi VM (ESXi v6.5) was working fine when virtual box version was 5.1.30
I was doing nested virtualization for years. The question is "what" nested virtualization.

Because if you're talking about running a FreeDOS VM, it was working. I'm not sure if it's going to work anymore, now that "raw" mode has been deprecated and VT-x is required even for smallest of the VMs...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Site Moderator
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Nested virtualization/AMD-V in the guest: Success stories (and failures)

Postby HulkySulky » 28. Jan 2020, 08:05

Here's my (failure) story. Basically (at least with Debian 10) it's not working. It's on an Intel laptop, not AMD, but since 6.1 Intel's CPU are supposed to be supported by VirtualBox for nested virtualization.

Physical Host :
- Processor : Intel Core i7-10510U @1.80GHz (1 proc, 4 cores, 8 threads)
- RAM : 16GB
- OS : Debian 10.2 (latest)
- VirtualBox 6.1.2 r135662 (latest) with extension pack installed

Guest :
- 4 CPU
- 10GB RAM
- OS : Debian 10
- Guest Additions installed
- VirtualBox 6.1.2 r135662 with nested VT-x/AMD-V enabled and extension pack installed

Nested Guest :
- 2 CPU

I tried a fresh installation of Debian 10 into the nested guest. At first, the installation process seems to start (I get to the screen where you have to choose the installation type), but right after that it freezes both the guest and the nested guest. In the physical host I can see 100% workload on half of the processors. I waited for 10 minutes, then I killed the guest.

Second try : I migrated a Win7 VM into the guest. Same result, after starting the nested guest (Win7), Windows starts but doesn't reach the login screen. Soon both the nested guest (Win7) and the guest (Debian 10) are frozen, with 100% workload on half of the physical host's processors. Waited for 10 minutes, then killed the guest.
Posts: 1
Joined: 28. Jan 2020, 06:24

Re: Nested virtualization/AMD-V in the guest: Success stories (and failures)

Postby Bidyut » 6. Apr 2020, 09:02

This is working in v6.1.4 whereas it was not in v6.0.4 because intel h/w support is enabled from 6.1.x
Posts: 10
Joined: 19. Aug 2018, 15:52

Re: Nested virtualization/AMD-V in the guest: Success stories (and failures)

Postby virtualboi » 25. May 2020, 20:49

Exactly same story as @HulkySulky here.

I'm attempting triple Ubuntu 20.04 on an Intel laptop. On starting the nested VM, the guest-host freezes completely. I've tinkered with all the settings I can find, but never gotten anywhere near a working nested VM. I have achieved the same set up with QEMU however - it works smoothly. Am I right in assuming the Intel support isn't fully implemented yet? I notice you still have to use the CLI to enable nested VT-x.
Posts: 1
Joined: 25. May 2020, 20:43

Re: Nested virtualization/AMD-V in the guest: Success stories (and failures)

Postby vbart2020 » 6. Jul 2020, 13:32

Hi, did anyone here ran nested virtualization with Win10 and Docker? I have this configuration: ArchLinux host -> VirtualBox 6.1.10 -> Win10 May 2020 build -> Docker on Windows? I get Docker errors. When I choose for VirtualBox machine KVM or Hyper-V for paravirtualization Docker reports that virtualization disabled. Task Manager under Windows shows that it is a virtual machine. When I choose None for paravirtualization, Windows shows that it is not a virtual machine and virtualization enabled (in Task Manager) but Docker reports "hardware assisted virtualization and data execution protection must be enbled in the BIOS" (in Win those features enabled: Virtual Machine Platform, Hyper-V, WSL).
Posts: 1
Joined: 6. Jul 2020, 13:22

Re: Nested virtualization/AMD-V in the guest: Success stories (and failures)

Postby CodingNinja » 23. Oct 2020, 17:40

Hi All, I have an AMD cpu and windows 10 host. I am trying to create a windows 10 VM by downloading the image from microsoft website. I am getting the attached issue. By checking some articles online, i enabled VT-x/AMD-v and enable PAE/NX as well. still its giving same issue. I do not know more about virtual box to give you any log file. please let me know whatelse u might require to help me resolve this issue.
the setting
winvmissue_2.JPG (44.27 KiB) Viewed 1598 times
the issue
winvmissue.JPG (118.51 KiB) Viewed 1598 times
Posts: 1
Joined: 23. Oct 2020, 16:53


Return to Using VirtualBox

Who is online

Users browsing this forum: Google [Bot] and 7 guests