No sound from any guest OS (#17076)

This is for discussing general topics about how to use VirtualBox.

No sound from any guest OS (#17076)

Postby MarkX » 25. Aug 2017, 16:37


[ModEdit, related ticket #17076: No sound from any guest OS]

Hi,
I have VB5.1.26 on a Windows 8.1 Host. I use Ubuntu 10.? and Ubuntu 16.04.03 LTS and Windows 7 guests. I don't hear any sounds from any of the guests.
Sounds work fine on the Host OS.
I have configured the guests to Enable Audio and use Windows DirectSound with Intel HD Audio. I have also tried AC97. This problem has existed for me for a long time, also with older versions of VB. I have looked at the Manual, FAQs and web guides, but they don't help.
Last edited by socratis on 12. Sep 2017, 18:04, edited 1 time in total.
Reason: Added ticket related information.
MarkX
 
Posts: 8
Joined: 25. Aug 2017, 16:32

Re: No sound from any guest OS

Postby socratis » 25. Aug 2017, 16:48

Pick a VM, let's say Win7. Follow a "start the VM from cold-boot" / "observe error" / "shutdown the VM" cycle. With the VM shut down completely (not paused or saved), right-click on the VM in the VirtualBox Manager and select "Show Log". Save only the first "VBox.log", ZIP it and attach it to your response (see the "Upload attachment" tab below the reply form).
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 12665
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: No sound from any guest OS

Postby MarkX » 25. Aug 2017, 17:13

Here it is.
Attachments
log.zip
(27.9 KiB) Downloaded 57 times
MarkX
 
Posts: 8
Joined: 25. Aug 2017, 16:32

Re: No sound from any guest OS

Postby socratis » 25. Aug 2017, 22:04

Here are the relevant parts of your VBox.log, with the last line I believe to be the most important (which I wrapped for readability). I, unfortunately, have no clue what it means, what causes it, or what might fix it. Let's hope someone else does:
00:00:03.179717 Audio: Initializing DirectSound audio driver
00:00:03.237376 DSound: Output: GUID: {89305DED-0456-4D79-9E4E-C6F3ABB1D713} [Speakers (Realtek High Definition Audio)] (Module: {0.0.0.00000000}.{89305ded-0456-4d79-9e4e-c6f3abb1d713})
00:00:03.237393 DSound: Output: GUID: {30112792-6F01-4F9B-8E2B-F33306F51CB3} [Realtek Digital Output (Realtek High Definition Audio)] (Module: {0.0.0.00000000}.{30112792-6f01-4f9b-8e2b-f33306f51cb3})
00:00:03.237401 DSound: Output: GUID: {CF499F28-E0ED-48D7-9843-32606B5A347B} [Realtek Digital Output(Optical) (Realtek High Definition Audio)] (Module: {0.0.0.00000000}.{cf499f28-e0ed-48d7-9843-32606b5a347b})
00:00:03.308041 DSound: Found 3 host playback devices
00:00:03.308053 DSound: Found 0 host capturing devices
00:00:03.308484 Audio: Host audio backend supports 3 output streams and 0 input streams at once
00:00:03.308516 Audio: Initializing VRDE driver
00:00:03.308526 Audio: Host audio backend supports 1 output streams and 2 input streams at once
00:00:03.308550 Audio: Skipping to create input stream "[LUN#0] hda.in", as the host audio
backend reached its maximum of concurrent audio input streams

Other than that, you may want to lower the number of vCPUs that you've assigned to your guest. You have 2 physical CPUs and you've assigned them both to your guest. But, this is not the source of your audio problem...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 12665
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: No sound from any guest OS

Postby MarkX » 26. Aug 2017, 13:24

Could this be down to Windows' Exclusive Mode?
(BTW: I have 4 cores in the CPU).
MarkX
 
Posts: 8
Joined: 25. Aug 2017, 16:32

Re: No sound from any guest OS

Postby socratis » 26. Aug 2017, 15:06

I don't know what Windows' Exclusive Mode is, but from a quick read, that might be it.
BTW, you have 2 physical cores. That's all VirtualBox cares about, not marketing booya...
00:00:03.330843 CPUM: Logical host processors: 4 present, 4 max, 4 online, online mask: 000000000000000f
00:00:03.330845 CPUM: Physical host cores: 2
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 12665
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: No sound from any guest OS

Postby MarkX » 26. Aug 2017, 16:34

It's an AMD A10-7850K CPU.
MarkX
 
Posts: 8
Joined: 25. Aug 2017, 16:32

Re: No sound from any guest OS

Postby socratis » 26. Aug 2017, 17:14

<sarcasm>
Oh, I'm sorry, I didn't realize...
You actually have 128 CPUs, but due to marketing, they only reveal 4.
You have to drink the magic potion to see the rest....
</sarcasm>
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 12665
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: No sound from any guest OS

Postby MarkX » 26. Aug 2017, 17:52

I really wish they wouldn't nobble CPUs like this.
FWIW I have disabled Audio exclusive mode but I still don't get sound in the Guest OSs.
MarkX
 
Posts: 8
Joined: 25. Aug 2017, 16:32

Re: No sound from any guest OS

Postby MarkX » 5. Sep 2017, 13:07

Anyone have any ideas how I can progress this issue?
MarkX
 
Posts: 8
Joined: 25. Aug 2017, 16:32

Re: No sound from any guest OS

Postby ChipMcK » 5. Sep 2017, 18:41

ChipMcK
Volunteer
 
Posts: 962
Joined: 20. May 2009, 02:17
Location: U S of A
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Windows, OSX

Re: No sound from any guest OS

Postby MarkX » 6. Sep 2017, 14:33

Thanks for the post, but I don't think it helps. I have tried Intel HD Audio as well as AC97 with the same results (i.e. no sound).
MarkX
 
Posts: 8
Joined: 25. Aug 2017, 16:32

Re: No sound from any guest OS (#17076)

Postby socratis » 12. Sep 2017, 18:05

Related ticket #17076: No sound from any guest OS.
Thanks MarkX for including a callback to the discussion in the ticket.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 12665
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: No sound from any guest OS (#17076)

Postby MarkX » 7. Dec 2017, 17:01

I haven't seen any more responses to this problem. Any ideas?
MarkX
 
Posts: 8
Joined: 25. Aug 2017, 16:32

Re: No sound from any guest OS (#17076)

Postby socratis » 7. Dec 2017, 17:19

It's not like it's fixable if you change a setting. There are fundamental problems with the audio, something that they're actively working on. Your best bet is to install the latest test builds and hope for the best. Patience my young padawan... ;)
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 12665
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to Using VirtualBox

Who is online

Users browsing this forum: Google [Bot], socratis and 13 guests