Browsing, the connection was reset

This is for discussing general topics about how to use VirtualBox.

Re: Browsing, the connection was reset

Postby abutler » 2. Nov 2016, 03:16

jsiponen wrote:
Code: Select all   Expand viewCollapse view
$  sudo apt-key adv --keyserver [server] --recv-keys 58118E89F3A912897C070ADBF76221572C52609D


I tried this 10-15 times on my ubuntu guests (one xenial and one trusty) but this always failed with "Connection reset by peer".


Glad I finally found this thread! I've been trying to troubleshoot this all afternoon.

On Arch I was trying to run this and getting connection reset by peer as well:
Code: Select all   Expand viewCollapse view
gpg --recv-keys --keyserver hkp://pgp.mit.edu 1EB2638FF56C0C53


I also got weird issues with using apm (Atom's package manager) when trying to install packages. Same commands work just fine on a real install of Arch or OS X, but not in Virtualbox.
abutler
 
Posts: 2
Joined: 2. Nov 2016, 03:11

Re: Browsing, the connection was reset

Postby socratis » 3. Nov 2016, 23:22

For those of you not subscribed to #16084:
vushakov wrote:Please, can you test a recent 5.1 test build (111724 or later)?

It worked in my case, but please test it yourselves.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 24684
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Browsing, the connection was reset

Postby Poil » 4. Nov 2016, 15:55

Hi,

With latest testing build I still have some connection reset (not on all website) on h.t.t.p.s.

Best regards
Poil
 
Posts: 10
Joined: 4. Nov 2016, 11:35

Re: Browsing, the connection was reset

Postby socratis » 4. Nov 2016, 17:04

@Poil
Can you provide an example (or two) ?
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 24684
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Browsing, the connection was reset

Postby abutler » 7. Nov 2016, 09:04

Test build seems to have fixed my problems (gpg key retrieval and installing apm packages).
abutler
 
Posts: 2
Joined: 2. Nov 2016, 03:11

Re: Browsing, the connection was reset

Postby socratis » 7. Nov 2016, 09:09

@abutler
Thank you for the reply. I'll post an update in the main bug report (#16084) so that the developers know.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 24684
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Browsing, the connection was reset

Postby Poil » 10. Nov 2016, 16:50

Hi,

My problem is on a confluence instance where there are lot off ajax request, for the moment I can't reproduce on another website

Best regards
Poil
 
Posts: 10
Joined: 4. Nov 2016, 11:35

Re: Browsing, the connection was reset

Postby Richlv » 12. Nov 2016, 03:25

can confirm that 5.0.28 (macos host, linux guest) had network issues; "5.0.x revision 111848" works ok
Richlv
 
Posts: 2
Joined: 11. Nov 2016, 01:17

Re: Browsing, the connection was reset

Postby Poil » 14. Nov 2016, 12:04

Hi,

I think I've found when I have a connection reset with the 5.1.19 release.
All websites where I have a connection reset have a KeepAlive Off

Best regards

*EDIT* :
My support team have enable "KeepAlive" on our Confluence instance. I have no more problem with virtualbox.
So when we have multiple SSL negociation we still have a problem on 5.1.19

*EDIT 2*
I've also had the problem on a Rundeck and a Request Tracker instance, it is also fixed after the configuration of KeepAlive on Apache
Poil
 
Posts: 10
Joined: 4. Nov 2016, 11:35

Re: Browsing, the connection was reset

Postby phliKtid » 18. Nov 2016, 19:11

this appears to be pretty well defined at this point, but i just wanted to add that i have been experiencing this same problem once upgrading to 5.0.28 two or three weeks ago. i'm so happy i found this thread -- i was banging my head against the wall trying to figure out what was going on. my host is a mac mini running el capitan (10.11.6). i was seeing problems for some (but not all) websites in firefox. unfortunately, it was happening on the main website i use the vm for. furthermore, because of how firefox displays messages, i didn't have enough info to know what was happening at a communication level...just a generic error page that said the "secure connection failed", "the connection to the server was reset while the page was loading", and "the page you are trying to view cannot be shown because the authenticity of the received data could not be verified". not very helpful, and made me go down rabbit holes with site certs, ca trusts, etc. downgrading firefox to several different versions didn't help. i did that because at first i thought it might just be firefox (and i have to use firefox for this site/application). but then i realized the problems happen in chrome and ie also. this was happening on a win10 64-bit guest, but then i went back to a win7 32-bit guest and it was doing it there as well. from reading this thread, i switched my network setting from nat to bridged and that resolved it. looking forward to a new release with a fix.
phliKtid
 
Posts: 1
Joined: 18. Nov 2016, 18:33

Re: Browsing, the connection was reset

Postby f456 » 20. Nov 2016, 22:33

Just to chip in - had the same problem.

Fixed with latest testbuild Version 5.1.9 r111957 (Qt5.6.2).
f456
 
Posts: 54
Joined: 2. Sep 2012, 16:42

Previous

Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 14 guests