Discuss the 5.1.8 release

This is for discussing general topics about how to use VirtualBox.

Discuss the 5.1.8 release

Postby frank » 18. Oct 2016, 21:33

Discuss the 5.1.8 release here.
You can download the release here.
frank
Oracle Corporation
 
Posts: 3362
Joined: 7. Jun 2007, 09:11
Location: Dresden, Germany
Primary OS: Debian Sid
VBox Version: PUEL
Guest OSses: Linux, Windows

Re: Discuss the 5.1.8 release

Postby loukingjr » 19. Oct 2016, 00:41

I try not to whine in public however…
Running 5.1.8 on a macOS Sierra 10.12 host. The new version is actually worse than all previous 5.1 versions.
1. Audio is still screwed up in Windows 10 guests
2. Audio is now screwed up in Windows 7 guests
2. Audio is now screwed up in Ubuntu guests (out of sync).
3. For some reason it takes an inordinate amount of time to install the GAs in Windows 7 guests.

That's what I've checked just so far.

To be honest I had uninstalled VB from my Macs after installing what seems like a dozen 5.1.7 test builds. I thought I would try 5.1.8.
Maybe another time.
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8827
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: Discuss the 5.1.8 release

Postby marcthin » 19. Oct 2016, 12:17

I am not able to use Oracle 5.1.8 release because in my linux guests (50 distributions) is het not possible to play YouTube video's and flash video's. I am now downgradet to release 5.1.2 and that release works 100 % voor al my distributions. My host is windos 10 1607.
marcthin
 
Posts: 23
Joined: 18. Jul 2015, 09:43

Re: Discuss the 5.1.8 release

Postby pentagonik » 19. Oct 2016, 15:10

@loukingjr

1. Audio is still screwed up in Windows 10 guests
2. Audio is now screwed up in Windows 7 guests
2. Audio is now screwed up in Ubuntu guests (out of sync).


Can you please elaborate what exactly is "screwed up" for you and how to reproduce? Thanks!
pentagonik
Oracle Corporation
 
Posts: 275
Joined: 19. May 2008, 16:09
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Too many to specify!

Re: Discuss the 5.1.8 release

Postby loukingjr » 19. Oct 2016, 15:18

Probably the easiest thing to notice is play any music video on YouTube. The audio in Windows 10 quickly goes out of sync with the video and Spotify is slightly garbled.

For the other guests, the video and audio are no longer in sync. I didn't play it for long but in my Windows 7 guest, if you play something with audio after 5 mins or so the audio creates it's own noise in the background.

edit: I forgot to mention the tempo is too fast in Windows 10 guests.
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8827
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: Discuss the 5.1.8 release

Postby Organic_Marble » 19. Oct 2016, 18:08

Has anyone confirmed that the snapshot deletion problem is fixed? The release notes show that it should be, but I would like someone to weigh in before I go down that path.
Organic_Marble
 
Posts: 15
Joined: 20. Aug 2016, 02:44
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Ubuntu Win98 WinXP Win7

Re: Discuss the 5.1.8 release

Postby socratis » 19. Oct 2016, 20:30

Organic_Marble wrote:I would like someone to weigh in before I go down that path.

Why don't you create a full clone of the VM that you're afraid of messing up and try it out? It's faster and 100% guaranteed that you'll know if it works or not.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25932
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Discuss the 5.1.8 release

Postby Papolytic » 19. Oct 2016, 21:04

Organic_Marble wrote:Has anyone confirmed that the snapshot deletion problem is fixed? The release notes show that it should be, but I would like someone to weigh in before I go down that path.

Hi - Snapshot deletion has worked fine since a couple beta builds back and is fine on a Ubuntu VM with 4 VDI's and also a W10 VM with 4 VDI's in 5.1.8.
Papolytic
 
Posts: 52
Joined: 15. Apr 2013, 02:01

Re: Discuss the 5.1.8 release

Postby hd » 19. Oct 2016, 22:18

Can anyone shed some light on this point in particular:
  • Storage: some fixes for the NVMe emulation with Windows guests

I've tested with 5.1.6 and 5.1.8 now on a mixed use nvme, and the performance is limited by something, but this update does not seem to address that.

In 5.1.8 my NVME experience is summarized here: https://i.imgur.com/ZRUKpyg.png
For 5.1.6 I posted a thread asking for some feedback here, which shows similar performance issues.
hd
 
Posts: 6
Joined: 11. Oct 2016, 22:13
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: XP, W10Pro

Re: Discuss the 5.1.8 release

Postby michaln » 20. Oct 2016, 10:13

hd wrote:For 5.1.6 I posted a thread asking for some feedback here, which shows similar performance issues.

The NVMe emulation is still very new and has not been tuned. If it does not satisfy your requirements, don't use it.
michaln
Oracle Corporation
 
Posts: 2958
Joined: 19. Dec 2007, 15:45
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Any and all

Re: Discuss the 5.1.8 release

Postby Organic_Marble » 20. Oct 2016, 15:49

Papolytic wrote:
Organic_Marble wrote:Has anyone confirmed that the snapshot deletion problem is fixed? The release notes show that it should be, but I would like someone to weigh in before I go down that path.

Hi - Snapshot deletion has worked fine since a couple beta builds back and is fine on a Ubuntu VM with 4 VDI's and also a W10 VM with 4 VDI's in 5.1.8.


Thanks very much.
Organic_Marble
 
Posts: 15
Joined: 20. Aug 2016, 02:44
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Ubuntu Win98 WinXP Win7

Re: Discuss the 5.1.8 release

Postby Organic_Marble » 20. Oct 2016, 15:49

socratis wrote:
Organic_Marble wrote:I would like someone to weigh in before I go down that path.

Why don't you create a full clone of the VM that you're afraid of messing up and try it out? It's faster and 100% guaranteed that you'll know if it works or not.


Because I would have to install the new version of VirtualBox, wiping out the one that works, and then do it all over again to restore it if it doesn't.
Organic_Marble
 
Posts: 15
Joined: 20. Aug 2016, 02:44
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Ubuntu Win98 WinXP Win7

Re: Discuss the 5.1.8 release

Postby BrianG61UK » 21. Oct 2016, 02:28

I run VirtualBox on a Windows 7 Ultimate 64 bit host.
I have just discovered that with VirtualBox 5.1.4, 5.1.6 and 5.1.8 my FreeDOS 1.1 VM will not start at all.
I am reverting to VirtualBox 5.1.2 for now.
I am attaching the log files and configuration of the VM.
The oldest log file "VBox.log.3" is one from when it last worked, the others are fails.

VirtualBox 5.1.8 FreeDOS 1.1 VM.zip
(74.07 KiB) Downloaded 15 times


Thanks in advance for any help you can offer.
BrianG61UK
 
Posts: 49
Joined: 21. Mar 2014, 02:15
Location: Reading. Berkshire. UK.
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows, DOS, Linux

Re: Discuss the 5.1.8 release

Postby socratis » 21. Oct 2016, 09:25

@BrianG61UK
You seem to have added two parallel ports in your VM, with the same exactly settings. Delete the line that is strikethrough from your .vbox file:
        <Port slot="0" enabled="true" IOBase="0x378" IRQ="7" path="LPT1"/>
<Port slot="
1" enabled="false" IOBase="0x378" IRQ="7" path="LPT1"/>


PS. FreeDOS runs fine here.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25932
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Discuss the 5.1.8 release

Postby BrianG61UK » 21. Oct 2016, 16:19

socratis wrote:@BrianG61UK
You seem to have added two parallel ports in your VM, with the same exactly settings. Delete the line that is strikethrough from your .vbox file:
        <Port slot="0" enabled="true" IOBase="0x378" IRQ="7" path="LPT1"/>
<Port slot="
1" enabled="false" IOBase="0x378" IRQ="7" path="LPT1"/>


PS. FreeDOS runs fine here.

I never really looked closely in there before.
There's a lot of stuff that doesn't really make any sense.
Why on earth are there 8 network cards, each with a unique MAC address?

The line you said to delete seems to be present in the configuration of all my VMs, even ones where I'm pretty sure I have never asked for any LPT ports, so it can't be there because I issued a strange VBoxManage command. It's there on VM's I set up completely through the GUI.
BrianG61UK
 
Posts: 49
Joined: 21. Mar 2014, 02:15
Location: Reading. Berkshire. UK.
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows, DOS, Linux

Next

Return to Using VirtualBox

Who is online

Users browsing this forum: DbaDavid, Google [Bot] and 14 guests