Discuss the 5.0.10 release

This is for discussing general topics about how to use VirtualBox.

Discuss the 5.0.10 release

Postby frank » 10. Nov 2015, 23:03

Discuss the 5.0.10 release here. See the changelog for details.
frank
Oracle Corporation
 
Posts: 3362
Joined: 7. Jun 2007, 09:11
Location: Dresden, Germany
Primary OS: Debian Sid
VBox Version: PUEL
Guest OSses: Linux, Windows

Re: Discuss the 5.0.10 release

Postby johnlee » 11. Nov 2015, 00:01

Can confirm that the problem I reported re 5.0.8 where the vb vm manager didn't start after installation on win 7 64 is fixed. Thanks.

john
johnlee
 
Posts: 41
Joined: 30. Mar 2012, 20:07

Re: Discuss the 5.0.10 release

Postby trekfan1 » 11. Nov 2015, 09:37

And most important (and not mentioned in changelog) on ubuntu 15.10 (wily) or higher the dependency of libvpx1 is removed
Sorry for my English, i'm Italian
trekfan1
 
Posts: 91
Joined: 13. May 2007, 07:22
Location: Italy
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: Discuss the 5.0.10 release

Postby frank » 11. Nov 2015, 16:58

Actually a Wily package was available for 5.0.8 as well. I mentioned it somewhere... :-)
frank
Oracle Corporation
 
Posts: 3362
Joined: 7. Jun 2007, 09:11
Location: Dresden, Germany
Primary OS: Debian Sid
VBox Version: PUEL
Guest OSses: Linux, Windows

Re: Discuss the 5.0.10 release

Postby Weekend Warrior » 11. Nov 2015, 21:46

32 bit guest additions install fails with a message about the installer failing the integrity check. 64 bit installs OK. Tried downloading and reinstalling additions package but it still fails. Host machine is opensuse 13.2 64 bit. Failed on 2 instances of Windows server 2008.
Weekend Warrior
 
Posts: 3
Joined: 11. Nov 2015, 21:44

Re: Discuss the 5.0.10 release

Postby frank » 12. Nov 2015, 11:43

Cannot reproduce any integrity problem with a Windows XP guest, the Guest Additions just install fine.
frank
Oracle Corporation
 
Posts: 3362
Joined: 7. Jun 2007, 09:11
Location: Dresden, Germany
Primary OS: Debian Sid
VBox Version: PUEL
Guest OSses: Linux, Windows

Re: Discuss the 5.0.10 release

Postby Giangi » 12. Nov 2015, 11:50

As suggested by @mpack here I'm reposting a problem I have with NAT on Win7 32bit with Forefront TMG client installed...

NAT isn't working anymore. I'm primarily using VB on a network which has Microsoft Forefront TMG as proxy/firewall (it's actually in the process to be replaced, probably by first months of 2016).

I do have full admin access on TMG and enabling the logging I do not see any errors but I do not see any "real traffic" too, just the start/close session

Googling I have found this bug report https://www.virtualbox.org/ticket/13292 where (what a surprise :cry: ) the hardening feature seems involved.

On my pc I have the Forefront TMG Client installed and enabled, could it be that its DLLs are being blocked?

In the logs there are many references to these DLLs, like the following.

1388.1bb0: supHardenedWinVerifyImageByHandle: -> 0 (\Device\HarddiskVolume2\Program Files\Forefront TMG Client\FwcWsp.dll) WinVerifyTrust
1388.1bb0: supR3HardenedWinVerifyCacheInsert: \Device\HarddiskVolume2\Program Files\Forefront TMG Client\FwcWsp.dll

1388.1bb0: supR3HardenedMonitor_LdrLoadDll: pName=C:\Program Files\Forefront TMG Client\FwcWsp.dll (rcNtResolve=0xc0150008) *pfFlags=0x0 pwszSearchPath=007c7b5c:C:\Program Files\Oracle\VirtualBox;C:\Windows\system32 [calling]
1388.1bb0: supR3HardenedScreenImage/NtCreateSection: cache hit (VINF_SUCCESS) on \Device\HarddiskVolume2\Program Files\Forefront TMG Client\FwcWsp.dll
1388.1bb0: supR3HardenedDllNotificationCallback: load 74bb0000 LB 0x001fc000 C:\Program Files\Forefront TMG Client\FwcWsp.dll [fFlags=0x0]
1388.1bb0: supR3HardenedScreenImage/LdrLoadDll: cache hit (VINF_SUCCESS) on \Device\HarddiskVolume2\Program Files\Forefront TMG Client\FwcWsp.dll
Attachments
Logs.zip
(54.52 KiB) Downloaded 109 times
Giangi
 
Posts: 43
Joined: 13. Aug 2013, 09:15
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: XP, Seven, Win10

Re: Discuss the 5.0.10 release

Postby Snail » 12. Nov 2015, 12:53

I updated on Fedora 23 this morning from 5.08 and I'm now getting and error upon launch regarding my Kali VM. Says warning one or more image files are currently not accessible.......

Even though the VM appears to run fine. It is the only image file and I'm also new to Linux & Virtualbox, be gentle please :D



EDIT:

Ignore, I have solved the problem and it was all my fault!
Snail
 
Posts: 1
Joined: 12. Nov 2015, 12:40

Re: Discuss the 5.0.10 release

Postby Magnus Madsen » 13. Nov 2015, 10:12

Using copyto or copyfrom functions from VBoxManage and the API is still broken in 5.0.10: https://www.virtualbox.org/ticket/14336
Magnus Madsen
 
Posts: 22
Joined: 11. Jun 2013, 08:35
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: WinXP, WinVista, Win7, Win8

Re: Discuss the 5.0.10 release

Postby Giangi » 13. Nov 2015, 12:49

Giangi wrote:As suggested by @mpack here I'm reposting a problem I have with NAT on Win7 32bit with Forefront TMG client installed...

NAT isn't working anymore. I'm primarily using VB on a network which has Microsoft Forefront TMG as proxy/firewall (it's actually in the process to be replaced, probably by first months of 2016).


Addendum, yesterday evening I have updated the two pc I have at home (a desktop and a laptop, both Win7 32 bit, both with McAfee VSE 8.8.0 patch) and the same guests (I keep them on an external USB disk) were able to navigate via NAT from my home network!

Please let mw know how can I help you understand what is wrong with Forefront TMG as proxy/firewall!
Giangi
 
Posts: 43
Joined: 13. Aug 2013, 09:15
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: XP, Seven, Win10

Re: Discuss the 5.0.10 release

Postby RonSMeyer1 » 13. Nov 2015, 23:00

Does not install on current Linux Mint 17.2 machines. Error: Dependency is not satisfiable: libdevmapper1.02.1 (>=2:1.02.99)

Now what?
RonSMeyer1
 
Posts: 23
Joined: 26. May 2012, 16:20
Primary OS: Linux other
VBox Version: PUEL
Guest OSses: Host: Linux Mint / Guests: Win7 32bit - Linux Mint - Win XP - Win 10 - OS/2 Warp 4 - MS-DOS

Re: Discuss the 5.0.10 release

Postby loukingjr » 14. Nov 2015, 02:39

RonSMeyer1 wrote:Does not install on current Linux Mint 17.2 machines. Error: Dependency is not satisfiable: libdevmapper1.02.1 (>=2:1.02.99)

Now what?

Download and install the "Trusty" version. You tried to install the "Wily" version.
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8827
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: Discuss the 5.0.10 release

Postby RonSMeyer1 » 14. Nov 2015, 16:18

Ok, thank you. Good grief, all these cutsie names to keep track of.
RonSMeyer1
 
Posts: 23
Joined: 26. May 2012, 16:20
Primary OS: Linux other
VBox Version: PUEL
Guest OSses: Host: Linux Mint / Guests: Win7 32bit - Linux Mint - Win XP - Win 10 - OS/2 Warp 4 - MS-DOS

Re: Discuss the 5.0.10 release

Postby loukingjr » 14. Nov 2015, 16:24

:lol: I know. You're Welcome.

Canonical's fault.
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8827
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: Discuss the 5.0.10 release

Postby johnlee » 10. Dec 2015, 16:31

Running windows vb from test builds v104456, win 7 64, fx 4300, 4 cpus, 4G memory

I run 2 vms, ubuntu 15.10 & xp on startup. All been ok for previous versions

After updating to 104602 the xp vm hangs on loading personal settings and whole host gets very slow all processors 100% then
illegal instruction at 0xe607124f at memory 0000000018 so reverted to 104456 - all ok again, so don't think it is me.

Think there were some changes from 104456 to 104602 to linux systemd startup but can't see any to win unless something is grabbing memory. Can't now try 104602 again. Any ideas?

J
johnlee
 
Posts: 41
Joined: 30. Mar 2012, 20:07

Next

Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 8 guests