Discuss the 4.3.22 release

This is for discussing general topics about how to use VirtualBox.

Re: Discuss the 4.3.22 release

Postby mpack » 28. Feb 2015, 11:03

Augmenting search engines doesn't seem to have worked: the first post of this discussion could hardly be clearer, yet people still post to this thread as if they haven't read it!
mpack
Site Moderator
 
Posts: 24461
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Discuss the 4.3.22 release

Postby Brutalizer » 2. Mar 2015, 13:36

Brutalizer wrote:I am running Solaris 11.2 as host. I have installed Win7 in a VM and it works fine. I have also cloned the VM but in the clone the sound does not work at all. Any clues?

I downgraded back to 4.3.10 and the sound works again. :)

UPDATE: the original VM has a working sound, whereas the clone has no sound.
Last edited by Brutalizer on 3. Mar 2015, 22:44, edited 1 time in total.
Brutalizer
 
Posts: 52
Joined: 7. Oct 2012, 18:24

Re: Discuss the 4.3.22 release

Postby g2flyer » 2. Mar 2015, 17:10

g2flyer wrote:
mpack wrote:@g2flyer: please discard the saved state associated with the VERR_NO_MEMORY VM. In future, best make sure VMs are fully shut down before you swap software versions from underneath them.

As i wrote, this time discarding saved state makes it work also for the future (not true in earlier versions).

Regarding your suggestion to do proactively shutdown all VMs before an upgrade is not a really good solution when you have lots of VM. And, more importantly, this was never necessary before the problem arrived in 4.3.18!!


Aargh, i was premature in saying the Failed to load unit 'pgm' (VERR_NO_MEMORY) happens now, contrary to 4.3.16-4.3.20, only the first time after the upgrade. While resuming seemed to work once after the discard of saved state and subsequent suspend, it now consistently fails again with following error

Code: Select all   Expand viewCollapse view
Failed to open a session for the virtual machine Win7 KVM.
Failed to load unit 'pgm' (VERR_NO_MEMORY).
Result Code: NS_ERROR_FAILURE (0x80004005)
Component: Console
Interface: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}


As the VM name indicates it is a windows 7 guest under ubuntu host. The guest has 3070MB RAM allocated and there is plenty of RAM left on my 16GB laptop (even considering that he host is a 32-bit PAE system and only ~3500 MB can be assigned max per VM). Note this same VM, even with more RAM assigned worked perfectly with 4.3.14 (to which i probably will have to fall back again ... :-()
g2flyer
 
Posts: 21
Joined: 15. Oct 2014, 05:26

Previous

Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 16 guests