Discuss the 4.3.18 release

This is for discussing general topics about how to use VirtualBox.

Re: Discuss the 4.3.18 release

Postby BrianG61UK » 13. Oct 2014, 18:20

michaln wrote:
socratis wrote:All SMP Windows guests cannot restart (I tried XP, 7, 8.1, 10). IO/APIC enabled (according to the linked post it helped, but I don't believe it matters).

Does this include 64-bit guests? Or did you only test 32-bit guests?


FWIW the only 64 bit guest I have at the moment is the Windows 10 Preview and it restarts okay.
BrianG61UK
 
Posts: 49
Joined: 21. Mar 2014, 02:15
Location: Reading. Berkshire. UK.
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows, DOS, Linux

Re: Discuss the 4.3.18 release

Postby loukingjr » 13. Oct 2014, 19:08

I have a Windows 7 and Windows 10 64bit guest and they restart without issue.
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8827
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: Discuss the 4.3.18 release

Postby kastecno » 15. Oct 2014, 00:01

Anybody could help with a problem that I have with the virtual machine. I get a message " critical error occurred during the execution of the virtual machine already been stopped" I have Windows 8.1 in my computer and I have installed in virtual machine windows 7.
Last edited by kastecno on 15. Oct 2014, 06:16, edited 2 times in total.
kastecno
 
Posts: 1
Joined: 14. Oct 2014, 23:53

Re: Discuss the 4.3.18 release

Postby g2flyer » 15. Oct 2014, 05:41

Since upgrading to 4.3.18 (from 4.3.16) i have trouble resuming some VMs from saved state where i get a "Failed to load unit 'pgm' (VERR_NO_MEMORY)." error. I can boot iff i drop the saved state; in fact, i can even save and resume a few times before i run into the problem again! I definitely more than enough free memory according to "free" and the filesystem where the VMs reside also has free space. My host is a 32-bit (PAE) Ubuntu 14.04 (running with kernel 3.17.0-031700-generic) and the problem guest a 64-bit Win7 with 3GB of RAM (whereas a 3.5GB 64-bit Ubuntu guest seems to restore without problems). Note this has never happened with earlier VB versions. The error entries in the log file ..

0:00:55.170447 AssertLogRel /home/vbox/vbox-4.3.18/src/VBox/VMM/VMMR3/PGMPhys.cpp(4470) int PGMR3PhysAllocateHandyPages(PVM): RT_SUCCESS(rc)
00:00:55.170477 95/128: idPage=0x369400 HCPhysGCPhys=0000000212915000 rc=VERR_NO_MEMORY
00:00:55.170490 AssertLogRel /home/vbox/vbox-4.3.18/src/VBox/VMM/VMMR3/PGMSavedState.cpp(2789) int pgmR3LoadMemory(PVM, PSSMHANDLE, uint32_t, uint32_t): RT_SUCCESS_NP(rc)
00:00:55.170497 GCPhys=00000000ad73b000 Z--:RAM:0003a847b000:0000000:-0000 rc=VERR_NO_MEMORY
00:00:55.170508 SSM: LoadExec failed for 'pgm' instance #1 (version 14, pass 0xffffffff): VERR_NO_MEMORY
00:00:55.170520 VMSetError: /home/vbox/vbox-4.3.18/src/VBox/VMM/VMMR3/SSM.cpp(8349) int ssmR3LoadExecV2(PVM, PSSMHANDLE); rc=VERR_NO_MEMORY
00:00:55.170522 VMSetError: Failed to load unit 'pgm'


.. do not immediately give more insights (find he whole log-file attached).

I'd appreciate if anybody could help resolving this issue. thanks!

-michael-
Attachments
VBox.log
(100.39 KiB) Downloaded 18 times
g2flyer
 
Posts: 21
Joined: 15. Oct 2014, 05:26

Re: Discuss the 4.3.18 release

Postby JayEm » 17. Oct 2014, 12:04

I reverted back to 4.3.16, now snapshots are working as they should.
JayEm
 
Posts: 32
Joined: 15. Jul 2014, 21:20

Re: Discuss the 4.3.18 release

Postby g2flyer » 17. Oct 2014, 14:25

I also reverted, but to 4.3.14 so not only resume works but also fullscreen which got busted in 4.3.16 (and seemed to get even worse in 4.3.18)
g2flyer
 
Posts: 21
Joined: 15. Oct 2014, 05:26

Re: Discuss the 4.3.18 release

Postby mpack » 17. Oct 2014, 18:01

Reverting to 4.3.14 is probably the worst option, since it's the most buggy (on Windows hosts).
mpack
Site Moderator
 
Posts: 29843
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Discuss the 4.3.18 release

Postby kRu_ZaDeR » 19. Oct 2014, 13:53

4.3.18 and 4.3.16 is broken when you try to go fullscreen
or seamless mode. It hangs the whole ubuntu. Mouse
clicks do not work for guest or host. Only the host key + Q
to shutdown machine works.

I too had to revert back to 4.3.14 where fullscreen and
seamless mode works beautifully.

Sony VAIO VPCF136FM/B Laptop
8GB Ram, Quad core i7
Nvidia GeForce 425-GT
Ubuntu 14.04 64-bit host
Windows 7 Home, Windows 8.1 guests
kRu_ZaDeR
 
Posts: 2
Joined: 7. Aug 2011, 11:18
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Windows XP

Re: Discuss the 4.3.18 release

Postby michael » 20. Oct 2014, 12:58

kRu_ZaDeR wrote:4.3.18 and 4.3.16 is broken when you try to go fullscreen
or seamless mode. It hangs the whole ubuntu. Mouse
clicks do not work for guest or host. Only the host key + Q
to shutdown machine works.

I too had to revert back to 4.3.14 where fullscreen and
seamless mode works beautifully.

Sony VAIO VPCF136FM/B Laptop
8GB Ram, Quad core i7
Nvidia GeForce 425-GT
Ubuntu 14.04 64-bit host
Windows 7 Home, Windows 8.1 guests


Please create a bug report for this, attaching a machine log file and mentioning your host graphics card and drivers. Does disabling 3D make a difference? Can you exit full-screen using Host+F?
michael
Oracle Corporation
 
Posts: 683
Joined: 10. May 2007, 09:46

Re: Discuss the 4.3.18 release

Postby g2flyer » 21. Oct 2014, 15:50

mpack wrote:Reverting to 4.3.14 is probably the worst option, since it's the most buggy (on Windows hosts).

That might be true for windows hosts but on (ubuntu) linux hosts 4.3.14 seems substantially better than 4.3.18 (i.e., i had no bigger issue with 4.3.14 but with 4.3.18 (and 4.3.16) fullscreen doesn't work anymore properly (it is offset so only a small part shows up) and above mentioned resume problem happens only (but persistently) on 4.3.18.
g2flyer
 
Posts: 21
Joined: 15. Oct 2014, 05:26

Re: Discuss the 4.3.18 release

Postby heavymx » 23. Oct 2014, 20:35

My set-up:
OS: Linux Kubuntu 14.04 amd64
MB: Asus m2n-sli deluxe
CPU: Phenom II x4 955 - 3.2Ghz
GPU: Nvidia Geforce GTS 250
RAM: 8GB

since version 4.3.16 on windows 7 x32 guest, when aero is turned on, there are many flashes, flickers and white boxes when you pass the mouse over the icons on the taskbar or menu bar, also on top of the windows (eg: close Window symbol), etc. I had to install backwards 4.3.14 and everything returned to normal.

Also in Windows 8.1 x32 guest, although it doesn't drive aero, happen similar things!

I haven't tasted it in x64 guests.

When 4.3.18 version was released, I thought the problem would be fixed, but it wasn't

Any workaround?

Thank you
heavymx
 
Posts: 6
Joined: 23. Oct 2014, 20:11

Re: Discuss the 4.3.18 release

Postby Shevchuk » 5. Nov 2014, 14:53

Have similar problem as g2flyer and kRu_ZaDeR.
Host: Ubuntu 14.10
Guest: Ubuntu 14.10

Seems that problem is with guest additions. Without GA it goes fullscreen and back to windowed mode just fine (as well as with disabled 3D, as michael suggested). With GA and 3D enabled you can exit fullscreen mode, but virtual machine screen would still be on top of everything, even its window, taking all available space except like 30px on the right and bottom of the screen and sometimes it would not react on mouse/keyboard. You could still interact with host interface if you are lucky to have something in those 30px areas (like turn your computer off :D actually I'm finishing this post like this after failed attempt to take a screenshot :D).
Shevchuk
 
Posts: 3
Joined: 6. Jun 2014, 10:28
Location: Russia, Saint Petersburg
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Linux

Re: Discuss the 4.3.18 release

Postby mpack » 5. Nov 2014, 15:47

Shevchuk wrote:Seems that problem is with guest additions. Without GA it goes fullscreen and back to windowed mode just fine

Not really. There has been a problem of OpenGL drivers tripping over the new hardening features on Windows hosts. There can also be totally unrelated host driver bugs which cause OpenGL problems.

Of course if you don't install the GAs then you don't get graphics acceleration which means it can't fail to load the OpenGL drivers. While the observation is true, it's a poor workaround and not a solution: most will want decent graphics performance.
mpack
Site Moderator
 
Posts: 29843
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Discuss the 4.3.18 release

Postby loukingjr » 5. Nov 2014, 17:14

FWIW, I have Ubuntu 14.10 installed on both a Mac host (OSX 10.10) and a Linux Host (LM17). With the GAs installed and 3D enabled on the Mac host I can switch between full screen and windowed mode with no problem. Not so for the Linux host. No clue why.
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8827
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: Discuss the 4.3.18 release

Postby michael » 5. Nov 2014, 22:16

loukingjr wrote:FWIW, I have Ubuntu 14.10 installed on both a Mac host (OSX 10.10) and a Linux Host (LM17). With the GAs installed and 3D enabled on the Mac host I can switch between full screen and windowed mode with no problem. Not so for the Linux host. No clue why.


This should now be fixed - care to give a test build<1> a try?

<1> https://www.virtualbox.org/wiki/Testbuilds
michael
Oracle Corporation
 
Posts: 683
Joined: 10. May 2007, 09:46

PreviousNext

Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 16 guests