Discuss the 4.3.16 release

This is for discussing general topics about how to use VirtualBox.

Re: Discuss the 4.3.16 release

Postby EarlsFurniture » 10. Sep 2014, 23:11

indigo196 wrote:I can also confirm the issue of full screen not working as expected with Unity elements covering the guest OS whne using fullscreen.


Same here with Ubuntu 12.04.5

I opened a bug report here: #13365 on the bugtracker here at virtualbox (I can't post the link here because I'm brand new) as I couldn't find anything on this issue. It was defintely introduced in the 4.3.16 update as I tested this specifically in 4.3.14 with no issue present, updated to 4.3.16, immediately retested and the bug presented itself.
EarlsFurniture
 
Posts: 1
Joined: 10. Sep 2014, 23:04

Re: Discuss the 4.3.16 release

Postby fdb66 » 10. Sep 2014, 23:37

Weird problem!

I have just upgraded to version 4.3.16 r95972 of Virtualbox. My host OS is Mac OS X version 10.9.4 running Windows 7 as guest OS.

After the upgrade, using my 3 fingers to slide my screen to the Virtualbox the screen comes up empty. All I see is a gray empty screen instead of a Windows 7 screen. The only way I can have the Windows 7 virtualbox to appear is to click on its icon down in the Docking system tray. Weird!

Does any one have the same experience? It is annoying and it only started happening after the upgrade to version 4.3.16 r95972 of virtual box.
fdb66
 
Posts: 4
Joined: 10. Sep 2014, 23:01

Re: Discuss the 4.3.16 release

Postby socratis » 11. Sep 2014, 00:57

fdb66 wrote:using my 3 fingers to slide my screen to the Virtualbox the screen comes up empty.

There is a similar thread in the Mac forum that talks about the same thing (Lost Swipe between Machines in Latest Update) and they have a solution; turn off the mini-toolbar option. Does that work for you?
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Discuss the 4.3.16 release

Postby MuldeR » 11. Sep 2014, 00:58

Since VirtualBox v4.3.16 it seems the Windows version has "visual styles" disabled, i.e. all controls look like in Windows 2000.

Looks like the "XP Manifest" to enable the "modern" UI styles is missing...

Image
MuldeR
 
Posts: 27
Joined: 25. Aug 2014, 20:45

Re: Discuss the 4.3.16 release

Postby Mist » 11. Sep 2014, 01:42

Everything worked with 4.3.14
Upgraded to 4.3.16 r95972
Host is openSUSE 12.2 with 3 monitors
Guests: openSUSE 13.1, Windows 7

Guests will not span multiple monitors. When stretched beyond a monitor boundary, they snap back inside the closest monitor.

Tried changing
Host -> File -> Preferences -> Display
through all options to no avail.

Any ideas?

Thanks,
Mist
Mist
 
Posts: 2
Joined: 11. Sep 2014, 01:31

Re: Discuss the 4.3.16 release

Postby michael » 11. Sep 2014, 11:51

Regarding the full-screen problem with Unity, for now you can work around it by disabling the mini-tool-bar.
michael
Oracle Corporation
 
Posts: 683
Joined: 10. May 2007, 09:46

Re: Discuss the 4.3.16 release

Postby davido » 11. Sep 2014, 16:46

I too can confirm... I start VirtualBox 4.3.16 on Ubuntu 14.04, and run Windows 7.1 in full-screen mode. Unlike with previous versions, the Ubuntu/Unity toolbar remains at the top of the screen. The mini-VB bar at the bottom of the screen looks a little different too, with a shadow that never quite disappears.

If I switch out of full-screen mode, the screen becomes corrupted, and VirtualBox / the guest become totally unresponsive, forcing me to open a shell and kill the process.
davido
 
Posts: 1
Joined: 11. Sep 2014, 16:43

Re: Discuss the 4.3.16 release

Postby el_viejo » 12. Sep 2014, 02:13

michael wrote:Regarding the full-screen problem with Unity, for now you can work around it by disabling the mini-tool-bar.


unfortunately this is only half of a solution as every switching back from fullscreen mode to windows mode corrupts all unity workspaces and the system gets unresponsive. switching back to fullscreen mode at that time leads to a fullscreen vm not responding on any mouse or keyboard input.

i guess i am rolling back to 4.3.14.


greetings

peter


ps: i just wonder if the vb-team has ever tested 4.3.16 how it runs under unity... this bug is quite obvious...
el_viejo
 
Posts: 7
Joined: 12. Sep 2014, 02:06

Re: Discuss the 4.3.16 release

Postby misha » 12. Sep 2014, 08:09

el_viejo wrote:
michael wrote:Regarding the full-screen problem with Unity, for now you can work around it by disabling the mini-tool-bar.


unfortunately this is only half of a solution as every switching back from fullscreen mode to windows mode corrupts all unity workspaces and the system gets unresponsive. switching back to fullscreen mode at that time leads to a fullscreen vm not responding on any mouse or keyboard input.

i guess i am rolling back to 4.3.14.


greetings

peter


ps: i just wonder if the vb-team has ever tested 4.3.16 how it runs under unity... this bug is quite obvious...

Could you post a VM log for your issue here, to help us determine the source of your problem?
misha
 
Posts: 289
Joined: 19. Dec 2008, 11:10

Re: Discuss the 4.3.16 release

Postby michael » 12. Sep 2014, 08:12

el_viejo wrote:
michael wrote:Regarding the full-screen problem with Unity, for now you can work around it by disabling the mini-tool-bar.


unfortunately this is only half of a solution as every switching back from fullscreen mode to windows mode corrupts all unity workspaces and the system gets unresponsive. switching back to fullscreen mode at that time leads to a fullscreen vm not responding on any mouse or keyboard input.


And could you please provide more details of your set-up? I do actually run Unity (single host monitor except for testing purposes - do you see this with one monitor?) and do not see the corruption or the input problems, so I presume there is some important difference between our systems. Do you get this with 3D disabled for the guest you are running?

It might be helpful if you opened a bug ticket.
michael
Oracle Corporation
 
Posts: 683
Joined: 10. May 2007, 09:46

Re: Discuss the 4.3.16 release

Postby Peter Müller 123456 » 12. Sep 2014, 10:29

Hello,

after ugrading to 4.3.16 I have difficulties with USB devices.
Here the description of the situation:
Host system
Ubuntu Linux 12.04 64-bit
Kernel Linux 3.2.0-68-generic
GNOME 3.4.2
Guest system
Win 8.1 64-bit

Before the upgrade everything worked fine. I am not sure which version I had before. However I always did an upgrade whenever Virtualbox told me so.
Now I also got the information that an update to version 4.3.16 r95972 was available. I did the update accordingly. After the update I got informed that there is a new version of the extention pack available for this version.
I updated this as well. Then I started win8.1 everything as usual,plugged in my Sandisk USB stick and windows got frozen. No way to shutdown windows. In Ubuntu the system monitor showed me that virtual box used the 4 core CPU load at 400% (all 4 at hundred). There was no way to stop the virtual machine in any way. The only possibility I had was to kill the process.
So I reinstalled the extension pack from the virtualbox website started windows again and also updated the guest additions. Same behavoir when I plugged in my USB stick. USB scanner the same also usb cardreader. The only usb device where win8.1 didn't freeze was the USB bluetoothadapter.

Since everything worked fine before my guess would be that something might not be right with the extension pack.
Does anybody have an idea what I could do? In case more information is needed to investigate this issue please let me know.

Update:
Finally I decided to downgrade again back to 4.3.12. Now everything is fine again.
Peter Müller 123456
 
Posts: 10
Joined: 12. Sep 2014, 10:12

Re: Discuss the 4.3.16 release

Postby indigo196 » 12. Sep 2014, 17:54

I know this thread is for reporting experiences and will end up mostly negative, but I want to say thank you to all the developer who put time in on this product. I appreciate your efforts and I am sure that fixes well be released.
indigo196
 
Posts: 2
Joined: 10. Sep 2014, 19:34

Re: Discuss the 4.3.16 release

Postby Mr Wolf » 12. Sep 2014, 18:11

Hi!
I've just upgraded to VirtualBox 4.3.16: in Windows XP, the icon of the extension pack file Oracle_VM_VirtualBox_Extension_Pack-4.3.16-95972.vbox-extpack is missing. It says the vboxres.dll file doesn't contain any icon.

By the way, in Windows 7, the infamous Unidentified network is gone.

Just I'd like to have confirmation for these.

Thanks.
Mr Wolf
 
Posts: 50
Joined: 23. Aug 2010, 15:48
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Kali Linux, BackTrack, Windows XP

Re: Discuss the 4.3.16 release

Postby DarthJJ » 13. Sep 2014, 16:43

I'm also seeing this issue with 4.3.16 (keyboard works in fullscreen mode, but the mouse does not work). I tried the VBoxGuestAdditions_4.3.17-96003.iso and it didn't seem to fix the issue either.

I'm running on Ubuntu 14.04 64bit
DarthJJ
 
Posts: 3
Joined: 13. Sep 2014, 16:37

Re: Discuss the 4.3.16 release

Postby BrianG61UK » 14. Sep 2014, 06:50

I find that with 4.3.16 my 32 bit Windows VMs (One Windows 7, One XP) (with 3D enabled) will not shut down or restart.
32 bit Linux VMs seem okay and I don't have any 64 bit VMs.
I am running VirtualBox 4.3.16 on Windows 7 Ultimate 64-bit.
BrianG61UK
 
Posts: 49
Joined: 21. Mar 2014, 02:15
Location: Reading. Berkshire. UK.
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows, DOS, Linux

PreviousNext

Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 11 guests