Discuss the 4.3.14 release

This is for discussing general topics about how to use VirtualBox.

Discuss the 4.3.14 release

Postby frank » 16. Jul 2014, 09:23

Discuss the 4.3.14 release here. See the changelog for details.
frank
Oracle Corporation
 
Posts: 3330
Joined: 7. Jun 2007, 09:11
Location: Dresden, Germany
Primary OS: Debian Sid
VBox Version: PUEL
Guest OSses: Linux, Windows

Re: Discuss the 4.3.14 release

Postby gregz83 » 16. Jul 2014, 09:26

Ever since updating to 4.3.14, i can no longer use virtual box, it will not start, nor can I start any VM separately.

The following error happens every time:
VB error.PNG
VB error.PNG (46.21 KiB) Viewed 25488 times


Please fix soon. There is more discussion on this error in the forums, happening to many people.

Host OS: Windows 7 Pro 64bit
Guest OS: Any 32/64bit
gregz83
 
Posts: 4
Joined: 16. Jul 2014, 08:35

Re: Discuss the 4.3.14 release

Postby bird » 16. Jul 2014, 11:11

Some software has patched the ntdll.dll after it got loaded into the VirtualBox process. VirtualBox does not like when other meddles with the process in that manner. To help us figure out what's going on here, could you please tell us what kind of protection software (antivirus, anti-malware, firewall, endpoint protection, internet security, sandboxing, etc) you have installed on your system, if you have any?

Kind Regards,
bird.
Knut St. Osmundsen
Oracle Corporation
bird
Oracle Corporation
 
Posts: 108
Joined: 10. May 2007, 10:27

Re: Discuss the 4.3.14 release

Postby teschl » 16. Jul 2014, 11:38

I got another error on Window s7 x64 Pro (SP1) when trying to start a vm.
The vm a freshly new created.

1.jpg
1st MessageBox
1.jpg (40.07 KiB) Viewed 25423 times

2.jpg
2nd MessageBox
2.jpg (49.76 KiB) Viewed 25423 times



Installed protection software: Kaspersky KES10 (10.2.1.23(a).
Exlucsions in KES are: *.vbox,*.vdi and VBoxSVC.exe, VirtualBox.exe
Tryed with disabled KES, same error.
Attachments
VBoxSVC.log
SVC log
(2.27 KiB) Downloaded 301 times
teschl
 
Posts: 5
Joined: 16. Jul 2014, 11:25

Re: Discuss the 4.3.14 release

Postby Alinod » 16. Jul 2014, 12:29

I can confirm teschl's errors:

Code: Select all   Expand viewCollapse view
Failed to open a session for the virtual machine CentOS.

The virtual machine 'CentOS' has terminated unexpectedly during startup with exit code 1.

Result Code: E_FAIL (0x80004005)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}

I'm on Windows 7 Home Premium 64-bit and using McAfee.

Uninstalling 4.3.14 and re-installing 4.3.14 did not resolve the issue.
Uninstalling 4.3.14 and re-installing 4.3.12 *did* resolve the issue.
Last edited by Alinod on 16. Jul 2014, 16:56, edited 2 times in total.
Alinod
 
Posts: 1
Joined: 11. Jul 2014, 16:32
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: CentOS

Re: Discuss the 4.3.14 release

Postby Steve Richards » 16. Jul 2014, 13:11

After installing to Win 8.1 host, every startup of virtualbox.exe pops up this error dialog.

I do have nVidia graphics adapter in machine.

Code: Select all   Expand viewCollapse view
---------------------------
VirtualBox.exe - Bad Image
---------------------------
C:\Windows\system32\nvinitx.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support. Error status 0xc0000190.
---------------------------
OK   
---------------------------
Last edited by Steve Richards on 16. Jul 2014, 14:24, edited 1 time in total.
Steve Richards
 
Posts: 16
Joined: 18. Nov 2008, 14:38

Re: Discuss the 4.3.14 release

Postby Hali1236 » 16. Jul 2014, 13:48

I installed 4.3.14 over 4.3.12 on Windows 7 Pro 64 bit, now the guest machines (Windows 2003 Server and Windows 7, both 32 bit) have no longer connetion to the network. I get no error message, the network symbol in status bar says "connected with 100 MBit", but I cannot access the network or internet.
Hali1236
 
Posts: 1
Joined: 16. Jul 2014, 13:45

Re: Discuss the 4.3.14 release

Postby andrewm659 » 16. Jul 2014, 15:55

I'm getting errors with Teamviewer 9. Not sure why...rolling back to previous release.
andrewm659
 
Posts: 8
Joined: 2. Apr 2014, 19:14

Re: Discuss the 4.3.14 release

Postby NilexBM » 16. Jul 2014, 16:10

Hello

Installed 4.3.14 over 4.3.12 on a Windows 7 64bit host. Got the error shown below.
Reinstalled 4.3.14 (repair), but still got the error.
Unistalled VirtualBox completely, and then did a fresh install. Still the same error.
Restarted Windows when the installation program asked me to do so.

Finally I went back to the previous version 4.3.12 - no problems.

I have been using VBox on this host for almost two years now, never had issues like this.

Some of the drives on the host are encrypted with TrueCrypt. One virtual machine has it's virtual HDD on an encrypted disk.
Running in total 4 virtual machines.

Additional Info
I just read the thread about 4.3.14 being incompatible with some AntiVirus software packages. I should perhaps mention I'm using Symantec Endpoint Protection on the host.

vboxerror.png
vboxerror.png (53.39 KiB) Viewed 25151 times
NilexBM
 
Posts: 6
Joined: 5. Sep 2011, 12:14
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Win

Re: Discuss the 4.3.14 release

Postby mpack » 16. Jul 2014, 17:04

Since the antivirus issue only affects Windows hosts, I created a topic in the "Windows Hosts" forum (here) since that's where the dozen new threads were popping up anyway. Please use the other thread for that one issue, this one for everything else.
mpack
Site Moderator
 
Posts: 24282
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Discuss the 4.3.14 release

Postby JayEm » 16. Jul 2014, 20:06

My impressions of 4.3.14 release:
Running it on 3 machines, 3x Windows 7 Professional x64 with latest patches.

2 machines needed to fix the registry key (DISABLEUSERCALLBACKEXCEPTION). These 2 machines don't have virus scanner. No problems with virtual machines.
1 machine needed no registry fix. This machine has Trend Micro Worry Free Business security installed (ver. 9.0 Build 1431 with latest critical patches 1433 and 1439). No problems with this virus scanner, machines running as expected. But Trend Micro seems not to inject a dll in the process (checked other tasks with Process Explorer).
Machines need significantly more time to start from a snapshot - with 4.3.12 release, this happened immediately. with 4.3.14 release, it needs around 5 seconds, till the window of the virtual machine comes up. All machines have fast SSDs (840 Pro) and fast Processor (i7) and enough memory. It think it has to do with the new security features (checking of injected dlls?) that VMs need a few seconds to start. All functions are working as expected like in version 4.3.12.
JayEm
 
Posts: 18
Joined: 15. Jul 2014, 21:20

Re: Discuss the 4.3.14 release

Postby SuperFly89 » 17. Jul 2014, 21:20

I get the same problem.

I am running AVG Antivirus, Spybot Search & Destroy, and Microsoft Security Essentials.
Attachments
VM Error.JPG
VM Error.JPG (24.08 KiB) Viewed 24140 times
SuperFly89
 
Posts: 1
Joined: 17. Jul 2014, 21:16

Re: Discuss the 4.3.14 release

Postby mpack » 18. Jul 2014, 12:31

People, I suggest we try not to split the workload. For the anti-virus issue on Windows hosts please post in the dedicated thread.

I also suspect that, by this point, the seriousness of the issue has already impressed itself on the devs, and further "me too" messages will not be helpful. Post in the other thread, but preferable only if it's with an antivirus or other package not already mentioned.
mpack
Site Moderator
 
Posts: 24282
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Discuss the 4.3.14 release

Postby user1111 » 19. Jul 2014, 16:26

Windows 8.1 Pro x64

I use MacType software for better font rendering on my Windows.
VirtualBox cannot start. Rolling back to 4.3.12
Attachments
CWindowsSystem32cmd.exe_2014-07-19_18-23-35.jpg
CWindowsSystem32cmd.exe_2014-07-19_18-23-35.jpg (105.76 KiB) Viewed 23213 times
VirtualBox_-_Error_In_supR3HardenedWinVerifyProces_2014-07-19_18-14-46.jpg
VirtualBox_-_Error_In_supR3HardenedWinVerifyProces_2014-07-19_18-14-46.jpg (38.29 KiB) Viewed 23213 times
user1111
 
Posts: 1
Joined: 19. Jul 2014, 16:19

Re: Discuss the 4.3.14 release

Postby pschneider1968 » 19. Jul 2014, 21:13

Hi,

I have a new issue with 4.3.14 that I didn't have with 4.3.12 and which I did not see discussed here yet.

Host is Windows 7 Professional 64bit, german locale and keyboard layout. Guests are various Linux 64bit VMs, e.g. CentOS 6.5, Ubuntu 13.10, CentOS 7, OEL 6.5 each with german locale and keyboard layout. All OS, guests and host are patched up to date.

The issue I have is that when typing in guest VMs, I am no longer able to enter characters which on a german keyboard are composed with AltGR, e.g. "@", or "|". It does not matter whether I upgrade the guest additions to 4.3.14, or leave them at 4.3.12. This is especially a problem when passwords contain such characters; I had to ssh in and change PW to something different. I'm afraid that when there is no quick workaround I have to downgrade to 4.3.12.

Thanks and regards
Peter

P.S.: Shall I make an entry to the bug tracker, too?
pschneider1968
 
Posts: 2
Joined: 19. Jul 2014, 21:03

Next

Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 6 guests