Discuss the 4.2.10 release

This is for discussing general topics about how to use VirtualBox.

Discuss the 4.2.10 release

Postby frank » 15. Mar 2013, 16:20

Discuss the 4.2.10 release here.
You can download it from here.
frank
Oracle Corporation
 
Posts: 3362
Joined: 7. Jun 2007, 09:11
Location: Dresden, Germany
Primary OS: Debian Sid
VBox Version: PUEL
Guest OSses: Linux, Windows

Re: Discuss the 4.2.10 release

Postby lexxx » 15. Mar 2013, 18:04

I have made a topic about corrupted additions iso in here https://forums.virtualbox.org/viewtopic.php?f=6&t=54618
lexxx
 
Posts: 28
Joined: 25. Oct 2011, 08:30
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Mostly Windows 7 and 2008 R2

Re: Discuss the 4.2.10 release

Postby Perryg » 15. Mar 2013, 19:42

From the looks of it the guest additions packed in the Windows build may be corrupt.
You can download the standalone guest additions by clicking HERE
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Discuss the 4.2.10 release

Postby frank » 16. Mar 2013, 09:12

Sorry for this broken Windows package. I have no idea what happened. I've uploaded a fixed package with the same version some hours ago but the server didn't catch the package. So I've uploaded a new package 4.2.10-84105 which is now available on the server. Note: Only the Windows package is affected!
frank
Oracle Corporation
 
Posts: 3362
Joined: 7. Jun 2007, 09:11
Location: Dresden, Germany
Primary OS: Debian Sid
VBox Version: PUEL
Guest OSses: Linux, Windows

Re: Discuss the 4.2.10 release

Postby Hawk2001 » 16. Mar 2013, 15:13

This appears to be an issue in Linux also. I have three VMs that cannot mount the guest additions ISO at all.
Hawk2001
 
Posts: 2
Joined: 16. Mar 2013, 15:12

Re: Discuss the 4.2.10 release

Postby mpack » 16. Mar 2013, 15:21

Hawk2001 wrote:This appears to be an issue in Linux also. I have three VMs that cannot mount the guest additions ISO at all.

And is this problem fixed by downloading from the link Perry provided? And by "in Linux" I assume you mean that the three VMs are all Linux guests?
mpack
Site Moderator
 
Posts: 29327
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Discuss the 4.2.10 release

Postby winsnomore » 16. Mar 2013, 22:22

I have another problem.

I have a Win7 hosting debian 32 bit .. 3.2.6 kernel.
I had 4.2.6 running fine .. I upgraded to 4.2.8 fine ..
Today I did the 4.2.10 upgrade .. too ..and I can't use this VM.
-- this is what I did .. installed 4.2.10 on win7 and ran the VBoxLinuxaddtions.run in the VM.
I rebooted my VM/Machine ..and now the VM doesn't take any mouse or kb input .. it's running otherwise .. I can ssh into it from another machine.

Came here, read the issues with the windows release .. so I went ahead and installed the 84105 build and reinstalled the host additions ..
But my VM is dead .. DEAD ..
In single user mode I can at least get root shell .. but once I go multi-user mode .. keybd/mouse is no longer working in the VM.

Is there a way to revert back the Vboxadditions I did?
winsnomore
 
Posts: 3
Joined: 16. Mar 2013, 22:12

Re: Discuss the 4.2.10 release

Postby winsnomore » 16. Mar 2013, 22:35

I can add two things to my woes (Debian running under Win7)

#1. In my VM it still shows it's running r84104 .. I know I installed run the isntall on r84105

#2. I sshd into the VM .. and can't see the VBoxGuesAddtions.iso
( I know I was able to run this "before" I installed the 84105 )
winsnomore
 
Posts: 3
Joined: 16. Mar 2013, 22:12

Re: Discuss the 4.2.10 release

Postby AlanL » 16. Mar 2013, 22:49

MacOS X host and Win 7 client. 4.2.10 r 84104 only available. Installation of Guest Additions also fails and no update is provided.

Downloaded separate iso and mounted it. Ran installation. Rebooted to complete installation.

Satisfactory resolution but an undesirable interruption.
AlanL
 
Posts: 12
Joined: 16. Mar 2013, 22:43

Re: Discuss the 4.2.10 release

Postby winsnomore » 17. Mar 2013, 00:29

All day wasted with this "release"

I recovered by ssh'ing to the VM, upgrading the distro .. that removes the dkms modules installed by new release.
-- I then reran the install of linuxadditions .. that seems to put my humpty dumpty back.
I had work to do today and I spent 5 hours recovering from this fiasco.

In short 4.2.10 seems to be a disaster created by whatever was in 84104 load .. it seems not be there any more so others may not suffer but I have!

My suggestion to VBox maintainers . please
DON'T PUT UP THE MESSAGE ABOUT NEW VERSION EVERY TIME ONE STARTS THE PGM.
DO IT ONCE .. OR ONCE A WEEK but not on EVERY PGM START.

I only installed the new version because I was getting annoyed having to click that off every time.
You are putting out release every few weeks and wasting people's time won't win you friends.
winsnomore
 
Posts: 3
Joined: 16. Mar 2013, 22:12

Re: Discuss the 4.2.10 release

Postby Perryg » 17. Mar 2013, 00:38

@ winsnomore,

You have the power to turn the notifications off or change the check to fit your preference. Open preferences and go to update, remove the check mark, no more notifications, or select a length of time or which type of release.
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Discuss the 4.2.10 release

Postby Mark92630 » 17. Mar 2013, 03:40

AlanL wrote:MacOS X host and Win 7 client. 4.2.10 r 84104 only available. Installation of Guest Additions also fails and no update is provided.

Downloaded separate iso and mounted it. Ran installation. Rebooted to complete installation.

Satisfactory resolution but an undesirable interruption.


I have the exact same problem. I'll attempt to locate and download the ISO.

Mark
Host: macOS High Sierra 10.13.2 (17C88)
VM VirtualBox 5.2.4 r119785 (Qt5.6.3), with Extension Pack 5.2.4
Guest: Windows 7 Home Premium (32-bit) with Service Pack 1 applied (Build: 7601.23915), and with Guest Additions 5.2.4 installed
Guest: Windows 10 Home (32-bit), Version 1703, Build 15063.726, with Guest Additions 5.2.4r119785 installed
Guest: Ubuntu 16.04.3 LTS with Guest Additions 5.2.4 installed
Mark92630
 
Posts: 29
Joined: 2. Dec 2012, 09:56
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Windows 10

Re: Discuss the 4.2.10 release

Postby Mark92630 » 17. Mar 2013, 05:00

Frank Mehnert wrote:Sorry for this broken Windows package. I have no idea what happened. I've uploaded a fixed package with the same version some hours ago but the server didn't catch the package. So I've uploaded a new package 4.2.10-84105 which is now available on the server. Note: Only the Windows package is affected!


The Mac OS X VirtualBox-4.2.10-84104-OSX.dmg package is also broken with respect to Guest Additions. I was able to download the latest Guest Additions ISO separately, following instructions from another post on this thread, and install it successfully.

Mark
OS X 10.8.3 Host
Windows 7 Guest
Host: macOS High Sierra 10.13.2 (17C88)
VM VirtualBox 5.2.4 r119785 (Qt5.6.3), with Extension Pack 5.2.4
Guest: Windows 7 Home Premium (32-bit) with Service Pack 1 applied (Build: 7601.23915), and with Guest Additions 5.2.4 installed
Guest: Windows 10 Home (32-bit), Version 1703, Build 15063.726, with Guest Additions 5.2.4r119785 installed
Guest: Ubuntu 16.04.3 LTS with Guest Additions 5.2.4 installed
Mark92630
 
Posts: 29
Joined: 2. Dec 2012, 09:56
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Windows 10

Re: Discuss the 4.2.10 release

Postby JohnMLie » 17. Mar 2013, 15:25

In the latest relaese (84105) the issue with the iso is solved.
That's fast, while 84104 was just released a few days ago.
Good work of the team!
JohnMLie
 
Posts: 1
Joined: 17. Mar 2013, 15:19

Re: Discuss the 4.2.10 release

Postby kapetros » 17. Mar 2013, 17:18

Xorg 1.14 hit slackware current today, so the guest additions are not working (api version mismatch), I have tried with ServerFlags IgnoreAPI=true, but that didn't help. Is there a way to force the guest additions to be installed, ignoring the API?
Well done to the Virtualbox Team, fixing the additions.iso so quickly !!!!!
kapetros
 
Posts: 13
Joined: 26. Jul 2011, 23:29
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Gentoo, Archlinux, Debian, FreeBSD, other

Next

Return to Using VirtualBox

Who is online

Users browsing this forum: Robidj and 8 guests