UUID does not match the value in the registry

This is for discussing general topics about how to use VirtualBox.

Re: UUID does not match the value in the registry

Postby Tom Watson » 15. Dec 2016, 15:53

bn.vb wrote:I wanted to share a virtualbox disk (vdi file) across two different PCs and I was getting this error. I have separate installations of OVB on both each machine.
I found a thread elsewhere which solved it by
- going to File, Virtual Media Manager,
- select the disk,
- Release,
- Remove,
- Close.

Then in the VirtualBox machine,
- add the disk back as the hard drive and
- load the machine.
This all worked for me.


This also worked for me. Maybe not the obvious route, but certainly painless once you know how.
Tom Watson
 
Posts: 1
Joined: 15. Dec 2016, 15:51

Re: UUID does not match the value in the registry

Postby esmeralgan » 27. Apr 2018, 05:26

This worked for me as well.
The setup which led to this issue was the following :
1) created a name(-pt).vmdk files for raw partitions boot, worked fine
2) "something" changed on the physical disk, name.vmdk could no more boot in VM (some message with initfailure..)
3) renamed the files to name(-pt).back.vmdk , recreated name(-pt).vmdk files for the same partitions
4) I got the issue.
esmeralgan
 
Posts: 9
Joined: 15. Apr 2018, 22:30

Re: UUID does not match the value in the registry

Postby mpack » 27. Apr 2018, 09:21

There are many reasons for getting an error about a incorrect UUID, randomly playing around with file names will seldom improve the sitution.

I am locking this ancient thread. The best way to avoid having UUID problems is (a) avoid snapshots and linked clones if you intend to copy VMs around, (b) don't manually mess with any VirtualBox files unless you're an expert.
mpack
Site Moderator
 
Posts: 29846
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Previous

Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 10 guests