USB 3.0 hard drive fails to appear in guest when in 3.0 port

This is for discussing general topics about how to use VirtualBox.

USB 3.0 hard drive fails to appear in guest when in 3.0 port

Postby jsedwards » 15. Apr 2012, 17:39

I have a USB 3.0 hard drive that doesn't appear in the guest OS (both Host and Guest are Ubuntu Linux) when it is plugged into the USB 3.0 port on the motherboard. However, if I plug it into one of the USB 2.0 ports it works fine. Here is the dmesg from the guest when it is plugged into the USB 3.0 port:

[ 195.452122] usb 1-1: new high speed USB device number 6 using ehci_hcd
[ 195.600107] usb 1-1: device descriptor read/64, error 18
[ 195.844117] usb 1-1: device descriptor read/64, error 18
[ 196.060115] usb 1-1: new high speed USB device number 7 using ehci_hcd
[ 196.208112] usb 1-1: device descriptor read/64, error 18
[ 196.452987] usb 1-1: device descriptor read/64, error 18
[ 196.668108] usb 1-1: new high speed USB device number 8 using ehci_hcd
[ 196.736410] usb 1-1: Invalid ep0 maxpacket: 9
[ 196.852103] usb 1-1: new high speed USB device number 9 using ehci_hcd
[ 196.911949] usb 1-1: Invalid ep0 maxpacket: 9
[ 196.916099] hub 1-0:1.0: unable to enumerate USB device on port 1

The drive works correctly when plugged into the USB 3.0 port with the Host OS (no USB filter for it in VirtualBox).

Should I report this as a bug or am I missing something?
jsedwards
 
Posts: 10
Joined: 15. Apr 2012, 17:25

Re: USB 3.0 hard drive fails to appear in guest when in 3.0

Postby Perryg » 15. Apr 2012, 17:50

AFAIK usb3 is not supported yet. You can report it as an enhancement though if you like bugtracker
Perryg
Site Moderator
 
Posts: 25943
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: USB 3.0 hard drive fails to appear in guest when in 3.0

Postby Vasily » 15. Apr 2012, 18:14

jsedwards wrote:I have a USB 3.0 hard drive that doesn't appear in the guest OS (both Host and Guest are Ubuntu Linux) when it is plugged into the USB 3.0 port on the motherboard. However, if I plug it into one of the USB 2.0 ports it works fine. Here is the dmesg from the guest when it is plugged into the USB 3.0 port:

[ 195.452122] usb 1-1: new high speed USB device number 6 using ehci_hcd
[ 195.600107] usb 1-1: device descriptor read/64, error 18
[ 195.844117] usb 1-1: device descriptor read/64, error 18
[ 196.060115] usb 1-1: new high speed USB device number 7 using ehci_hcd
[ 196.208112] usb 1-1: device descriptor read/64, error 18
[ 196.452987] usb 1-1: device descriptor read/64, error 18
[ 196.668108] usb 1-1: new high speed USB device number 8 using ehci_hcd
[ 196.736410] usb 1-1: Invalid ep0 maxpacket: 9
[ 196.852103] usb 1-1: new high speed USB device number 9 using ehci_hcd
[ 196.911949] usb 1-1: Invalid ep0 maxpacket: 9
[ 196.916099] hub 1-0:1.0: unable to enumerate USB device on port 1

The drive works correctly when plugged into the USB 3.0 port with the Host OS (no USB filter for it in VirtualBox).

Should I report this as a bug or am I missing something?


Indeed USB 3.0 isn't supported yet. Could you please attach output of 'sudo lspci -vvvv' on your host?
---
Kind Regards,
Vasily.

P.S. Happy VBoxing!
Vasily
Oracle Corporation
 
Posts: 27
Joined: 7. Feb 2012, 10:12
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: All OS which has got TCP/IP stack

Re: USB 3.0 hard drive fails to appear in guest when in 3.0

Postby jsedwards » 18. Apr 2012, 15:57

Let me know if any other information would be helpful,

Thanks,
-Scott
Attachments
lspci-120418.txt
lspci -vvvv on ASUS M5A97 mobo
(31.17 KiB) Downloaded 56 times
jsedwards
 
Posts: 10
Joined: 15. Apr 2012, 17:25

Re: USB 3.0 hard drive fails to appear in guest when in 3.0

Postby skyler » 6. May 2012, 01:16

Enhancement request submitted. Feel free to add comments to 'bump' the rquest ;)

hrmm, apparently I can't post links... It's submitted as 'Ticket #10521 (new enhancement)' via bugtracker.
skyler
 
Posts: 1
Joined: 6. May 2012, 01:10

Re: USB 3.0 hard drive fails to appear in guest when in 3.0

Postby Perryg » 6. May 2012, 01:25

Here is the link Ticket #10521
Perryg
Site Moderator
 
Posts: 25943
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other


Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 13 guests