[SOLVED] Audio is kind of choppy

This is for discussing general topics about how to use VirtualBox.

[SOLVED] Audio is kind of choppy

Postby Revenant » 4. Aug 2011, 19:18

Audio is kind of choppy, depending somewhat on the kind of controller i use and depending on the application. Some applications run better, others do not. I looked up the manual if there are any audio buffers Virtualbox uses but to no avail.

Are there such audio-buffers in Virtualbox, to begin with? And how may i adjust them? RTFM? Perhaps altering some settings of the XPPro Guest may help?
Last edited by Revenant on 11. Apr 2012, 15:01, edited 1 time in total.
Host: Windows 7 32Bit
Guest: Windows XP Pro 32Bit
CPU: Core 2 Duo T7700 @ 2.4GHz
Revenant
 
Posts: 45
Joined: 21. Jul 2011, 17:27
Location: virtualized
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: WXP Pro 32Bit

Re: Audio is kind of choppy

Postby turdsamich » 5. Aug 2011, 21:16

Not sure if this will help you but I got better audio using the Intel HD Audio controller instead of the default ICH AC97
turdsamich
 
Posts: 2
Joined: 31. Jul 2011, 12:13
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Windows 7

Re: Audio is kind of choppy

Postby stefan.becker » 6. Aug 2011, 06:13

Intel ICH Sound does work since Vista. For XP AC97 is ok.

Forget sound, its nice to have, nothing else. For multimedia etc. use the host.
stefan.becker
Volunteer
 
Posts: 7397
Joined: 7. Jun 2007, 21:53

Re: Audio is kind of choppy

Postby ebones5 » 8. Aug 2011, 23:01

Try installing vbox tools
-Phillip
-Phillip
ebones5
 
Posts: 23
Joined: 7. Aug 2011, 14:20
Primary OS: Mac OS X Leopard
VBox Version: OSE other
Guest OSses: ME 2000

Re: Audio is kind of choppy

Postby Revenant » 11. Aug 2011, 23:22

I have tried AC'97 with Guest Additions installed and without it. This shows strange results. Without GA the sound works flawlessly, when i install them, the sound gets choppy. I used to expect the opposite. What's up?

With Soundblaster 16 it's the same. I am searching for drivers to try Intel HD Audio.
Host: Windows 7 32Bit
Guest: Windows XP Pro 32Bit
CPU: Core 2 Duo T7700 @ 2.4GHz
Revenant
 
Posts: 45
Joined: 21. Jul 2011, 17:27
Location: virtualized
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: WXP Pro 32Bit

Re: Audio is kind of choppy

Postby stefan.becker » 12. Aug 2011, 06:21

You will find no drivers, checked from many others (and me).

There are drivers for XP and Intel, but they will not work.
stefan.becker
Volunteer
 
Posts: 7397
Joined: 7. Jun 2007, 21:53

Re: Audio is kind of choppy

Postby Yacy » 4. Jan 2012, 18:11

Like i have already written in the following thread, disabling Intel® HT Technology in the host bio settings completely eliminated the audio stuttering in my windows xp guest. Maybe this will work for someone else too.

viewtopic.php?f=4&t=716
Yacy
 
Posts: 3
Joined: 29. Dec 2011, 14:55
Primary OS: Ubuntu other
VBox Version: OSE other
Guest OSses: Windows XP

Re: Audio is kind of choppy

Postby Revenant » 29. Mar 2012, 16:53

Finally i have found the cause of the choppiness. It is the I/O-APIC.

From the manual
Enable I/O APIC
Advanced Programmable Interrupt Controllers (APICs) are a newer x86 hardware feature that have replaced old-style Programmable Interrupt Controllers (PICs) in recent years. With an I/O APIC, operating systems can use more than 16 interrupt requests (IRQs) and therefore avoid IRQ sharing for improved reliability.
Note
Enabling the I/O APIC is required for 64-bit guest operating systems, especially Windows Vista; it is also required if you want to use more than one virtual CPU in a virtual machine.
However, software support for I/O APICs has been unreliable with some operating systems other than Windows. Also, the use of an I/O APIC slightly increases the overhead of virtualization and therefore slows down the guest OS a little.


With IO-APIC enabled the sound was choppy, if disabled everything works.

And if it was enabled the number of the used cores doesn't matter. Even with a highend Core i-7 (Sandy Bridge, 4 cores, 8 threads) i had interruptions in the sound.

For audio to work flawlessly, disable the IO-APIC, set the cores to 1.

With XP-Guests this counts:
-"improved reliability" not for audio
-"slows down the guest OS a little" the same
-"support for I/O APICs has been unreliable" even with windows, not for audio

And i have found that it depends very much on the application that has to run in the guest, if multi-core can gain improvements in speed. Winrar and 7-zip, data-compression, gain much. But that is the only case i have found so far. If other such gaining applications exist, i haven't found them. Maybe servers with high load?

I have to say, audio is needed much by the millions old-style gamers out there. Gamers feel it is important, for games its necessary and a tremendous part of the overall experience. All we want is that our software works under new OSs and on new hardware. It's high emotions that cling to games of all sorts. Thus, the games have to work under all circumstances. Gamers go to great lengths to make and keep this possible. It is the driving force for me and others to use things like emulators and virtualization environments. Keeping the games running keeps the spirit hot, alive and powerful.

I have even learned much about hardware and operation systems for this cause. You see, gamers will stop at nothing, even if it means having to keep learning constantly.

Therefore, thanks for VirtualBox!
Host: Windows 7 32Bit
Guest: Windows XP Pro 32Bit
CPU: Core 2 Duo T7700 @ 2.4GHz
Revenant
 
Posts: 45
Joined: 21. Jul 2011, 17:27
Location: virtualized
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: WXP Pro 32Bit

Re: [SOLVED] Audio is kind of choppy

Postby w2kfan10000 » 13. Dec 2015, 07:19

I have I/O Apic disabled and it's still choppy.
w2kfan10000
 
Posts: 8
Joined: 13. Dec 2015, 07:18

Re: [SOLVED] Audio is kind of choppy

Postby loukingjr » 13. Dec 2015, 12:54

w2kfan10000 wrote:I have I/O Apic disabled and it's still choppy.

You should probably start a new topic since this one is three years old. You should also mention, choppy in what guest, on what host, running which version of VirtualBox on what OS.
OSX, Linux and Windows Hosts & Guests
There are three groups of people. Those that can count and those that can't.
loukingjr
Volunteer
 
Posts: 8782
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: [SOLVED] Audio is kind of choppy

Postby mpack » 13. Dec 2015, 13:49

... and using what audio settings?
mpack
Site Moderator
 
Posts: 24744
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: [SOLVED] Audio is kind of choppy

Postby w2kfan10000 » 13. Dec 2015, 19:54

mpack wrote:... and using what audio settings?

I'm using ICH AC97. Intel HD Audio does not work. And yes, I should probably start a new topic.
w2kfan10000
 
Posts: 8
Joined: 13. Dec 2015, 07:18


Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 18 guests