Discuss the 4.1 release

This is for discussing general topics about how to use VirtualBox.

Discuss the 4.1 release

Postby frank » 19. Jul 2011, 15:56

This topic is for discussing the 4.1 release.
frank
Oracle Corporation
 
Posts: 3362
Joined: 7. Jun 2007, 09:11
Location: Dresden, Germany
Primary OS: Debian Sid
VBox Version: PUEL
Guest OSses: Linux, Windows

Re: Discuss the 4.1 release

Postby CaptSaltyJack » 19. Jul 2011, 16:48

I noticed I can't just do a dpkg -i to install this one over 4.0. Is it safe to do dpkg -r to remove 4.0 without losing my settings and virtual machines? Or is there another recommended way of installing this update?

Code: Select all   Expand viewCollapse view
Selecting previously deselected package virtualbox-4.1.
dpkg: regarding virtualbox-4.1_4.1.0-73009~Ubuntu~maverick_i386.deb containing virtualbox-4.1:
 virtualbox-4.1 conflicts with virtualbox
  virtualbox-4.0 provides virtualbox and is present and installed.
dpkg: error processing virtualbox-4.1_4.1.0-73009~Ubuntu~maverick_i386.deb (--install):
 conflicting packages - not installing virtualbox-4.1
Errors were encountered while processing:
 virtualbox-4.1_4.1.0-73009~Ubuntu~maverick_i386.deb
CaptSaltyJack
 
Posts: 26
Joined: 20. Jan 2011, 20:12
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Mint

Re: Discuss the 4.1 release

Postby levk » 19. Jul 2011, 16:58

I can't get PCI passthrough to work, it's been happening all throughout beta, I have a post here viewtopic.php?f=15&t=43012 describing everything.

If you don't mind me asking, what kind of hardware have you tested this on? Like host CPU and chipset and what you've successfully gotten to pass through. Also if you had to do any kernel stuff, like compiling it yourself with special flags.

Thanks in advance
levk
 
Posts: 33
Joined: 13. Apr 2011, 22:35
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: XP, Gentoo, Ubuntu*, CentOS, Scientific Linux

Re: Discuss the 4.1 release

Postby Technologov » 19. Jul 2011, 17:05

Congratulations to all the people, who made it happen !

--
-Alexey Eromenko "Technologov"
Technologov
Volunteer
 
Posts: 3313
Joined: 10. May 2007, 16:59
Location: Israel

Re: Discuss the 4.1 release

Postby fixedwheel » 19. Jul 2011, 17:22

CaptSaltyJack wrote:I noticed I can't just do a dpkg -i to install this one over 4.0. Is it safe to do dpkg -r to remove 4.0 without losing my settings and virtual machines?

yes, as always ... go ahead




my question: not intended that the new proxy settings work for guests behind VBox NAT too? :|
i need that badly here @work
fixedwheel
Volunteer
 
Posts: 1699
Joined: 13. Sep 2008, 02:18

Re: Discuss the 4.1 release

Postby freggel.doe » 19. Jul 2011, 18:58

As in beta3 my bridged vm won't boot from network anymore (see also http://forums.virtualbox.org/viewtopic.php?f=15&t=43124). after downgrading to 4.0.12 everything works as expected.
freggel.doe
 
Posts: 14
Joined: 26. Nov 2009, 21:35
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu Server 64bit, Windows XP Professional SP3

Re: Discuss the 4.1 release

Postby Perryg » 19. Jul 2011, 19:08

freggel.doe wrote:As in beta3 my bridged vm won't boot from network anymore (see also http://forums.virtualbox.org/viewtopic.php?f=15&t=43124). after downgrading to 4.0.12 everything works as expected.

Did you also install the corresponding Extension Pack for 4.1.0?
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Discuss the 4.1 release

Postby freggel.doe » 19. Jul 2011, 19:12

I did.
freggel.doe
 
Posts: 14
Joined: 26. Nov 2009, 21:35
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu Server 64bit, Windows XP Professional SP3

Support for cloning of VMs (Re: Discuss the 4.1 release)

Postby ajbrehm » 19. Jul 2011, 20:49

"Support for cloning of VMs"

Does this mean that VirtualBox finally supports using two hard disk images with the same ID?

Problem is, changing a hard disk ID required Windows to activate again, making clones useless. Has that been fixed.
ajbrehm
 
Posts: 72
Joined: 5. Nov 2009, 16:46
Location: Dublin, Ireland
Primary OS: Mac OS X Leopard
VBox Version: OSE other
Guest OSses: Windows, Linux

Re: Support for cloning of VMs (Re: Discuss the 4.1 release)

Postby Perryg » 19. Jul 2011, 20:53

ajbrehm wrote:"Support for cloning of VMs"

Does this mean that VirtualBox finally supports using two hard disk images with the same ID?

Problem is, changing a hard disk ID required Windows to activate again, making clones useless. Has that been fixed.

It is not something that is broken. You should validate your installs to assure you are running the software in accordance to the EULA.
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Discuss the 4.1 release

Postby Alandor » 19. Jul 2011, 22:39

Hi, I updated today from 4.0.10 to 4.1.0 in a windows 7 x64 host and after upgrading the guest additions in a windows xp guest I started working in some coding in Scite editor and I notice the mouse integration seems to be not accurate. When I try to click in a specific symbol (the + which toggles fields) it is not working as expected, after some tests I saw if I disable mouse integration mouse works as expected but when mouse integration enabled I have to click several pixels to the right and upper of the real point of click. This was not happening in 4.0.10 which worked perfectly accurate. So it seems could be some little bug in mouse integration driver, can anyone else confirm this ??

Thanx very much.

- Alandor -
Alandor
 
Posts: 2
Joined: 19. Jul 2011, 22:26
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows XP

Re: Discuss the 4.1 release

Postby tb2571989 » 19. Jul 2011, 23:14

To echo Technologov, congratulations on this major release. I was hoping 4.1 would be released before the end of July and here we are.
tb2571989
 
Posts: 145
Joined: 10. Sep 2009, 14:28
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Windows Server 2003, Windows Server 2008 R2, Ubuntu 9.10, Ubuntu 10.10

Re: Discuss the 4.1 release

Postby dave78ab » 20. Jul 2011, 00:47

Your changelog says:

Windows guests: Experimental WDDM graphics driver, supporting Windows Aero (bug #4607) and providing Direct3D support using a cleaner approach (no need to install the guest drivers in Safe Mode anymore)


Umm, using Win 7 SP1 x64 host, and just made a new Win 7 SP1 x64 vdi, installed OS, went to Install Guest additions - still says "Windows is currently not running in safe mode so Direct3D support cannot be installed".

So still the same. Doesn't look fixed to me.
dave78ab
 
Posts: 11
Joined: 11. Oct 2010, 19:53
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows 7 x64 SP1

Re: Discuss the 4.1 release

Postby Perryg » 20. Jul 2011, 00:57

@dave78ab,
When you install the Guest additions (in the guest) click through slowly and then when given the option to select 3D click the box.
A warning will appear and you need to read it carefully. You should actually select *NO here to install the wddm drivers or the installer will try to install the normal 3D drivers and that will fail if not in safe mode.
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Discuss the 4.1 release

Postby dave78ab » 20. Jul 2011, 01:41

Thanks. I did get the second popup after saying No, and it said it installed.

I must say that is quite confusing though.

Thanks though, I still can not get aero working on VB though. Still the same result I've had in the past even installing the regular 3D in safe mode.

My result is always attempt to run the WEI assessment, it goes through somewhat fast, sits there for awhile, then pops up with the -WEI can not be computed.

I can not figure what is wrong with it. Was hoping this version would finally allow me to use it, but it gives the same result.
Guess I will still have to go back using VMWare player which lets me use it. :(
dave78ab
 
Posts: 11
Joined: 11. Oct 2010, 19:53
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows 7 x64 SP1

Next

Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 16 guests