Discuss the 4.0.6 Release

This is for discussing general topics about how to use VirtualBox.

Re: Discuss the 4.0.6 Release

Postby ess » 22. Apr 2011, 19:09

Perryg wrote:How many upgraded VirtualBox while the guest was in a saved state and not shut down?


I don't think that any of the guests was saved; I do have at least one snapshot of each, though.

Perryg wrote:Another question is were these VirtualBox upgrades or from a distro VirtualBox upgrades?


In my case, the upgrade was announced by the usual Ubuntu update mechanism as one of a couple of packages that had become available overnight.
ess
 
Posts: 3
Joined: 22. Apr 2011, 14:29
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Windows XP

Re: Discuss the 4.0.6 Release

Postby genec » 22. Apr 2011, 21:18

Latest version (4.0.6) no longer works on fedora 14. I get this error during the kernel build phase:


DKMS make.log for vboxhost-4.0.6 for kernel 2.6.38.3-17.fc15.x86_64 (x86_64)
Fri Apr 22 15:06:26 EDT 2011
make: Entering directory `/usr/src/kernels/2.6.38.3-17.fc15.x86_64'
LD /var/lib/dkms/vboxhost/4.0.6/build/built-in.o
LD /var/lib/dkms/vboxhost/4.0.6/build/vboxdrv/built-in.o
CC [M] /var/lib/dkms/vboxhost/4.0.6/build/vboxdrv/linux/SUPDrv-linux.o
scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by scripts/basic/fixdep)
make[2]: *** [/var/lib/dkms/vboxhost/4.0.6/build/vboxdrv/linux/SUPDrv-linux.o] Error 1
make[1]: *** [/var/lib/dkms/vboxhost/4.0.6/build/vboxdrv] Error 2
make: *** [_module_/var/lib/dkms/vboxhost/4.0.6/build] Error 2
make: Leaving directory `/usr/src/kernels/2.6.38.3-17.fc15.x86_64'
genec
 
Posts: 5
Joined: 22. Apr 2011, 21:11
Primary OS: Fedora other
VBox Version: PUEL
Guest OSses: windows, linux

Re: Discuss the 4.0.6 Release

Postby kubuntu_9_10 » 22. Apr 2011, 21:44

Also USB problems with
Host kubuntu 9.10 karmic koala 64 bit, Kernel 2.6.31-22-generic
VB 4.0.6 + ext.pack succesfully installed + guest additions 4.0.6
Guest WinXP, Servicepack2, 32 Bit

I have already made:
The current user as a member of groups vboxusers and also member of plugdev
I also added to fstab:
none /proc/bus/usb usbfs devgid=118,devmode=664 0 0

USB devices are shown, but inactive. :evil:

Temporarily solution:
If the Host system was booted with an already a plugged in USB device, such as a memory stick, USB devices became accessible. :shock:

Has anyone an idea for a generally solution ??
kubuntu_9_10
 
Posts: 4
Joined: 22. Apr 2011, 21:01
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: win xp

Re: Discuss the 4.0.6 Release

Postby didierg » 22. Apr 2011, 23:48

genec wrote:Latest version (4.0.6) no longer works on fedora 14. I get this error during the kernel build phase:

DKMS make.log for vboxhost-4.0.6 for kernel 2.6.38.3-17.fc15.x86_64 (x86_64)
---/---
scripts/basic/fixdep: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by scripts/basic/fixdep)


So, I use Fedora 14 with 2.6.38 kernel from koji and I have same build problem with :

kernel-2.6.38.3-17.fc15.x86_64
kernel-2.6.38.3-18.fc15.x86_64

I dont have any build problem with :

kernel-2.6.38.3-15.rc1.fc15.x86_64

I also filled https://bugzilla.redhat.com/show_bug.cgi?id=699065 about this problem.
didierg
 
Posts: 22
Joined: 1. Apr 2008, 02:12
Primary OS: Fedora other
VBox Version: PUEL
Guest OSses: Fedora & Windows

Re: Discuss the 4.0.6 Release

Postby trucbidule » 23. Apr 2011, 02:16

Same USB subsystem bug here.
NS_ERROR_FAILURE (0x00004005)

Host : Ubuntu 10.10.
USB was OK until VBOX upgrade to 4.06 from 4.0.4.
USB devices not accessible. Message pops up when accessing machine's settings (NS_ERROR_FAILURE (0x00004005)).

Tried uninstalling and reinstalling extention pack, then virtualbox itself. Nothing changed. Tried to reboot host. No effect on the bug.

Rolling back to 4.0.4 for the moment. USB works again. :)

Any update on this issue welcome!
trucbidule
 
Posts: 13
Joined: 5. Feb 2010, 20:50
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: linux - windows

Re: Discuss the 4.0.6 Release

Postby AntiMatter » 23. Apr 2011, 02:37

Settings buttons disabled if VDI file not available

Using LinuxMint 10 x64 (same base as Ubuntu 10.10). I have re-organized my hard drive and moved all the VDI files to another folder. Of course, the VirtualBox GUI flags the VMs as not available. Formerly I just click Settings button and browse to the new location. Now with 4.06, the Setting button is disabled. The only way I could fix it is to edit manually the /home/username/.Virtualbox/VirtualBox.xml file.

I think that allowing to edit the Settings would make sense.
AntiMatter
Volunteer
 
Posts: 176
Joined: 2. Nov 2008, 06:48
Location: Canada
Primary OS: Ubuntu 12.04
VBox Version: PUEL
Guest OSses: All Windows (x32 & x64), Linux

Re: Discuss the 4.0.6 Release

Postby neanderthal » 23. Apr 2011, 10:44

same USB trouble here on win7 64 bit host and win7 32 guest. After starting VM, the usb hangs on both guest and host and I need to reboot host. Working fine on 4.0.4.
neanderthal
 
Posts: 18
Joined: 22. Apr 2011, 09:03
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Win7, WinXP, Linux

Re: Discuss the 4.0.6 Release

Postby gargamel » 23. Apr 2011, 11:42

Pandava cloud antivuris free is working now.
It would freeze the vm when clicking the panda icon in previous version.
Don't know if it's 4.0.6 fault but don't wanna downgrade when it's working now :D
I hope this forum is not only for bad news.

version: 4.0.6_OSEr71344 + extention
host: archlinux64
Linux bureel 2.6.38-ARCH #1 SMP PREEMPT Fri Apr 22 20:29:33 CEST 2011 x86_64 AMD Turion(tm) 64 X2 Mobile Technology TL-64 AuthenticAMD GNU/Linux
guest: vista32 + addition 4.0.6
gargamel
 
Posts: 1
Joined: 23. Apr 2011, 10:57
Primary OS: Linux other
VBox Version: PUEL
Guest OSses: xp-32 vista-32

Re: Discuss the 4.0.6 Release

Postby Prometej » 23. Apr 2011, 11:48

Perryg wrote:How many upgraded VirtualBox while the guest was in a saved state and not shut down?


I never use saved state, all vm were in shutdown state. If it matters, I use a lot snapshots per VM, but all are made in shutdown state.

Perryg wrote:Another question is were these VirtualBox upgrades or from a distro VirtualBox upgrades?


Allways make upgrade VirtualBox from downloaded installer.
I have another VirtualBox "server" runing headless VM on Arch Linux, but still running 4.0.4 version with no problems (some snapshot difficulties, but nothin non-solveable)
I'll try to upgrade to 4.0.6 to see if problem exists.
Prometej
 
Posts: 3
Joined: 13. Feb 2011, 10:23
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Archlinux, CentOS, Windows

Re: Discuss the 4.0.6 Release

Postby franck1135 » 23. Apr 2011, 13:05

For usb on linux put in /etc/udev/rules.d/ on name 10-vboxdrv.rules

KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="vboxusers", MODE="0660"
SUBSYSTEM=="usb_device", ACTION=="add", RUN="/opt/VirtualBox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass}"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN="/opt/VirtualBox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass}"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN="/opt/VirtualBox/VBoxCreateUSBNode.sh --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN="/opt/VirtualBox/VBoxCreateUSBNode.sh --remove $major $minor"
SUBSYSTEM=="usb_device", GROUP="vboxusers", MODE="0664"
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", GROUP="vboxusers", MODE="0664"

and chmod 644 /etc/udev/rules.d/10-vboxdrv.rules
chown root:root /etc/udev/rules.d/10-vboxdrv.rules
and reboot
franck1135
 
Posts: 1
Joined: 23. Apr 2011, 12:58
Primary OS: Other
VBox Version: PUEL
Guest OSses: Fedora

Re: Discuss the 4.0.6 Release

Postby zambosky » 23. Apr 2011, 13:55

Greetings.
I dowloaded and installed the latest VirtualBox version, 4.0.6 and installed guest additions and even the latest extension pack.
Host is Windows 7 X64, guest Xp 32
Problem :
After launched virtual box ( only this, without start any VM) and then I exit, i'm unable to use any usb device, as a pen drive or a Xbox controller.
I insert the usb device and nothing happen !
I have to re-start Windows 7 and then I have the possibility to insert pen.
As far as I remember this issue doesn't popped up with 4.0.4 but I'm not 100% sure.

Please any idea ?
Thank you in advance.

Sergio, Italy
zambosky
 
Posts: 3
Joined: 23. Apr 2011, 13:45
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: XP 32

Re: Discuss the 4.0.6 Release

Postby tmerriam » 23. Apr 2011, 18:10

Again with the USB support? This is getting extremely aggravating. Thanks franck, that udev rules edit did the trick.

If this is gonna be standard procedure for updates, I'm going to be looking for another VM. Sorry guys, and good luck.
tmerriam
 
Posts: 6
Joined: 24. Dec 2010, 18:02
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Windows 7

Re: Discuss the 4.0.6 Release

Postby kubuntu_9_10 » 23. Apr 2011, 23:20

Sorry, but the suggestion of franck1135 did not solve my problems with USB on kubuntu 9.10.
Absolutely no USB with applied changes of the file 10-vboxdrv.rules.

I needed to recover the original udev file make USB, as far as it works, workable again. :? :?
kubuntu_9_10
 
Posts: 4
Joined: 22. Apr 2011, 21:01
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: win xp

Re: Discuss the 4.0.6 Release

Postby Perryg » 23. Apr 2011, 23:41

@kubuntu_9_10,

none /proc/bus/usb usbfs devgid=118,devmode=664 0 0
Has not been needed for some time. Comment out the line in fstab.

What franck1135 has suggested may work for them but since the actual host is not specified there is no real way to tell.

Also you should always make a backup of any file you are editing if you do not know for sure it will work.

Here is a copy from one of my Ubuntu 10.10 hosts /etc/udev/rules.d/10-vboxdrv.rules. Compare but do not copy and paste. My builds are install in a different location due to the fact I build my own in testing. It also looks like franck1135 uses a build of OSE too as it installs in /opt
Code: Select all   Expand viewCollapse view
KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
SUBSYSTEM=="usb_device", ACTION=="add", RUN="/opt/VirtualBox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass}"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN="/opt/VirtualBox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass}"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN="/opt/VirtualBox/VBoxCreateUSBNode.sh --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN="/opt/VirtualBox/VBoxCreateUSBNode.sh --remove $major $minor"


Here is one from a release install on Ubuntu 10.04 which is probably closer to what you have.
Code: Select all   Expand viewCollapse view
KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
SUBSYSTEM=="usb_device", ACTION=="add", RUN="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN="/usr/share/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass} vboxusers"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN="/usr/share/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"
Perryg
Site Moderator
 
Posts: 34372
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Discuss the 4.0.6 Release

Postby kubuntu_9_10 » 24. Apr 2011, 00:35

Perryg,

I needed, and I did it, :P, a recovery of the original 10-vboxdrv.rules file to make USB, as far as it works, workable again. :?

if I comment out
none /proc/bus/usb usbfs devgid=118,devmode=664 0 0
USB does not work in VB.

I did not comment it out during applied improvement of franck1135.
kubuntu_9_10
 
Posts: 4
Joined: 22. Apr 2011, 21:01
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: win xp

PreviousNext

Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 27 guests