HP Compaq 8510P enable VTx in Bios is not enough?

This is for discussing general topics about how to use VirtualBox.

HP Compaq 8510P enable VTx in Bios is not enough?

Postby AntiMatter » 24. Nov 2010, 17:50

Hi,

Laptop model: HP Compaq 8510P (CPU is T8300, 64 bits and VTx compatible). Host: Windows 7 x64 using Virtualbox 3.2.10. Guest OS = Windows 2008 R2 (64 bits).

The VDI was prepared on another machine and is working OK. When copied to the laptop above. As soon as the VM starts, there is an error message saying that VTx must be enabled. In the bios, VTx is enabled but somehow Virtualbox seems not to be able to detect it. What is the reason and has anyone have has similar issue? More importantly, is there any possible fix?

Thanks in advance.
AntiMatter
Volunteer
 
Posts: 176
Joined: 2. Nov 2008, 06:48
Location: Canada
Primary OS: Ubuntu 12.04
VBox Version: PUEL
Guest OSses: All Windows (x32 & x64), Linux

Re: HP Compaq 8510P enable VTx in Bios is not enough?

Postby Perryg » 24. Nov 2010, 18:01

A simple test it to try to install a new 64bit guest and see if it works. If it does then you need to see why the image will not.
If it still complains then you need to check and see if there is a bios update for the unit. I have seen a lot where it says it is active but did not work and a bios update fixed the issue.
Perryg
Site Moderator
 
Posts: 25964
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: HP Compaq 8510P enable VTx in Bios is not enough?

Postby AntiMatter » 24. Nov 2010, 21:07

I'll go with Bios update. The Guest OS was carefully installed and the VDI used as base had been sysprep'ed and run on many other machines except this one.
AntiMatter
Volunteer
 
Posts: 176
Joined: 2. Nov 2008, 06:48
Location: Canada
Primary OS: Ubuntu 12.04
VBox Version: PUEL
Guest OSses: All Windows (x32 & x64), Linux

Re: HP Compaq 8510P enable VTx in Bios is not enough?

Postby edvard » 25. Nov 2010, 15:56

interesting information found here :

> http://blog.avivasolutions.nl/archive/2 ... aptop.aspx

=======================================================================================================
How to enable VT-x on HP 8510p laptop

Until the introduction of VirtualBox 3.0 (which includes SMP support) I never really cared for enabling hardware assisted virtualization, since it actually slowed down my VMs. But since the new VirtualBox version requires this in order to use more than one processor, I needed to enable this in my BIOS. However, after enabling the setting within the BIOS, and restarting my laptop, the VT-x option was still disabled within VirtualBox.

After several reboots and reinstalls of VirtualBox, I stumbled across a post (can’t remember the link unfortunately), where the suggestion was made that – after you have enabled the hardware assisted VT option in the BIOS – you remove the battery for at at least 30 seconds.

After that, reboot and voila! VT-x is enabled inside VirtualBox.
Posted on 02-07-2009 by Arnold Jan van der Burg
1 Comments | Trackback Url | Link to this post
Tags:
Links to this post
Comments
10-08-2009 by Toetke

Thanks! Had the same problem, this solved it.
=======================================================================================================

good luck,

edvard
edvard
 
Posts: 10
Joined: 18. Nov 2009, 10:10
Location: Hamburg
Primary OS: openSUSE
VBox Version: PUEL
Guest OSses: W2K, OpenSuSE11.2, OEL

Re: HP Compaq 8510P enable VTx in Bios is not enough?

Postby BillG » 27. Nov 2010, 03:16

That is interesting. For a BIOS update to happen, you need to do a power off, not just a reboot. I had heard that for some laptops you may need to actually remove the battery to achieve this, but I had never heard it first-hand from somebody who actually had to do this.
BillG
Volunteer
 
Posts: 2202
Joined: 19. Sep 2009, 04:44
Location: Sydney, Australia
Primary OS: MS Windows 8
VBox Version: PUEL
Guest OSses: Win 7, Win8, Windows Server 2008&2012


Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 11 guests