OVF Import Issues

This is for discussing general topics about how to use VirtualBox.

OVF Import Issues

Postby ShadesOfGrey » 9. Jan 2010, 06:49

I'm having some difficulty importing an OVF file from a Windows XP Pro (SP3) desktop to a Vista Home Premium (SP2) laptop both are 32-bit versions. Both Hosts are running VirtualBox 3.1.2 (build 56127). The guest is OS I'm trying to import is Windows XP Pro (SP3). I should probably mention this is the first time I've tried exporting/importing an appliance. Importing the OVF results in the following error messages. My best guess, based on the error reported, is that the checksums aren't being validated for some reason. Presumably at line 697. The question now is, what can I do about it?

I checked the checksums manually BTW and they are fine.

From the command line:

Code: Select all   Expand viewCollapse view
C:\Program Files\Sun\VirtualBox>VBoxManage.exe import "D:\Sand Box (IE7).ovf" --
vsys 0 --vmname "Sand Box"
VirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Interpreting D:\Sand Box (IE7).ovf...
OK.
Disks:  vmdisk1 10737418240     -1      http://www.vmware.com/specifications/vmd
k.html#sparse   Sand Box (IE7).vmdk     1172166144      -1      <NULL>
Virtual system 0:
 0: Suggested OS type: "WindowsXP"
    (change with "--vsys 0 --ostype <type>"; use "list ostypes" to list all poss
ible values)
 1: VM name specified with --vmname: "Sand Box"
 2: Number of CPUs: 1
    (change with "--vsys 0 --cpus <n>")
 3: Guest memory: 384 MB
    (change with "--vsys 0 --memory <MB>")
 4: Sound card (appliance expects "ensoniq1371", can change on import)
    (disable with "--vsys 0 --unit 4 --ignore")
 5: Network adapter: orig NAT, config 2, extra type=NAT
 6: Floppy
    (disable with "--vsys 0 --unit 6 --ignore")
 7: CD-ROM
    (disable with "--vsys 0 --unit 7 --ignore")
 8: IDE controller, type PIIX4
    (disable with "--vsys 0 --unit 8 --ignore")
 9: SATA controller, type AHCI
    (disable with "--vsys 0 --unit 9 --ignore")
10: Hard disk image: source image=Sand Box (IE7).vmdk, target path=D:\Users\Shad
esOfGrey\.VirtualBox\HardDisks\Sand Box (IE7).vmdk, controller=8;channel=1
    (change controller with "--vsys 0 --unit 10 --controller <id>";
    disable with "--vsys 0 --unit 10 --ignore")
0%...FAILED
ERROR: Couldn't verify the content of 'Sand Box (IE7).mf' against the available
files (VERR_MANIFEST_FILE_MISMATCH)
Details: code VBOX_E_FILE_ERROR (0x80bb0004), component Appliance, interface IAp
pliance, callee <NULL>
Context: "ImportAppliance" at line 697 of file VBoxManageImport.cpp


The error message form the GUI:
Attachments
VirtualBox-Error.jpg
Error Message from VirtualBox Import
VirtualBox-Error.jpg (27.31 KiB) Viewed 9397 times
ShadesOfGrey
 
Posts: 1
Joined: 9. Jan 2010, 06:06
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Linux, Windows, AROS, Haiku

Re: OVF Import Issues

Postby fabrizio.perin » 19. Feb 2010, 16:58

Hi,
i had the same problem with the version 3.1.4. According to a comment found here

http://www.virtualbox.org/svn/vbox/trun ... ceImpl.cpp

the system check the manifest file just if it exist. What i did was simply remove the .mf file from the directory where the .ovf and .vmdk files are and the import works fine.

This is not a solution but at least you can import your stuff.

Cheers,

Fabrizio
fabrizio.perin
 
Posts: 1
Joined: 19. Feb 2010, 16:52
Primary OS: Mac OS X Leopard
VBox Version: OSE other
Guest OSses: Ubuntu9.10

Re: OVF Import Issues

Postby lamaslany » 18. Mar 2010, 19:35

I am also encountering the same problem running version 3.1.4, importing to Windows 7 x64 from Windows 7 x64, and removing the manifest has indeed allowed me to complete the import. Thanks fabrizio.perin! :D
lamaslany
 
Posts: 2
Joined: 18. Mar 2010, 19:31
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Windows XP, 7, 2003, 2008, 2008 R2 & Ubuntu

Re: OVF Import Issues

Postby Flopsy007 » 10. Aug 2010, 09:36

Thank you, thank you, thank you Fabrizio.

Couldn't import > removed the .mf file and VOILA!! It worked like a charm. Saved me hours which I can now use on something a bit more funny than reinstalling Windows 7 + apps.
Flopsy007
 
Posts: 1
Joined: 10. Aug 2010, 09:30
Primary OS: Mac OS X Leopard
VBox Version: PUEL
Guest OSses: Windows 7

Re: OVF Import Issues

Postby scottro » 10. Jan 2013, 05:08

I also want to say thanks. I ran into something quite similar.

A pity that they don't offer that solution in the error message. Like Flopsy007, a simple removal of the mf file allowed a successful import (of a different image).
scottro
 
Posts: 20
Joined: 6. May 2008, 01:30


Return to Using VirtualBox

Who is online

Users browsing this forum: Google [Bot] and 14 guests