No Network Adapters in VirtualBox

This is for discussing general topics about how to use VirtualBox.

No Network Adapters in VirtualBox

Postby slafochmed » 23. Dec 2009, 22:21

Hi there. :)
I have just moved my vmware guest system to the virtual box 3.1.2.
But my virtualbox cannot install any network adapter hardware.
My host is Windows XP Prof. 64bit
My guest is Windows XP Prof. 32bit
I have installed the Guest Additions. Worked fine to install the Graphics drivers.
I tried all 3 kinds of network configurations
PCNet-Fast
Intel Pro
virtio-net
But I only selected these in combination with Host-only or NAT before switching on the virtualbox - without success.
My host system shows a working Host-only Virtual box adapter (connected).

Can someone help me?
slafochmed
 
Posts: 4
Joined: 23. Dec 2009, 22:13
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: Win XP Prof. 32bit

Re: No Network Adapters in VirtualBox

Postby stefan.becker » 23. Dec 2009, 22:30

Try the Intel Card. You need to install a driver for e1000 from the intel homepage.
stefan.becker
Volunteer
 
Posts: 7046
Joined: 7. Jun 2007, 21:53

Re: No Network Adapters in VirtualBox

Postby slafochmed » 23. Dec 2009, 23:02

Thank you alot! It works fine after installing the driver!
I was confused because in the help there is something that you only need to install intel driver for vista or later.
I burned the install exe to a cd image and loaded it into the virtualbox.
After installing, not even a restart was necessary.
8) :P :P :P 8)
slafochmed
 
Posts: 4
Joined: 23. Dec 2009, 22:13
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: Win XP Prof. 32bit

Re: No Network Adapters in VirtualBox

Postby mpack » 24. Dec 2009, 12:18

slafochmed wrote:I was confused because in the help there is something that you only need to install intel driver for vista or later.

That's usually true. XP Pro 32bit has native support for the Intel NICs provided by VirtualBox (that is part of the reason why VBox virtualizes those particular NICs and not some others). Native support for these old NICs was dropped in Vista and later (ditto for the sound card).

Is it possible your XP Pro guest had been nlited or something like that in the past? Anyway, not a problem now.
mpack
Site Moderator
 
Posts: 13171
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Mostly XP

Re: No Network Adapters in VirtualBox

Postby kjurkic » 11. Feb 2010, 01:51

Hiya

Just a follow-up for anyone else who might encounter similar problem.

I migrated a VMware windows XP production image onto VBox, and encountered the same problem; the PCnet fast nics would be detected but would not work no-way, no -how. XP would not see the intel nics at all.

I followed the prior post to download intel e1000, inject into ISO image, attach that to the guest settings, and boot. Ran the install, rebooted, and "there was much rejoicing"

regards
Ken
kjurkic
 
Posts: 9
Joined: 11. Jan 2009, 01:36


Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 9 guests

cron