Page 16 of 19

Re: 3D Acceleration Support

PostPosted: 28. Oct 2010, 00:13
by jnygaard
Hope this is not covered in the FAQ or too obvious - I've just discovered VB and the possibilities it offers:

I got OpenGL to work, at least it seems so at the moment (Ubuntu 9.10 host, XP guest, VB version 3.0.8) but my application also makes use of some (relatively simple) GL shaders. Something, and I suspect these shaders, really messes up the display, even though the app or guest OS does not actually crash. The app does behave odd, and the framebuffer somehow gets corrupted beyond the VB's ability to repaint/fix it.

Am I right in my suspicions, or should such shaders work? Would it be different for a newer VB? (3.0.8 is the one my ubuntu offers per default.)

J.

Re: 3D Acceleration Support

PostPosted: 17. Dec 2010, 22:46
by Technologov
few ideas:
1. update host OS video drivers for ATI/NVIDIA
2. Try VirtualBox 4.0.0 BETA (if you want)

Re: 3D Acceleration Support

PostPosted: 19. Dec 2010, 21:25
by mcp
Quick question: If I previously installed the 3d driver do I have to reinstall it each time the GA is updated?

MCP

Re: 3D Acceleration Support

PostPosted: 19. Dec 2010, 21:32
by Technologov
Unfortunately, Yes.

Re: 3D Acceleration Support

PostPosted: 22. Dec 2010, 20:09
by wotan
In the 4.0 series (including the Betas, other more pressing problems prevented me from spending time one it) results in the following messages when trying to enable 3D support:
Code: Select all   Expand viewCollapse view
[    53.790] (II) Next line is added to allow vboxvideo_drv.so to appear as whit
elisted driver
[    53.790] (II) The file referenced, is *NOT* loaded
[    53.790] (II) Loading /usr/lib/xorg/modules/drivers//ati_drv.so
[    53.790] (EE) AIGLX error: vboxvideo does not export required DRI extension
[    53.791] (EE) AIGLX: reverting to software rendering
[    54.046] (II) AIGLX: Loaded and initialized /usr/lib/dri/swrast_dri.so
[    54.046] (II) GLX: Initialized DRISWRAST GL provider for screen 0


Host is XP SP3, guest is a rolling release of Sabayon+limbo repository.

Re: 3D Acceleration Support

PostPosted: 21. Jan 2011, 20:32
by ZioNemo
I have VirtualBox 4.0.2 r.69518 installed on an up-to-date ubunu-10.10 host.
The Graphic card is an ATI Radeon HD4250 (I do attach an image with full specs).
I prepared a test Guest (WinXpSP3) and installed GA (YES I did check 3D support AND installed in safe-mode).
Unfortunately the 3D support does not work well; I do attach full DxDiag results.
To that I should add Direct3D 9 tests reports "All tests were successful" because I could see the rotating cube, but that is somewhat not true since the screen was flickering badly between that full-screen image and the background (green hill and bottom toolbar with "start" button).

Did I do something wrong or the support is still this buggy?
I assume the "Several files (d3d8.dll, d3d9.dll) are old versions" warning is due to the GA patched files, but I could be wrong.

Thanks for any comment
ZioNemo

Re: 3D Acceleration Support

PostPosted: 29. Jan 2011, 23:45
by Bushwalker
My VM (4.0.2) crashes during Win XP guest start-up when 3D acceleration is enabled. I've reported it here: viewtopic.php?f=6&t=38570.
Has anybody else experienced the same issue?

Re: 3D Acceleration Support

PostPosted: 26. Feb 2011, 02:07
by boeroboy
Yes I have the same problem after an upgrade to 4.0.2. I was developing an OpenGL app in Win 7 Home Prem x86 (Sabayon 2.6.36 x86_64 host). After the upgrade and guest additions upgrade, my windows appeared blank. I tried to revert my guest additions to 3.2.10 and now the application fails out with an invalid rendering context. Once again an upgrade causes more damage than good. I will be reverting to 3.2.10 or 3.2.12 later. Too much time wasted on it today. Unless someone posts a handy workaround over the weekend?? *wink-wink*
Thanks

Re: 3D Acceleration Support

PostPosted: 29. Mar 2011, 19:34
by SoftCoder
Yes I have the same problems, after going up to 4.x opengl apps crash with invalid enumerant etc (I am an open source author working on an RTS game for Linux / Windows). The same OpenGL code that used to work in 3.x no longer works on 4.x, even though the binaries work fine on the native Operating Systems.

Re: 3D Acceleration Support

PostPosted: 29. Mar 2011, 20:05
by Technologov
It would be nice if you could upload the demo of those binaries, that crash on VBox 4.0, so we can open bug about this.

Could you make such a freeware demo ?

Re: 3D Acceleration Support

PostPosted: 30. Mar 2011, 03:47
by SoftCoder
Download the 3.4.0 release of megaglest from megaglest.org (source is fully available on sourceforge.net, wiki etc mentioned on megaglest.org). For any assistance looking at code etc visit us on freenode at #glest.

Thanks

Re: 3D Acceleration Support

PostPosted: 30. Mar 2011, 03:49
by Technologov
Open bug in VBox bugzilla, and provide links to demo there.

Drop bug number here (after you open bug).

Re: 3D Acceleration Support

PostPosted: 1. Apr 2011, 22:35
by SoftCoder
Ticket #8666, thanks

Re: 3D Acceleration Support

PostPosted: 26. Jul 2011, 16:55
by JFekete9076
Is there any information about whether VirtualBox supports OpenGL 2.1 and newer versions?

Re: 3D Acceleration Support

PostPosted: 26. Jul 2011, 21:11
by Technologov
OpenGL 2.1 is supported, according to change-log of "Version 3.2.0 (2010-05-18)".

No new versions of OpenGL were added since then... just bug fixes.