Page 14 of 19

Re: 3D Acceleration Support

PostPosted: 17. Nov 2009, 13:40
by Leonid
It *IS* required to install d3d guest additions from safe mode atleast the first time.
It is also recommended to update d3d support from the safe mode as well. Overwise you might get it correctly installed or not with about 50/50 chance.

Re: 3D Acceleration Support

PostPosted: 17. Nov 2009, 13:42
by Technologov
I have plenty of VMs here, and all installed from normal mode, and 3D works.

Re: 3D Acceleration Support

PostPosted: 19. Nov 2009, 16:15
by Leonid
It's 50/50 chance...it also depends on whenever you've installed wine's 3d support a while ago, which service pack is installed on your system etc.
Personally I'm not going in safe mode and I don't use the installer at all...but that doesn't change the point:
As stated in manual and as a general suggestion it is required to install 3d support from safe mode, unless you want to deal with possible problems on your own.

Re: 3D Acceleration Support

PostPosted: 24. Nov 2009, 02:49
by jwatte
Actually, using Windows XP SP3 guest, Windows 7 host, installing the additions didn't work right (DXCapsViewer didn't see the card). Rebooting in safe mode and re-running the Guest Additions installer, then rebooting again, made it work. The card shows up as a GeForce FX 5200.
However, Wizard101 (one of my test apps, because it targets low-end hardware) doesn't draw right. The environment has lots of black, and the avatars don't show up at all.

Re: 3D Acceleration Support

PostPosted: 24. Nov 2009, 14:10
by Nacho
Hi,

I'm using the VBox that comes with VDI 3.1, on Solaris 10 (5/10) and a Sun Ultra 24 workstation.
VBox Version is 3.0.5 and I've installed Windows Vista Business Edition SP1 32-bit.
I've installed Guest Additions under Windows Safe Mode

My problem is that the "Enable 3d acceleration" is grayed out.
It does not happen with other versions of VBox, such as 3.0.12, but VBox 3.0.5 is the only compatible with VDI 3.1

Solaris won't recognize the command "glxinfo |grep direct "

Some help, please?

Re: 3D Acceleration Support

PostPosted: 24. Nov 2009, 16:46
by Technologov
Since it looks like VBox Version is 3.0.5 is internal version for VDI use, I recommend you to try to hack the VDI system to work with custom VBox. (such as VBox 3.0.12 or 3.1.0-BETA2)

Re: 3D Acceleration Support

PostPosted: 24. Nov 2009, 17:42
by Nacho
Thanks Technologov

Everything works now.
I uninstalled VBox 3.05 and installed VBox 3.0.12.

Re: 3D Acceleration Support

PostPosted: 30. Nov 2009, 20:25
by chrismounce
My Ubuntu 9.10 guest doesn't work right with VirtualBox 3.1.0 if 3D acceleration is enabled. It gets to the login screen and lets you log in, but the screen freezes (or appears to freeze) before the desktop comes up. Works just fine if 3D acceleration is turned off.

I'll try reinstalling Ubuntu tonight, but I just wanted to know if anyone else is having this problem.

Host is OS X 10.5.8

Re: 3D Acceleration Support

PostPosted: 2. Dec 2009, 02:54
by chrismounce
Just reinstalled Ubuntu 9.10. 3D support still messes up the screen as soon as I log in, even when installing guest additions onto a fresh install of Ubuntu.

The screen flickers and flips, and then returns to normal -- but it never progresses to the user desktop.

Ubuntu 9.10

PostPosted: 4. Dec 2009, 19:52
by crhylove
Ubuntu 9.10 is nothing but a giant mess of bugs. Don't get me wrong, I'm a Linux fan, and in particular a Mint fan (which is an Ubuntu remix, sort of). But the latest Ubuntu is a giant hideous mess of bugs, bloat and poor decision making by Canonical. Even the new Mint does not fix all the problems.

Linux Mint 7 is still probably one of the most stable, solid, easy OSes I have ever used, both in VM and native. It's based on Ubuntu 9.04, which is obviously much, much better than the latest release.

Just my 2 cents. I don't think your issues are Vbox issues. It's more likely the horrendous lack of quality control that went into the current Ubuntu.

Re: 3D Acceleration Support

PostPosted: 12. Dec 2009, 15:30
by Technologov
Interesting Paper explaining why VMware chose Gallium3D: (12.12.2009)
http://vmware-svga.svn.sourceforge.net/ ... revision=1

Re: 3D Acceleration Support

PostPosted: 18. Dec 2009, 00:59
by chrismounce
Just tried Ubuntu 9.10 on VirtualBox 3.1.2, and 3D support seems to be back to where it was before 3.1. There are still a few graphical glitches, but at least now the system's usable.

Re: 3D Acceleration Support

PostPosted: 25. Dec 2009, 16:42
by ryeckley82
I honestly don't understand why manufacturers feel threatened by Open Source. Why not give users a choice of emulating a Diamond Stealth 3D 2000, nVidia RivaTNT, or an older ATI Radeon? That way Windows 98 to XP is covered! :)

Re: 3D Acceleration Support

PostPosted: 25. Dec 2009, 17:15
by Technologov
I also thought about that... actually opening up old chip set specifications along with drivers won't hurt them...

Re: 3D Acceleration Support

PostPosted: 2. May 2010, 18:25
by pete_21
Hi!
I would like to ask, if Aero works for you in Windows 7 ?
I have an x86 Win7 guest, and when i run the Experience index, the vm freezes. Am i doing something wrong, or is it still unsupported?
Thanks