failed to created a proxy device for the usb device.

This is for discussing general topics about how to use VirtualBox.

failed to created a proxy device for the usb device.

Postby mhollowman » 9. Mar 2009, 15:09

Hi all



Is there any chance anyone has any experience on this (detailed below)? Thank you very much.

Failed to create a proxy device for the USB device. (Error: VERR_READ_ERROR).

Result Code: NS_ERROR_FAILURE(0X80004005)
Component: Console
Interface: IConsole

Could this be a problem in the host or VB? Thanks. I connected this device to the computer directly and it worked fine. But when I connected the device to the computer via a hub, this error message showed up. No clue at all. Thanks for helping out.
mhollowman
 
Posts: 2
Joined: 9. Mar 2009, 15:03

Re: failed to created a proxy device for the usb device.

Postby vbox4me2 » 9. Mar 2009, 15:32

Usb hubs are notorious for such problems, don't use hubs if you can.
vbox4me2
Volunteer
 
Posts: 5222
Joined: 21. Nov 2008, 20:27
Location: Rotterdam

Re: failed to created a proxy device for the usb device.

Postby mhollowman » 9. Mar 2009, 17:39

Hi thanks for the information. But a USB key connected via the same hub can be recognized by the guest and worked well. Do you think this error message is caused by the communication between the host and the USB device please? Thank you.
mhollowman
 
Posts: 2
Joined: 9. Mar 2009, 15:03

Re: failed to created a proxy device for the usb device.

Postby Murz » 15. Jul 2009, 18:43

Same problem on Debian Squeeze & Virtualbox 3.0:
USB devices like Flash Drives, USB mouse and keyboards attaches good, but one device (Amicon USB VPN key) failed to attach with error:
Code: Select all   Expand viewCollapse view
00:00:31.881 ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={9511bc54-15ee-4ddf-808e-472aba03809c} aComponent={Console} aText={Failed to create a proxy device for the USB device.  (Error: VERR_READ_ERROR)} aWarning=false, preserve=false

I try older Virtualbox 2.2 but it isn't help.
This key attaches normally on Ubuntu Jaunty (i386 and amd64) & Virtualbox 3.0 (on three computers!), but on Debian - fails. What I can look or do for search the problem?

USB device info (/proc/bus/usb/devices file):
Code: Select all   Expand viewCollapse view
T:  Bus=04 Lev=01 Prnt=01 Port=02 Cnt=01 Dev#=  3 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=16 #Cfgs=  1
P:  Vendor=a420 ProdID=5420 Rev= 1.00
S:  Manufacturer=AMICON
S:  Product=VPNLDR 1.5
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=130mA
I:* If#= 0 Alt= 0 #EPs= 4 Cls=00(>ifc ) Sub=00 Prot=00 Driver=(none)
E:  Ad=01(O) Atr=02(Bulk) MxPS=  16 Ivl=0ms
E:  Ad=81(I) Atr=02(Bulk) MxPS=  16 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=82(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
Murz
 
Posts: 16
Joined: 20. Aug 2008, 13:36

Re: failed to created a proxy device for the usb device.

Postby Graff » 28. Jul 2009, 07:24

the same problem with amicon vpnloader. debian lenny vbox 3.0.2. does anyone have any suggestion?
Graff
 
Posts: 5
Joined: 17. Jun 2008, 16:06

Re: failed to created a proxy device for the usb device.

Postby Graff » 28. Jul 2009, 21:03

i've played a bit with my box again, thinking that it's a problem with rights
I run virtualbox in headless mode from root, controlling it via vrdp

here is output of VBoxManage list usbhost before experiment:
    UUID: 1115d7c8-d11e-41b4-b9e7-6d8851c1dfee
    VendorId: 0xa420 (A420)
    ProductId: 0x5420 (5420)
    Revision: 1.0 (0100)
    Manufacturer: AMICON
    Product: VPNLDR 1.5
    Address: /proc/bus/usb/003/002
    Current State: Available

the device seems is connected and aviable to connect

then I connect it to virtualbox by this:
Code: Select all   Expand viewCollapse view
VBoxManage controlvm WinXP usbattach /proc/bus/usb/003/002


the device seems to be captured:
    UUID: 1115d7c8-d11e-41b4-b9e7-6d8851c1dfee
    VendorId: 0xa420 (A420)
    ProductId: 0x5420 (5420)
    Revision: 1.0 (0100)
    Manufacturer: AMICON
    Product: VPNLDR 1.5
    Address: /proc/bus/usb/003/002
    Current State: Captured

the vm is very slow this time, and then nothing happens and in several seconds device state becomes:
    UUID: 1115d7c8-d11e-41b4-b9e7-6d8851c1dfee
    VendorId: 0xa420 (A420)
    ProductId: 0x5420 (5420)
    Revision: 1.0 (0100)
    Manufacturer: AMICON
    Product: VPNLDR 1.5
    Address: /proc/bus/usb/003/002
    Current State: Held

so, what's wrong is it? where can I find the problem?
Once again I should say that the situation is the same while running virtualbox from my user or from root.
Graff
 
Posts: 5
Joined: 17. Jun 2008, 16:06

Re: failed to created a proxy device for the usb device.

Postby Murz » 23. Sep 2009, 08:38

I'll try to attach the usb device to the virtualbox guest winxp started by user, by user via sudo and by root, in all times I can't connect the AMICON VPNLDR 1.5 device. Other usb devices (flash drives, mouse, keyboard, etc) connects successfully.
What difference in permissons when attaching AMICON and other USB device?
Murz
 
Posts: 16
Joined: 20. Aug 2008, 13:36

Re: failed to created a proxy device for the usb device.

Postby Murz » 9. Oct 2009, 13:52

I have updated virtualbox on Debian Squeeze to 3.0.8-53138_Debian_lenny because in changelog I have found:
# Linux hosts: change the default USB access mode on certain distributions (bugs #3394 and #4291)

But the problem with AMICON VPNLDR 1.5 USB dongle (VPN key) is still here.

Can anybody tell me the method to detect the problem or which files and packages is depend on the usb mount process in virtualbox?
Murz
 
Posts: 16
Joined: 20. Aug 2008, 13:36

Re: failed to created a proxy device for the usb device.

Postby Murz » 9. Oct 2009, 14:15

I have created a bug-report about this problem: http://www.virtualbox.org/ticket/5175
Murz
 
Posts: 16
Joined: 20. Aug 2008, 13:36

Re: failed to created a proxy device for the usb device.

Postby Starsis » 15. Oct 2012, 09:59

Hello everyone, i have that same error message and coming here just to tell what i noticed if it can help (i am far from being competent with linux yet so this wont be technical at all).
I have to install a work station under linuxmint 13 (maya) and have to install a windows XP host ... problems occurs when i need to install and configure a "Silhouette CAMEO" wich basically is a "cutter" ...

Here is the facts : as soon as i plug the cameo and turn it on, linuxmint detects it and tell me there is no driver for it ... then i can add an usb filter saying "unknown device" or something like that, then if i launch the VM i get this message :

"Échec de la connexion du périphérique USB Périphérique inconnu 0B4D:1121 [0100] à la machine virtuelle Windows XP.
Failed to create a proxy device for the USB device. (Error: VERR_READ_ERROR)."

if i just start my VM and turn the power on, i get the linux driver message then this message ... nothing to do then ...

BUT ... when i just plug the cameo and turn it on, then reboot my host, no detection, no error message, then boot my VM, the cameo is fully recognized and usable ... of course if i ever turn it off or unplug and plug it again, the same crap happen.

I think that once linux "know" that peripherial wont work, he cant make a link between the usb port and the VM, but can do without even knowing its here ... wich sound totally strange but well ... thats what i noticed.

Hope (even if i doubt it) this will help or anyone would have a solution for linuxmint, for now editing files that i dont even really understand the use sounds like losing more time than i actualy do so im reluctant to try such and such said solution i could read :)

Cordially, Matthias Joets.
Starsis
 
Posts: 1
Joined: 15. Oct 2012, 09:49


Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 7 guests