Page 1 of 1

change usb settings from 2.0 to 3.0

PostPosted: 15. Apr 2021, 20:10
by Eneros
running Oracle VB Version 6.1.18 r142142 (Qt5.6.2) with/VirtualBox 6.1.18 Oracle VM VirtualBox Extension Pack
running kali 2020 x 64 customized by Zcurity v1.3 on oracle VB
running Device name DESKTOP-Q92CA83
Processor AMD A10-9600P RADEON R5, 10 COMPUTE CORES 4C+6G 2.40 GHz
Installed RAM 6.00 GB (4.97 GB usable)
System type 64-bit operating system, x64-based processor
HP computer
Tried to post pic of logs for VB. Since Its my first post our site wont let me yet. My logs are very long how would you like me to post them if needed?

I have read post on this with no help for me. Running Kali but could not get results in airodump-ng wlano cause I am on usb 2.0 need to change to usb 3.0 but the usb setting is greyed out and yes I installed vmbox update and reinstalled update but nothing I have tried will open up usb from being greyed out and let me change from 2.0 to 3.0 thx Eneros

Re: change usb settings from 2.0 to 3.0

PostPosted: 16. Apr 2021, 11:02
by mpack
Enable "USB 3.0 (xHCI)" in the VM settings.

USB level is not a decision made in software. If you plug a USB3 device into a USB3 host port then it uses USB3. Then the question was only: does the guest OS support USB3, and have you captured this host device in the guest.

Any further discussion will require a VM log. Make sure the VM is fully shut down, then right click it in the manager UI. Select "Show Log" and save "VBox.log" (no other file) to a zip file. Attach the zip here.

Also read: USB Basics and Troubleshooting.