Discuss the 6.1.30 release

This is for discussing general topics about how to use VirtualBox.

Discuss the 6.1.30 release

Postby arudnev » 22. Nov 2021, 21:45

Discuss the VirtualBox 6.1.30 release here.
You can download the release here.
VirtualBox 6.1.30 is a maintenance release.

Changelog is here.
arudnev
Oracle Corporation
 
Posts: 39
Joined: 20. Feb 2018, 14:59

Re: Discuss the 6.1.30 release

Postby Oracleiscool » 24. Nov 2021, 21:08

@arudnev

Saw no other postings here, so just a heads up!

6.1.30 installed on top of 6.1.28 on Windows 10 Host at 21H2 level (fully updated with MS and Hyper-V already configured per our previous postings in 10 and 11) without error.
Extension Pack (6.1.30) was installed via VB Control Panel (No errors) Restart OK (Old Habits die hard, eh?).

VMs are Ubuntu (latest stable LTR) and MX-21.

Ubuntu saw new guest addition and offered it up as a shell run after selected from Devices Menu, then ran with no errors (restart required).

MX21 dropped to blinking cursor on first power-up, blank desktop. Restarted system, then desktop (KDE Plasma) came up, then had to manually load (from Devices Menu) guest additions and mount,then usual file manager, find start shell, execute, some complaining about updating the previous kernel, just let it run through, then restart after kernel recompile (also have seen this in previous MX versions). I think they write their own custom Guest Additions for VB, but I do not normally use them as a general rule. All is well. Job well done :D
Oracleiscool
 
Posts: 53
Joined: 12. Aug 2021, 19:51
Location: US
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: MX21 Ubuntu

Re: Discuss the 6.1.30 release

Postby deckrider » 27. Nov 2021, 19:36

I'm still having the same trouble on Windows 10...

Code: Select all   Expand viewCollapse view
Edition   Windows 10 Enterprise
Version   20H2
Installed on   ‎10/‎20/‎2021
OS build   19042.1348
Experience   Windows Feature Experience Pack 120.2212.3920.0


...with VirtualBox 6.1.30 as I had with 6.1.28 (6.1.26 is still working for me)...

Code: Select all   Expand viewCollapse view
Failed to open a session for the virtual machine Ubuntu.

Failed to load R0 module C:\Program Files\Oracle\VirtualBox/VMMR0.r0: SUP_IOCTL_LDR_OPEN failed (VERR_LDR_GENERAL_FAILURE).

Failed to load VMMR0.r0 (VERR_LDR_GENERAL_FAILURE).

Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}


So I opened the following ticket and attached the output of VBoxBugReport.exe to it:

www virtualbox org ticket 20694
deckrider
 
Posts: 5
Joined: 27. Nov 2021, 19:26

Virtual Box :Failed to load VMMR0.r0 (VERR_LDR_GENERAL_FAILURE)

Postby deckrider » 28. Nov 2021, 18:50

I seem to be have the same issue when using 6.1.28 and 6.1.30. Only 6.1.26 is working for me:

www virtualbox org/ticket/20694
forums virtualbox org/viewtopic.php?f=1&t=104524
deckrider
 
Posts: 5
Joined: 27. Nov 2021, 19:26

Re: Discuss the 6.1.30 release

Postby scottgus1 » 28. Nov 2021, 23:28

Couple more folks with the 6.1.28 bug on 6.1.30 too:
viewtopic.php?f=6&t=104576
viewtopic.php?f=6&t=104574
scottgus1
Site Moderator
 
Posts: 14329
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: Discuss the 6.1.30 release

Postby fth0 » 30. Nov 2021, 03:13

deckrider wrote:I seem to be have the same issue when using 6.1.28 and 6.1.30.

On your Windows host, please go to Start > Settings > Update & security > Windows Security > Open Windows Security, select Device security, then Core isolation details. Under Core Isolation, check if Memory integrity is turned on or off. If it's on, turn it off, reboot the Windows host, and check if your issue persists.
fth0
Volunteer
 
Posts: 2765
Joined: 14. Feb 2019, 03:06
Location: Germany
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Linux, Windows 10, ...

Re: Discuss the 6.1.30 release

Postby deckrider » 30. Nov 2021, 17:18

fth0 wrote:
deckrider wrote:I seem to be have the same issue when using 6.1.28 and 6.1.30.

On your Windows host, please go to Start > Settings > Update & security > Windows Security > Open Windows Security, select Device security, then Core isolation details. Under Core Isolation, check if Memory integrity is turned on or off. If it's on, turn it off, reboot the Windows host, and check if your issue persists.


It is "on" and the administrator will not allow me to change it.
deckrider
 
Posts: 5
Joined: 27. Nov 2021, 19:26

Re: Discuss the 6.1.30 release

Postby scottgus1 » 30. Nov 2021, 19:13

fth0 wrote:check if Memory integrity is turned on or off

Interesting! I wonder if this was the source of the bug all along.

deckrider wrote:It is "on" and the administrator will not allow me to change it.

This will be a blocker, then, until and if the devs can get Virtualbox to run with Memory integrity enabled. You might try making a case to your boss that Virtualbox is needed for work, then maybe the boss can get IT to let up.
scottgus1
Site Moderator
 
Posts: 14329
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: Discuss the 6.1.30 release

Postby deckrider » 30. Nov 2021, 21:01

scottgus1 wrote:
fth0 wrote:check if Memory integrity is turned on or off

Interesting! I wonder if this was the source of the bug all along.

deckrider wrote:It is "on" and the administrator will not allow me to change it.

This will be a blocker, then, until and if the devs can get Virtualbox to run with Memory integrity enabled. You might try making a case to your boss that Virtualbox is needed for work, then maybe the boss can get IT to let up.


Please allow me to be certain I understand before I pester my admins:

6.1.26 is expected to work with Memory integrity enabled
6.1.28, 6.1.30, and higher is expected to fail with Memory integrity enabled

Do I have this right?
deckrider
 
Posts: 5
Joined: 27. Nov 2021, 19:26

Re: Discuss the 6.1.30 release

Postby fth0 » 1. Dec 2021, 00:19

deckrider wrote:6.1.26 is expected to work with Memory integrity enabled
6.1.28, 6.1.30, and higher is expected to fail with Memory integrity enabled

Do I have this right?

Perhaps. ;)

Seriously, I don't know (yet). For the time being, it's "just" an educated guess. Let me try and summarize a few aspects:

Microsoft wrote:Hypervisor-protected Code Integrity (HVCI) is a virtualization based security (VBS) feature available in Windows. In the Windows Device Security settings, HVCI is referred to as Memory Integrity.

1. Windows 10 and 11 are constantly changing. New Windows installations and perhaps also Windows updates enable HVCI under certain conditions. Additionally, Microsoft quietly enhanced its VBS implementations over the years. HVCI is the only VBS feature that is suspected to conflict with some VirtualBox installations so far.

2. The SUP_IOCTL_LDR_OPEN failure when loading VMMR0.r0 has been reported by ~10 VirtualBox users in the last 4 weeks, and the reports indicated that it occurred with VirtualBox 6.1.28 and 6.1.30, but not 6.1.26.

This type of VirtualBox error could very well be caused by HVCI, but we don't know that (yet). This is the reason why I've asked a few of the latest reporters capable of reproducing this error to try VirtualBox 6.1.30 with HVCI disabled in their setups. If we can prove a relationship between HVCI and the SUP_IOCTL_LDR_OPEN failure, we may have a case (*) for the busy VirtualBox developers to go for ...

(*) I know about 20694, but reproducibility is the key here. ;)
fth0
Volunteer
 
Posts: 2765
Joined: 14. Feb 2019, 03:06
Location: Germany
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Linux, Windows 10, ...

Re: Discuss the 6.1.30 release

Postby fth0 » 2. Dec 2021, 01:48

FWIW, I've just reproduced the issue myself, and can confirm that HVCI prevents VirtualBox from loading VMMR0.r0.
fth0
Volunteer
 
Posts: 2765
Joined: 14. Feb 2019, 03:06
Location: Germany
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Linux, Windows 10, ...

Re: Discuss the 6.1.30 release

Postby deckrider » 2. Dec 2021, 15:59

fth0 wrote:FWIW, I've just reproduced the issue myself, and can confirm that HVCI prevents VirtualBox from loading VMMR0.r0.


Thank you!!! The appeal to my admins was going nowhere
deckrider
 
Posts: 5
Joined: 27. Nov 2021, 19:26

Re: Discuss the 6.1.30 release

Postby mtinberg » 2. Dec 2021, 17:48

I experienced this, VMs failed to start after upgrading from 6.1.16 to 6.1.28 with HVCI enabled and while I was able to get the VMs to start on 6.1.30 I was not able to get the Host Only Network adapter driver to load and I needed to disable HVCI to get the Host-Only network driver to load and now it works fine. I'd like to be able to use HVCI, I'm not sure if it was enabled when using 6.1.16 or if it was enabled more recently. The amount of Hyper-V which needs to be active to make WSL2 work doesn't seem to run afoul of HVCI, I'm not sure what those drivers are doing differently.
mtinberg
 
Posts: 1
Joined: 2. Dec 2021, 17:38

Re: Discuss the 6.1.30 release

Postby Oracleiscool » 5. Dec 2021, 03:56

@mtinberg

Just read your post from your work in this release. I was curious if, after you disabled Windows Security Features that were causing VB to crash (or the VM, either or both), once everything was back up and running in VirtualBox, did you ever try to either wholly or selectively re-enable Hyper-V (HCVI), Core isolation, etc. and see if Windows would possibly "skip" the checking routines once the system has the VB and VM data loaded? As a reboot or as a complete system power-off and on? (As a side don't do this on a non backed up production system or a primary device you need... better safe than sorry I think) :)

I am only asking as a curious observer, and Windows has been know in the past for working "backwards" like this on lots of programs that it will allow to run after the initial turn off then back on thing (especially on security, network adapters, graphics drivers, and oh yea.... printers (local and network)) :oops:
Oracleiscool
 
Posts: 53
Joined: 12. Aug 2021, 19:51
Location: US
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: MX21 Ubuntu

Re: Discuss the 6.1.30 release

Postby PeterE » 13. Dec 2021, 02:09

I am disappointed that the bug with the mouse pointers in a Windows XP guest with MS Office is still not fixed.
I once reported it as Ticket #20167.
PeterE
 
Posts: 35
Joined: 10. Dec 2012, 16:13
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Arch Linux, Windows

Next

Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 15 guests