Discuss the 5.2.16 release

This is for discussing general topics about how to use VirtualBox.

Discuss the 5.2.16 release

Postby michael » 17. Jul 2018, 16:39

Discuss the 5.2.16 release here.
You can download the release here.
Mainly a regression-fix release for 5.2.14.
michael
Oracle Corporation
 
Posts: 606
Joined: 10. May 2007, 09:46

Re: Discuss the 5.2.16 release

Postby arQon » 17. Jul 2018, 17:49

michael - you've pasted the 5.2.14 link in there instead.
arQon
 
Posts: 47
Joined: 1. Jan 2017, 09:16
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu 16.04 x64, W7

Re: Discuss the 5.2.16 release

Postby mpack » 17. Jul 2018, 18:05

I've corrected the link in the quote below.

michael wrote:Discuss the 5.2.16 release here.
You can download the release here.
Mainly a regression-fix release for 5.2.14.
mpack
Site Moderator
 
Posts: 27169
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Discuss the 5.2.16 release

Postby michael » 17. Jul 2018, 21:15

Thanks - fixed in my message.
michael
Oracle Corporation
 
Posts: 606
Joined: 10. May 2007, 09:46

Re: Discuss the 5.2.16 release

Postby sej7278 » 18. Jul 2018, 11:24

whilst obviously you can't officially support debian sid, i thought i'd just let you know that due to its dependency on libcurl3, vbox 5.2.16 won't even install on debian sid/buster amd64 but 5.2.14 works fine.

running dpkg -I against the two packages seems to show dependency on libcurl3-gnutls (>= 7.16.2) for 5.2.14, but libcurl3 (>= 7.16.2) for 5.2.16

seems like an error to depend on the non gnutls version - wouldn't that break the update check or whatever you're using curl for?
sej7278
Volunteer
 
Posts: 996
Joined: 5. Sep 2008, 14:40
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Solaris, Linux, Windows, OS/2, MacOSX, FreeBSD

Re: Discuss the 5.2.16 release

Postby michael » 18. Jul 2018, 11:26

Please try the Ubuntu 18.04 package. Ubuntu 18.04 is based on Buster/Sid, so is a better match than Debian Stretch. And Ubuntu 18.04 uses libcurl4.
michael
Oracle Corporation
 
Posts: 606
Joined: 10. May 2007, 09:46

Re: Discuss the 5.2.16 release

Postby michael » 18. Jul 2018, 11:34

Could you please elaborate on why the non-gnutls version should break the update check? My understanding, including from reading what the libcurl authors write, is that the choice of openssl/gnutls is an implementation detail, but you may well know something I do not.
michael
Oracle Corporation
 
Posts: 606
Joined: 10. May 2007, 09:46

Re: Discuss the 5.2.16 release

Postby UliBär » 18. Jul 2018, 11:41

While the 5.2.14 release solved all the audio issues i had with all clients on Windows 7 & 10 hosts,
a sporadic slightly crackling in sound has reappeared with the 5.2.16 release. :(
In all other aspects the update is fine with me. :|
UliBär
 
Posts: 16
Joined: 24. Jan 2018, 11:12
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: WinXP and lots of Linuxes

Re: Discuss the 5.2.16 release

Postby sej7278 » 18. Jul 2018, 15:08

i mistakenly assumed the libcurl3-gnutls version is the only one that supports crypto, not that the libcurl3 version supports openssl

i wouldn't recommend installing the ubuntu 18.04 package for buster users, it seems to have completely broken my systemd setup!!!!!
Last edited by sej7278 on 18. Jul 2018, 15:24, edited 1 time in total.
sej7278
Volunteer
 
Posts: 996
Joined: 5. Sep 2008, 14:40
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Solaris, Linux, Windows, OS/2, MacOSX, FreeBSD

Re: Discuss the 5.2.16 release

Postby michael » 18. Jul 2018, 15:12

michael
Oracle Corporation
 
Posts: 606
Joined: 10. May 2007, 09:46

Re: Discuss the 5.2.16 release

Postby toy dragon » 22. Jul 2018, 02:10

Host Windows home 10 64bit v1803
Guest: Windows 7 64bit sp1
Problem: I have audio issues from any type of audio source, streaming, video clips, mp3, etc.
Description of problem:
1) Using HD Intel audio Perfect audio for the first 11minutes followed by progressive popping and scratching at first followed by incoherent audio that flutters like a misaligned film projector. The stream or video or mp3 needs to be paused for a few second then it returns to normal until another 11 minutes passes by to start the distortion all over again.
2) Using AC'97 Audio Every 20 to 30 seconds the audio skips and mutes for a few second then resumes back to normal for intervals of another 20-30 seconds then repeats the same problem.

Start of the problem:
At the same time I updated Windows from v1607 to v1803 also Updated Virtualbox from v5.1.22 to v5.2.16
I should have installed one at the time to pinpoint which was the culprit, but no.

Solutions tried:
I tried 5.2.x revision 123579, didn't change conditions.
Same problems coming from a Linux Mint Guest.
Changing from 48'000 audio to 44'000 audio didn't fix or change anything.
I would like to reinstall v5.1.22 but I can't launch any hosts. (too noob to know how to roll back VB versions)

Please help
toy dragon
 
Posts: 1
Joined: 22. Jul 2018, 01:31

Re: Discuss the 5.2.16 release

Postby Selin » 22. Jul 2018, 11:13

Have met with CPU load issue...

Host has 6-cores CPU (+6 HT-cores enabled).
Guest has 4-cores assigned.

When guest shows 100% CPU load for all 4 cores, host shows 100% load for 2 cores only.

Before the VBox update CPU load was correlated: i.e. 100% load for 4 cores on guest - 100% load for 4 cores on host.
(Previous version was 5.2.10)
Selin
 
Posts: 60
Joined: 7. Sep 2016, 17:00

Re: Discuss the 5.2.16 release

Postby 0xDEADBEEF » 22. Jul 2018, 12:28

michael wrote:Please try the Ubuntu 18.04 package. Ubuntu 18.04 is based on Buster/Sid, so is a better match than Debian Stretch. And Ubuntu 18.04 uses libcurl4.

So why don't you just provide buster on your debian repo?
0xDEADBEEF
 
Posts: 4
Joined: 20. Jul 2018, 19:34

Re: Discuss the 5.2.16 release

Postby michael » 23. Jul 2018, 09:09

1) Buster is not yet released and we do not yet support it.
2) Every additional build we provide has overhead. If the Ubuntu 18.04 build works with Buster, what's the problem? People were using the Debian 8 build with it up until now.
michael
Oracle Corporation
 
Posts: 606
Joined: 10. May 2007, 09:46

Re: Discuss the 5.2.16 release

Postby 0xDEADBEEF » 23. Jul 2018, 10:49

michael wrote:1) Buster is not yet released and we do not yet support it.
2) Every additional build we provide has overhead. If the Ubuntu 18.04 build works with Buster, what's the problem? People were using the Debian 8 build with it up until now.


For 1) True, I understand that.
For 2) There might be people being uncomfortable with introducing inconsistencies by mixing up Debian and Ubuntu packages on their systems because Ubuntu packages are known to often break other stuff on Debian, especially on Testing. That's a downside. Regarding overhead, why don't you just drop support (and manpower) for Lenny btw.? I assume there are very few people still using Lenny anyway, it's EOL since 2012-06-02.

Nevertheless, up until now, the stretch repo version used to work flawlessly (in sense of installation or upgrade) so what's the problem with building the package against libcurl4 from now on?
0xDEADBEEF
 
Posts: 4
Joined: 20. Jul 2018, 19:34

Next

Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 11 guests